E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > Brake squeak



Reply
 
Thread Tools Search this Thread
      01-24-2013, 09:25 PM   #1
Robert428
New Member
 
Drives: E90 335i
Join Date: Jan 2013
Location: Tampa, FL

Posts: 22
iTrader: (0)

Brake squeak

Rear passenger side brake squeaks/chirp at low speed without applying the brake???...around 5-10mph
Robert428 is offline  
0
Reply With Quote
      01-24-2013, 10:42 PM   #2
Florida Boy
Captain
 
Drives: TiAg 325i, oem 359m
Join Date: Dec 2009
Location: Orlando

Posts: 632
iTrader: (7)

I am having the same issue. I put on ceramic pads. Did you do anything... Install pads?
Florida Boy is offline   United_States
0
Reply With Quote
      01-24-2013, 11:40 PM   #3
e679
Private First Class
 
e679's Avatar
 
Drives: E93
Join Date: Dec 2011
Location: Hong Kong

Posts: 117
iTrader: (0)

I had it too. Squeaks worst when turning left.
__________________
E93 335i Alpine White, 19" Works, PSS, M3 arms, M3 bushings,M3 E93 FSB/E92 RSB, powerflex rear diff bush.
AST 5100 with M3 rear camber arms. GC street plates.
e679 is offline   Hong Kong
0
Reply With Quote
      01-24-2013, 11:45 PM   #4
e90335iftw
First Lieutenant
 
Drives: 335i
Join Date: Jan 2013
Location: Canada

Posts: 358
iTrader: (0)

My car does the same. Took it to the dealership, they basically said it's normal and to deal with it.
e90335iftw is offline  
0
Reply With Quote
      01-25-2013, 02:37 AM   #5
Phil325i
Major
 
Phil325i's Avatar
 
Drives: E92 325i MSport Coupe
Join Date: Apr 2012
Location: UK South East

Posts: 1,125
iTrader: (0)

Garage List
It'll be the pad wear sensor.
__________________
E92 pre-LCI 325i - Ohlins R&T; H&R spacers; M3 strut brace; Meyle HD droplinks; BMS clutch stop; BMS CDV; RE g/box mounts; Saikoumichi OCC; K&N; Cyba scoops; BMW Perf Exhaust; M3 rear spoiler; M3 white dash LEDs; LED Angels; BMW Perf black grille; CSL reps; SSDD carbon diffuser; Monster Wrap black roof
Phil325i is offline   United Kingdom
0
Reply With Quote
      01-25-2013, 12:26 PM   #6
Robert428
New Member
 
Drives: E90 335i
Join Date: Jan 2013
Location: Tampa, FL

Posts: 22
iTrader: (0)

Quote:
Originally Posted by Florida Boy
I am having the same issue. I put on ceramic pads. Did you do anything... Install pads?
No I didn't change any pads yet since I got the car a few months ago. But yes it's very annoying
Robert428 is offline  
0
Reply With Quote
      01-25-2013, 12:45 PM   #7
TitanLH8
Lieutenant
 
TitanLH8's Avatar
 
Drives: 07 E90 335i
Join Date: Feb 2011
Location: NoVA

Posts: 401
iTrader: (3)

http://www.e90post.com/forums/showthread.php?t=526765
TitanLH8 is offline   United_States
0
Reply With Quote
      01-26-2013, 09:42 AM   #8
ndukyh
The Tanzanian
 
ndukyh's Avatar
 
Drives: 2 feet (for now)
Join Date: Jan 2012
Location: Boston, MA

Posts: 477
iTrader: (8)

I don't think anyone has definitively figured this out. Different solutions work for different people for varying amounts of time but it seems like inevitably it comes back. Tons of posts on this, good luck. I have the squeal but I've given up thinking about it
ndukyh is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:51 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST