E90Post
 


E92-lighting
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > Need some Help with Resetting Micro Filter error after coding.



Reply
 
Thread Tools Search this Thread
      10-12-2012, 04:48 PM   #1
Laosboixx781
Private
 
Laosboixx781's Avatar
 
Drives: 07 Titanium M-Silver 328XI
Join Date: Jun 2010
Location: Boston, MA

Posts: 93
iTrader: (1)

Send a message via AIM to Laosboixx781 Send a message via Skype™ to Laosboixx781
So I was able to code my E92 to close the windows and side mirrors with my key fob, turn the fog lights on upon unlocking and done the corner deletes, and disabled the gong when the key is in All Successful YEAH!! Pretty stoked about that. But to my surprise I received a micro filter service warning after coding!! Done my searches through the forums, performed the services reset through the instrument cluster and get the same results. So finally I gave up. I took the car in to see the dealer... after 2 hours My SA informed me that they can't get the error to reset, even with them disconnecting the battery. So they gave me a loaner for the time being until they can figure out the issue. I am reaching out to the CODERS to see if there is anything I can do to code this error out. ALL help is appreciated. Thanks.

Last edited by Laosboixx781; 10-16-2012 at 11:40 AM.
Laosboixx781 is offline   United_States
0
Reply With Quote
      10-13-2012, 09:26 AM   #2
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: 917-939-4980
Join Date: Jun 2007
Location: New York

Posts: 18,255
iTrader: (5)

Send a message via Yahoo to cn555ic
Why don't you try to code the Kombi back to default values using expertmode.
__________________

Coding E and F New York 917-939-4980
cn555ic is offline   United_States
0
Reply With Quote
      10-13-2012, 09:51 AM   #3
Laosboixx781
Private
 
Laosboixx781's Avatar
 
Drives: 07 Titanium M-Silver 328XI
Join Date: Jun 2010
Location: Boston, MA

Posts: 93
iTrader: (1)

Send a message via AIM to Laosboixx781 Send a message via Skype™ to Laosboixx781
Thanks. I will give it a shot once I get my car back from the dealer
__________________
2007 Titanium Metallic Silver 328XI // Sport Package // Premium Package // Winter Package // 7 Pro Logic //Navi //Madico 35% Tint all around //GP Thunder 7500K V2 Fogs//City Vision AE's//
Laosboixx781 is offline   United_States
0
Reply With Quote
      10-16-2012, 12:32 AM   #4
Laosboixx781
Private
 
Laosboixx781's Avatar
 
Drives: 07 Titanium M-Silver 328XI
Join Date: Jun 2010
Location: Boston, MA

Posts: 93
iTrader: (1)

Send a message via AIM to Laosboixx781 Send a message via Skype™ to Laosboixx781
So here is a little update so I got my car back today from the dealer... So my SA tells me that after attempting to reset the micro filter error for 3 days they were able to clear it only by updating my software for my car (at no charge). He says the software was 3 years old. As i go through the i drive menu everything appears to be the same. How can I tell if the software has been updated? The only problem now is that all the coding that I had preformed no longer works, I am a little skeptical at this point about coding my car. Although I did figure out that I screwed up in the first place I uploaded the work folder with the original posters E46 PROFILE without over writing his profile with my car profile first
__________________
2007 Titanium Metallic Silver 328XI // Sport Package // Premium Package // Winter Package // 7 Pro Logic //Navi //Madico 35% Tint all around //GP Thunder 7500K V2 Fogs//City Vision AE's//
Laosboixx781 is offline   United_States
0
Reply With Quote
      10-16-2012, 11:36 AM   #5
Laosboixx781
Private
 
Laosboixx781's Avatar
 
Drives: 07 Titanium M-Silver 328XI
Join Date: Jun 2010
Location: Boston, MA

Posts: 93
iTrader: (1)

Send a message via AIM to Laosboixx781 Send a message via Skype™ to Laosboixx781
Bit the Bullet recorded everything No Error Successful Coding..
__________________
2007 Titanium Metallic Silver 328XI // Sport Package // Premium Package // Winter Package // 7 Pro Logic //Navi //Madico 35% Tint all around //GP Thunder 7500K V2 Fogs//City Vision AE's//
Laosboixx781 is offline   United_States
0
Reply With Quote
      10-16-2012, 12:25 PM   #6
markusvt
New Member
 
Drives: 2009 335i
Join Date: Sep 2012
Location: vermont

Posts: 23
iTrader: (0)

Garage List
2009 335i  [0.00]
What/where did you find the best procedure for the first timer? I have my cable and am ready to go. Got the 2012 maps stuff all installed no problem, now the coding.

Quote:
Originally Posted by Laosboixx781 View Post
So I was able to code my E92 to close the windows and side mirrors with my key fob, turn the fog lights on upon unlocking and done the corner deletes, and disabled the gong when the key is in All Successful YEAH!! Pretty stoked about that. But to my surprise I received a micro filter service warning after coding!! Done my searches through the forums, performed the services reset through the instrument cluster and get the same results. So finally I gave up. I took the car in to see the dealer... after 2 hours My SA informed me that they can't get the error to reset, even with them disconnecting the battery. So they gave me a loaner for the time being until they can figure out the issue. I am reaching out to the CODERS to see if there is anything I can do to code this error out. ALL help is appreciated. Thanks.
markusvt is offline  
0
Reply With Quote
      10-16-2012, 01:02 PM   #7
Laosboixx781
Private
 
Laosboixx781's Avatar
 
Drives: 07 Titanium M-Silver 328XI
Join Date: Jun 2010
Location: Boston, MA

Posts: 93
iTrader: (1)

Send a message via AIM to Laosboixx781 Send a message via Skype™ to Laosboixx781
I followed the DIY from the first BMW coding success thread down to the T, only problem is that I made a stupid mistake by copying the wrong FS_PW man file from the original folder when I extracted thathe NCS expert work folder, although I failed to mention that the second time around I didn't code the door gong because that would reset your ECU. Here is a small list of what I did code: (BASIC) I am not a pro at this yet
close windows w/fob
fold side mirrors w/fob
fog lights on when unlocking corner LED delete
__________________
2007 Titanium Metallic Silver 328XI // Sport Package // Premium Package // Winter Package // 7 Pro Logic //Navi //Madico 35% Tint all around //GP Thunder 7500K V2 Fogs//City Vision AE's//
Laosboixx781 is offline   United_States
0
Reply With Quote
      10-20-2012, 02:34 PM   #8
07e92
Private
 
Drives: 07 335i
Join Date: Jul 2012
Location: N CAL

Posts: 85
iTrader: (3)

Same here, after car was coded, micro filter service warning comes up, was not able to reset it because the date and mileage are all showing dashes (no due date and mileage due). It is annoying, but I have lived with that since then.
07e92 is offline   United_States
0
Reply With Quote
      10-20-2012, 06:08 PM   #9
Laosboixx781
Private
 
Laosboixx781's Avatar
 
Drives: 07 Titanium M-Silver 328XI
Join Date: Jun 2010
Location: Boston, MA

Posts: 93
iTrader: (1)

Send a message via AIM to Laosboixx781 Send a message via Skype™ to Laosboixx781
Quote:
Originally Posted by 07e92 View Post
Same here, after car was coded, micro filter service warning comes up, was not able to reset it because the date and mileage are all showing dashes (no due date and mileage due). It is annoying, but I have lived with that since then.
Dag bro. that sux that annoyed the shit out of me for the first 5 times i started the car lol, but yea the dealer updated my software and the error was wiped out.. I guess they updated my software because they couldn't reset the error themselves. Have you tried to recode back to default like CN555IC said on the reply?
__________________
2007 Titanium Metallic Silver 328XI // Sport Package // Premium Package // Winter Package // 7 Pro Logic //Navi //Madico 35% Tint all around //GP Thunder 7500K V2 Fogs//City Vision AE's//
Laosboixx781 is offline   United_States
0
Reply With Quote
      10-20-2012, 08:59 PM   #10
charles.soori
Second Lieutenant
 
Drives: e90 08 328i
Join Date: Apr 2011
Location: canada

Posts: 216
iTrader: (1)

My micro filter service disappeared after coding never bothered to get it back.
charles.soori is offline   Canada
0
Reply With Quote
      10-20-2012, 09:51 PM   #11
07e92
Private
 
Drives: 07 335i
Join Date: Jul 2012
Location: N CAL

Posts: 85
iTrader: (3)

Not sure how to use expertmode that CN555IC mentioned. May be he can chime in. I have lived with this for a few months

Quote:
Originally Posted by Laosboixx781 View Post
Dag bro. that sux that annoyed the shit out of me for the first 5 times i started the car lol, but yea the dealer updated my software and the error was wiped out.. I guess they updated my software because they couldn't reset the error themselves. Have you tried to recode back to default like CN555IC said on the reply?
07e92 is offline   United_States
0
Reply With Quote
      10-20-2012, 09:52 PM   #12
07e92
Private
 
Drives: 07 335i
Join Date: Jul 2012
Location: N CAL

Posts: 85
iTrader: (3)

Lucky you

Quote:
Originally Posted by charles.soori View Post
My micro filter service disappeared after coding never bothered to get it back.
07e92 is offline   United_States
0
Reply With Quote
      10-20-2012, 10:08 PM   #13
e90sexion
E 9 0 S E X I O N
 
e90sexion's Avatar
 
Drives: like old times
Join Date: Sep 2006
Location: Vancouver/WA

Posts: 6,151
iTrader: (16)

whenever you do the software update by dealer, all the errors are supposed to be gone I guess???
I had Recaro Pole position, and had lived with the air bag light / passenger restraint system malfunction.
Now, I have put stock seat back, I still have those lights.
__________________
2008 AW e92 M3
RPI | H&R | 2008 IB e86 M coupe (sold)
KW | VOLK TE37SL | RECARO | PE - 2008 AW e92 335xi (sold)
e90sexion is offline   Canada
0
Reply With Quote
      10-20-2012, 10:25 PM   #14
Laosboixx781
Private
 
Laosboixx781's Avatar
 
Drives: 07 Titanium M-Silver 328XI
Join Date: Jun 2010
Location: Boston, MA

Posts: 93
iTrader: (1)

Send a message via AIM to Laosboixx781 Send a message via Skype™ to Laosboixx781
Quote:
Originally Posted by 07e92 View Post
Not sure how to use expertmode that CN555IC mentioned. May be he can chime in. I have lived with this for a few months
i think what he is saying is that when you load the profile for NCS you choose expert mode instead of your FS PSW.MAN file then you go back and changed the values that have you changed back to default.. i could be wrong the dealer fixed it before i could try it.

__________________
2007 Titanium Metallic Silver 328XI // Sport Package // Premium Package // Winter Package // 7 Pro Logic //Navi //Madico 35% Tint all around //GP Thunder 7500K V2 Fogs//City Vision AE's//

Last edited by Laosboixx781; 10-20-2012 at 10:30 PM.
Laosboixx781 is offline   United_States
0
Reply With Quote
      12-31-2012, 02:04 PM   #15
spottv
New Member
 
Drives: bmw 335i coupe
Join Date: Jun 2012
Location: South Africa

Posts: 8
iTrader: (0)

microfilter error

were u guys able to solve this problem, i have a e92 2009 335i that has the same error after coding.Local dealer also has no idea but needs the car for a day or two. Any help appreciated
spottv is offline  
0
Reply With Quote
      03-05-2013, 02:54 AM   #16
nv_e92
Modding & Detailing Rookie
 
nv_e92's Avatar
 
Drives: 2008 Space Gray Metallic E92
Join Date: Apr 2011
Location: El Paso, TX

Posts: 96
iTrader: (0)

Garage List
Talking

Ok guys I finally figured this out with the help of NCS Dummy. I hope this helps anyone still looking.

In NCS expert, read your KOMBI module and open the PSW_FSW.TRC file and look for CBS_STAT_04H. Change from anzeige to sperre. Save as MAN file. Execute SG_CODERIEN & boom, no more microfilter service warning.

Happy Coding!
__________________
2008 328i e92 | Space Gray | Coral Red | Aero Lip | StopTech Slotted Rotors | StopTech Street Performance Brake Pads | OEM 359M Wheels
nv_e92 is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:48 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST