E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > windshield wiper arm out of position



Reply
 
Thread Tools Search this Thread
      01-27-2013, 09:45 PM   #1
07lilredwagon
Lieutenant
07lilredwagon's Avatar
7
Rep
525
Posts

 
Drives: 07 328 wagon
Join Date: Dec 2012
Location: New York

iTrader: (0)

windshield wiper arm out of position

So I just readjusted my drivers side wiper arm as it looks to have slipped down and was not only rubbing on the other wiper when they first started moving, causing a loud noise as the rubber blade bounced across the glass, but I also could not lift the arm up for cleaning as it would hit the hood!........

It appears that the bolt became just loose enough for the arm to slip on the post....I think this may be common, so check the tightness of your wiper arm bolts.

1) Open the hood
2) pull off the wiper arm nut cover
3) loosen and take the nut off, wiggle the arm off and clean everything really well, us a little lithium grease where the splines are, and reposition the arm. The blade should line up with the black area of the glass just underneath the arm. It should also line up with the other wiper arm and blade.
4) tighten the nut snug and then a little bit more...dont overdo it!
5) put the cap back on
6) test the wiper action...the arm should clean all the way to just shy of the edge of the glass by the pillar. It will no longer interfere with the other arm.

Its a simple one, but will hopefully prevent any damage to the splines in the arm or the post of the wiper motor, ect....I have a couple of nicks in the paint on the backside of the hood to fix from the last owner trying to pry the wiper arm up while it was out of place.

Forgot to take pics, but can do that if needed...

JP
Appreciate 0
      01-27-2013, 10:21 PM   #2
Higgs1
Lieutenant
Higgs1's Avatar
United_States
11
Rep
423
Posts

 
Drives: E90 330i
Join Date: Nov 2008
Location: Boston, MA

iTrader: (7)

Garage List
2006 330i  [5.00]
Send a message via AIM to Higgs1
thanks Im going to try this at some point this week. My passenger side arm seems to low, I can't pull it forward as it keeps hitting my hood
__________________
06 E90 330i
Alpine White | Terra Dakota Leather | Carbon Fiber Trim | ZSP | ZPP | ZCW | Navi | PDC
Sirius Radio | Xenon | GP Thunder 7500k Fogs | Lux 5.0 Angel Eyes | 18% Tint | Blacklines
Appreciate 0
      01-28-2013, 10:27 PM   #3
07lilredwagon
Lieutenant
07lilredwagon's Avatar
7
Rep
525
Posts

 
Drives: 07 328 wagon
Join Date: Dec 2012
Location: New York

iTrader: (0)

Quote:
Originally Posted by Higgs1 View Post
thanks Im going to try this at some point this week. My passenger side arm seems to low, I can't pull it forward as it keeps hitting my hood
Thats exactly what mine was doing....I think these things work themselves loose!

JP
Appreciate 0
      01-29-2013, 05:41 AM   #4
John 070
Lieutenant General
157
Rep
11,506
Posts

 
Drives: 335i cpe
Join Date: Oct 2006
Location: ZSP/ZPP/ZCW

iTrader: (0)

I dunno if you fellas have had your windshields replaced, but usually the guy doing the glass f's up the wiper arms, and that's why it happens, imho.....
Appreciate 0
      01-29-2013, 08:51 AM   #5
rclee820
Enlisted Member
1
Rep
37
Posts

 
Drives: 2010 335i xDrive
Join Date: Jan 2013
Location: Stamford, CT

iTrader: (1)

Quote:
Originally Posted by Higgs1 View Post
thanks Im going to try this at some point this week. My passenger side arm seems to low, I can't pull it forward as it keeps hitting my hood
I had the same issue. My passenger-side wiper arm was actually overlapping the edge of the windshield.
Appreciate 0
      03-16-2013, 12:36 PM   #6
MZHammer
First Lieutenant
MZHammer's Avatar
Canada
4
Rep
359
Posts

 
Drives: Z4MR
Join Date: Sep 2010
Location: Hamilton

iTrader: (2)

Just had my windshield replaced and now the wipers are too low, in the rest position and don't sweep as wide as they used to. I'll have to try this fix. Thanks guys.
Appreciate 0
      03-16-2013, 09:32 PM   #7
07lilredwagon
Lieutenant
07lilredwagon's Avatar
7
Rep
525
Posts

 
Drives: 07 328 wagon
Join Date: Dec 2012
Location: New York

iTrader: (0)

one note....remove the bolt covers on your wiper arms carefully...the mar easily....in theory they just pull off...


JP
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:01 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST