E90Post
 


E92-lighting
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Mileage trip and clock resetting on it's own on cold start



Reply
 
Thread Tools Search this Thread
      01-28-2013, 07:18 PM   #1
SebringS2k
Private First Class
 
Drives: '08 E92 335i 6MT
Join Date: Nov 2006
Location: Wilmington

Posts: 181
iTrader: (0)

Mileage trip and clock resetting on it's own on cold start

hey guys

Recently, when I start my car in the morning or when I leave from work, the trip resets back to 0.00 and the clock nulls out, also the Service Light (Car on lift image) shows up. But, when I look in my service menu, the Service Light is not for another 19k miles. The car starts/drives fine otherwise, and radio settings and power seat settings are the same...just the trip and clock resets, any ideas? It's happened about 4 times in the last week or so

It's been rather cold here on the east coast, so not sure if that's causing the issue...also my comfort access has been not working at times, when before it always opened when I put my hand on the handle. I have an '08 E92 335i, 40k miles, manual if that makes a diff. I'm out of warranty, so rather not deal with the stealership, but I do have CPO (useless?)

Thanks in advance.

Last edited by SebringS2k; 01-28-2013 at 07:28 PM.
SebringS2k is offline  
0
Reply With Quote
      01-28-2013, 09:02 PM   #2
TheeGovernor
Life is better with burnouts
 
TheeGovernor's Avatar
 
Drives: BMW
Join Date: Dec 2011
Location: Mile High

Posts: 243
iTrader: (2)

Garage List
2007 BMW 335i  [0.00]
sounds like a dying car battery. How long since it was last replaced?
TheeGovernor is offline  
0
Reply With Quote
      01-28-2013, 09:08 PM   #3
Richurd
Captain
 
Richurd's Avatar
 
Drives: Too slow.
Join Date: Jul 2009
Location: nyc

Posts: 638
iTrader: (6)

Your car is shutting down unnecessary things right now so you have just enough juice to start your car.
__________________
07 e92 335i | BSM | SB | Gray Poplar Wood Trim | 6MT | Premium | Sport | Cold Weather | iDrive | Logic7 | Comfort Access |
Richurd is offline   United_States
0
Reply With Quote
      01-28-2013, 09:42 PM   #4
cmyk
resident girl.
 
cmyk's Avatar
 
Drives: 2008 335i
Join Date: Dec 2011
Location: Dallas, Texas

Posts: 1,016
iTrader: (1)

Garage List
2008 BMW 335i  [4.38]
^^ what they said. Classic failing battery symptoms. The 08s are nearing their expected lifespan of the original battery. Time to get it replaced. Luckily these cars tend to give us a few warning signs instead of just randomly leaving us stranded in a parking lot one day
__________________


2008 E90 335i // Black Everything // photos
COBB tuned / QTP e-cutouts / Helix FMIC / cp-e DCI / AWE BOVs / Black M6 wheels + Toyo Proxes
(and yes, I am a girl)
cmyk is offline   United_States
0
Reply With Quote
      01-28-2013, 10:46 PM   #5
SebringS2k
Private First Class
 
Drives: '08 E92 335i 6MT
Join Date: Nov 2006
Location: Wilmington

Posts: 181
iTrader: (0)

oh wow, didn't know that, glad I asked on here...far as I know, it's on the original battery. how much does a bmw battery run? this is my first bmw
SebringS2k is offline  
0
Reply With Quote
      01-28-2013, 10:48 PM   #6
Verbatim
Colonel
 
Verbatim's Avatar
 
Drives: 2008 335i
Join Date: Sep 2010
Location: at the repair shop

Posts: 2,555
iTrader: (0)

Garage List
2008 BMW 335i  [5.00]
that's the sign for a battery check
if you get the code through the dash, you'll see what the specific service is for
there was a thread that recently floated up on this board with a pdf file of all the in-dash indicator meanings when you get a little code off the screen

but yeah... i went through the same thing. your battery should probably be replaced
__________________

2008 BMW 335i Sedan | Sparkling Graphite | Sport | Premium | Navigation | Comfort Access | Logic7
Golf Tee | M3 Spoiler | LED Angel Eyes | 5000k Fogs | Resonator Delete | Black Kidney Grills | Black Finisher Rods | 35%/18% Tint |12mm/20mm (F/R) Spacers | Black Lines


Verbatim is offline   United_States
0
Reply With Quote
      01-28-2013, 10:58 PM   #7
SebringS2k
Private First Class
 
Drives: '08 E92 335i 6MT
Join Date: Nov 2006
Location: Wilmington

Posts: 181
iTrader: (0)

I see thanks, though I'm not getting a battery sign in my dash (non-idrive), just the 'service light'?
SebringS2k is offline  
0
Reply With Quote
      01-28-2013, 11:57 PM   #8
Richurd
Captain
 
Richurd's Avatar
 
Drives: Too slow.
Join Date: Jul 2009
Location: nyc

Posts: 638
iTrader: (6)

If you don't have iDrive, the battery would not cost as one that has an iDrive.
__________________
07 e92 335i | BSM | SB | Gray Poplar Wood Trim | 6MT | Premium | Sport | Cold Weather | iDrive | Logic7 | Comfort Access |
Richurd is offline   United_States
0
Reply With Quote
      01-29-2013, 09:47 PM   #9
SebringS2k
Private First Class
 
Drives: '08 E92 335i 6MT
Join Date: Nov 2006
Location: Wilmington

Posts: 181
iTrader: (0)

just an update, started the car this morning, and everything was normal, so I'm thinking it's definitely weather related (45 degrees), gonna monitor it over the next couple days
SebringS2k is offline  
0
Reply With Quote
      01-29-2013, 11:42 PM   #10
Fastfission
New Member
 
Drives: 328xi sedan monaco blue
Join Date: Jun 2012
Location: southern Idaho

Posts: 6
iTrader: (0)

My 2008 has been doing the same thing lately. I do mostly short (about 5 mile) commutes, and I've found that this doesn't let the battery get charged. A few hours a week on the charger, or a quick 20-30 mile run on the freeway seems to get things back to normal, at least for about a week. I am planning to get a battery minder, and I figure that there's probably a battery in my future this summer.

The cold weather does reduce battery capacity (we've been mostly around -15-20F for the past month).
Fastfission is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:43 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST