E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > 335is owners jb4 help e85



Reply
 
Thread Tools Search this Thread
      07-07-2012, 01:34 PM   #1
busta7777
Captain
United_States
11
Rep
641
Posts

 
Drives: RB N54 335iS
Join Date: Apr 2010
Location: Downey

iTrader: (4)

Send a message via AIM to busta7777 Send a message via Yahoo to busta7777
335is owners jb4 help e85

Ok so ive been putting e85 on my car i put around 8 gallons of 91 an 3 gallons of e85
On map 5 car is hitting 15 psi almost the whole way
On map 6 it hit 16-17 psi its crazy lol
Anyways
Car runs perfect couldent ask for more speed yet

But alot of times when im doing strong pulls the car on any map after a few strong runs of 2nd an 3rd it starts to only boosting 10 psi the whole time until i turn it off
Is their a reason this is happening?
Wat can i do to fix this
Its gettig really ennoying im
Really thinking of just not putting e85 since most of the time it happens on e85
Appreciate 0
      07-07-2012, 01:36 PM   #2
busta7777
Captain
United_States
11
Rep
641
Posts

 
Drives: RB N54 335iS
Join Date: Apr 2010
Location: Downey

iTrader: (4)

Send a message via AIM to busta7777 Send a message via Yahoo to busta7777
Quote:
Originally Posted by busta7777 View Post
Ok so ive been putting e85 on my car i put around 8 gallons of 91 an 3 gallons of e85
On map 5 car is hitting 15 psi almost the whole way
On map 6 it hit 16-17 psi its crazy lol
Anyways
Car runs perfect couldent ask for more speed yet

But alot of times when im doing strong pulls the car on any map after a few strong runs of 2nd an 3rd it starts to only boosting 10 psi the whole time until i turn it off
Is their a reason this is happening?
Wat can i do to fix this
Its gettig really ennoying im
Really thinking of just not putting e85 since most of the time it happens on e85
Mods:
jb4 with newst update
Appreciate 0
      07-07-2012, 01:42 PM   #3
335iSSA
Captain
Poland
8
Rep
603
Posts

 
Drives: 07' E92 335i
Join Date: Nov 2009
Location: Frederick, MD

iTrader: (10)

Likely pulling back because IATs are getting high. FMIC or meth will help.
Appreciate 0
      07-07-2012, 02:01 PM   #4
Bagelfast
Lieutenant Colonel
Bagelfast's Avatar
40
Rep
1,537
Posts

 
Drives: BMW
Join Date: Sep 2008
Location: USA

iTrader: (0)

Any codes?

Have you tried doing logs? Send them to Terry.
Appreciate 0
      07-07-2012, 02:55 PM   #5
chili36
Lieutenant
4
Rep
461
Posts

 
Drives: 335i
Join Date: Dec 2007
Location: So.Cal

iTrader: (1)

Heatsoak.
Appreciate 0
      07-07-2012, 03:11 PM   #6
Gugs
Cynical
Gugs's Avatar
United_States
4
Rep
431
Posts

 
Drives: E92 JetBlack
Join Date: Jul 2012
Location: Long island

iTrader: (1)

The answer is-
Your overboosting or knocking.

With the newer firmwares we have new features...

The Jb4 goes into safety mode and forces itself into map 4 until you restart the car.
look for flashing check engine lights right before it happens, 1 flash is overboost and several is knock.

This is exactly what is happening-
as its defaulting to map 4 and leaving you to OEM map/boost levels.


Put in less e85 and it will most likely help the issue.
Appreciate 0
      07-07-2012, 04:06 PM   #7
robc1976
DIYER
robc1976's Avatar
77
Rep
4,719
Posts

 
Drives: E90 335i
Join Date: Mar 2012
Location: Illinois

iTrader: (11)

Quote:
Originally Posted by Gugs View Post
The answer is-
Your overboosting or knocking.

With the newer firmwares we have new features...

The Jb4 goes into safety mode and forces itself into map 4 until you restart the car.
look for flashing check engine lights right before it happens, 1 flash is overboost and several is knock.

This is exactly what is happening-
as its defaulting to map 4 and leaving you to OEM map/boost levels.


Put in less e85 and it will most likely help the issue.
Spot on...seen it before with my buddies car...
__________________
JB4 G5, WEDGE flash, 455 LPFP, HFS-4 meth kit, BMS OCC, Motiv 750 ST, RB valve, BMS DCI, 3" AR Dps, Custom OC W/ SS lines, ER FMIC, ER CP W/HKS BOV, M3 control arms, M3 guide rods, M3 upper links, M3 front & rear sway-bars, HPA rear toe arms, Wavetrac LSD, HPF Gen 2 exhaust DEFIV kit, KW clubsport, Delrin solid subframe bushings, stoptech rotors, Rogue Tranny Mounts, 1M bumper, M3 CF hood, MORR VS8.2 rims 245/295
Appreciate 0
      07-07-2012, 04:31 PM   #8
Pete Schweaty
Captain
Pete Schweaty's Avatar
6
Rep
605
Posts

 
Drives: 2007 335i E90
Join Date: Jun 2011
Location: MD

iTrader: (0)

Quote:
Originally Posted by Gugs View Post
The answer is-
Your overboosting or knocking.

With the newer firmwares we have new features...

The Jb4 goes into safety mode and forces itself into map 4 until you restart the car.
look for flashing check engine lights right before it happens, 1 flash is overboost and several is knock.

This is exactly what is happening-
as its defaulting to map 4 and leaving you to OEM map/boost levels.


Put in less e85 and it will most likely help the issue.
Yup. The JB4 reverts to stock mapping as a safety feature. The stock boost for a 335is is 10psi.
Appreciate 0
      07-08-2012, 12:59 AM   #9
TheKid
Private First Class
TheKid's Avatar
2
Rep
122
Posts

 
Drives: e92 335is
Join Date: Nov 2010
Location: Toronto

iTrader: (2)

I was having the same issue on my 335is, increase your boost limit to 17.5 or 18... map 5 on 94+ octane I was hitting 17.3 psi tapering down to 13.8... your most likely over boosting.. hope this works
__________________
COBB PROTUNE/HFS4/AFE STG 2 DCI/ BMS OCC/AR 3" C*tless DPs/ER CP/Forge DV's/ Eibach Pro springs/M3 suspension bits/CF rear diffuser/ 30% tints / Lightly smoked tails/ Blacked out grill /SSP clutches
Appreciate 0
      07-08-2012, 04:09 AM   #10
boostaholic786
Lieutenant
boostaholic786's Avatar
6
Rep
564
Posts

 
Drives: E92 JB4 G5 ISO RB's FBO+40%E85
Join Date: Dec 2011
Location: irving tx

iTrader: (0)

It might be a 2D25 (mass air manipulation cover, maximum air) or something like that. If you dont want to decrease your E85 mix, just go to the user adjustment table, set futureuserA= 2, then change fuel open loop mapping to 75 or set it to 5 more than you have it set to. I had this exact same issue and it gets really annoying. But make sure you set your overboost to 18.0 as well because with the E85, you will hit that much boost, well depending on your mods
__________________
A/W E92 335i M-sport with JB4 G5 ISO/ E40 WEDGE PERFORMANCE BACKEND FLASH, Alpina TCU flash for AT/Switch-tronic +AR Downpipes, Stett gen 1 intake, Wagner-Tuning FMIC+RB Turbo setup/ RB PCV Valve+ Akro exhaust+60% E85/93 mix,+ HRE P40S wheels, KW coilovers, M3 sways,+BMW performance CF Mirrors, BMW Performance CF deck lid spoiler,+ CF interior trim, p3 vent boost gauge,+ LUX angel eyes (11.73@119mph on street tires) NO METH!
Appreciate 0
      07-08-2012, 02:06 PM   #11
busta7777
Captain
United_States
11
Rep
641
Posts

 
Drives: RB N54 335iS
Join Date: Apr 2010
Location: Downey

iTrader: (4)

Send a message via AIM to busta7777 Send a message via Yahoo to busta7777
Quote:
Originally Posted by TheKid View Post
I was having the same issue on my 335is, increase your boost limit to 17.5 or 18... map 5 on 94+ octane I was hitting 17.3 psi tapering down to 13.8... your most likely over boosting.. hope this works
Thanks for the help how are u changing
The setting for over boost is this like a usb must?
Appreciate 0
      07-08-2012, 02:10 PM   #12
robc1976
DIYER
robc1976's Avatar
77
Rep
4,719
Posts

 
Drives: E90 335i
Join Date: Mar 2012
Location: Illinois

iTrader: (11)

Quote:
Originally Posted by boostaholic786 View Post
It might be a 2D25 (mass air manipulation cover, maximum air) or something like that. If you dont want to decrease your E85 mix, just go to the user adjustment table, set futureuserA= 2, then change fuel open loop mapping to 75 or set it to 5 more than you have it set to. I had this exact same issue and it gets really annoying. But make sure you set your overboost to 18.0 as well because with the E85, you will hit that much boost, well depending on your mods
The map (assuming you are referring to map 5) is what governs the boost...it is possible to over boost to 18 though. I had the code above and just cut back to 45% instead of 50% and there is really no difference in performance. I may go back to 50% but I only get these codes once in a while so not Thst big of a deal.
__________________
JB4 G5, WEDGE flash, 455 LPFP, HFS-4 meth kit, BMS OCC, Motiv 750 ST, RB valve, BMS DCI, 3" AR Dps, Custom OC W/ SS lines, ER FMIC, ER CP W/HKS BOV, M3 control arms, M3 guide rods, M3 upper links, M3 front & rear sway-bars, HPA rear toe arms, Wavetrac LSD, HPF Gen 2 exhaust DEFIV kit, KW clubsport, Delrin solid subframe bushings, stoptech rotors, Rogue Tranny Mounts, 1M bumper, M3 CF hood, MORR VS8.2 rims 245/295
Appreciate 0
      07-08-2012, 02:11 PM   #13
robc1976
DIYER
robc1976's Avatar
77
Rep
4,719
Posts

 
Drives: E90 335i
Join Date: Mar 2012
Location: Illinois

iTrader: (11)

Quote:
Originally Posted by busta7777 View Post
Thanks for the help how are u changing
The setting for over boost is this like a usb must?
Yep, USB to lap tob under "user adjustments" very first adjustment"
__________________
JB4 G5, WEDGE flash, 455 LPFP, HFS-4 meth kit, BMS OCC, Motiv 750 ST, RB valve, BMS DCI, 3" AR Dps, Custom OC W/ SS lines, ER FMIC, ER CP W/HKS BOV, M3 control arms, M3 guide rods, M3 upper links, M3 front & rear sway-bars, HPA rear toe arms, Wavetrac LSD, HPF Gen 2 exhaust DEFIV kit, KW clubsport, Delrin solid subframe bushings, stoptech rotors, Rogue Tranny Mounts, 1M bumper, M3 CF hood, MORR VS8.2 rims 245/295
Appreciate 0
      07-08-2012, 04:21 PM   #14
Yodaime
Just a normal member.
Yodaime's Avatar
Vietnam
56
Rep
3,402
Posts

 
Drives: Banh Xeo
Join Date: Sep 2011
Location: Louisiana

iTrader: (12)

Happen to me before. usually high boost but after like a certain mph you feel like a nudge and then it backs down to 10psi all the way until you get off the gas or park or some shit it goes back to normal and does it again. This happen to me even tho I had FBO. cold air intake,downpipes,exhaust,fmic, extra oil cooler. still does it. It's like a spuddering but that's why I sold my jb4 and got a Cobb tune. Never had that problem anymore 16+PSI all the way till max. GL
__________________
Quote:
Originally Posted by nrrm1127 View Post
My life is complete. Yodaime has commented on a post with my car in it.
Appreciate 0
      07-29-2012, 09:29 PM   #15
neilvosko
Major
neilvosko's Avatar
United_States
19
Rep
1,429
Posts

 
Drives: 335i e92 FBO
Join Date: Dec 2011
Location: miami

iTrader: (16)

it autotunes so if the temp is high it cuts everything down.
exactly my issues with map5. you want consistent strong pulls with jb4...pick map 2 and 7
Appreciate 0
      07-30-2012, 02:20 AM   #16
robc1976
DIYER
robc1976's Avatar
77
Rep
4,719
Posts

 
Drives: E90 335i
Join Date: Mar 2012
Location: Illinois

iTrader: (11)

Quote:
Originally Posted by neilvosko View Post
it autotunes so if the temp is high it cuts everything down.
exactly my issues with map5. you want consistent strong pulls with jb4...pick map 2 and 7
Never will happen to me, highest I get is 220. If you are getting cuts because of high temps it is time to get a oil cooler.
__________________
JB4 G5, WEDGE flash, 455 LPFP, HFS-4 meth kit, BMS OCC, Motiv 750 ST, RB valve, BMS DCI, 3" AR Dps, Custom OC W/ SS lines, ER FMIC, ER CP W/HKS BOV, M3 control arms, M3 guide rods, M3 upper links, M3 front & rear sway-bars, HPA rear toe arms, Wavetrac LSD, HPF Gen 2 exhaust DEFIV kit, KW clubsport, Delrin solid subframe bushings, stoptech rotors, Rogue Tranny Mounts, 1M bumper, M3 CF hood, MORR VS8.2 rims 245/295
Appreciate 0
      07-30-2012, 08:02 AM   #17
neilvosko
Major
neilvosko's Avatar
United_States
19
Rep
1,429
Posts

 
Drives: 335i e92 FBO
Join Date: Dec 2011
Location: miami

iTrader: (16)

i am FBO with ER dual oil cooler.....temps are 230 or so, but boost comes super slow, i can reach 15 psi but at half the speed of map2
Appreciate 0
      07-30-2012, 11:29 AM   #18
robc1976
DIYER
robc1976's Avatar
77
Rep
4,719
Posts

 
Drives: E90 335i
Join Date: Mar 2012
Location: Illinois

iTrader: (11)

Quote:
Originally Posted by neilvosko View Post
i am FBO with ER dual oil cooler.....temps are 230 or so, but boost comes super slow, i can reach 15 psi but at half the speed of map2
That is odd, I hit 17 psi before the "1" mark on the bottom..so under a second. I did this on the G4 board but only 15psi. I now have the G5 board. Try setting lagfix to 100.
__________________
JB4 G5, WEDGE flash, 455 LPFP, HFS-4 meth kit, BMS OCC, Motiv 750 ST, RB valve, BMS DCI, 3" AR Dps, Custom OC W/ SS lines, ER FMIC, ER CP W/HKS BOV, M3 control arms, M3 guide rods, M3 upper links, M3 front & rear sway-bars, HPA rear toe arms, Wavetrac LSD, HPF Gen 2 exhaust DEFIV kit, KW clubsport, Delrin solid subframe bushings, stoptech rotors, Rogue Tranny Mounts, 1M bumper, M3 CF hood, MORR VS8.2 rims 245/295
Appreciate 0
      07-30-2012, 11:32 AM   #19
neilvosko
Major
neilvosko's Avatar
United_States
19
Rep
1,429
Posts

 
Drives: 335i e92 FBO
Join Date: Dec 2011
Location: miami

iTrader: (16)

Ohh, good point, i was actually thinking of lagfix.

i dropped it to 50 for the road course track sessions to give me a little more linearity on the boost, so may definitely be the culprit here.

thanks for the heads up, will report back.
Appreciate 0
      07-30-2012, 11:46 AM   #20
robc1976
DIYER
robc1976's Avatar
77
Rep
4,719
Posts

 
Drives: E90 335i
Join Date: Mar 2012
Location: Illinois

iTrader: (11)

Quote:
Originally Posted by neilvosko View Post
Ohh, good point, i was actually thinking of lagfix.

i dropped it to 50 for the road course track sessions to give me a little more linearity on the boost, so may definitely be the culprit here.

thanks for the heads up, will report back.
Should get a faster spool up!
__________________
JB4 G5, WEDGE flash, 455 LPFP, HFS-4 meth kit, BMS OCC, Motiv 750 ST, RB valve, BMS DCI, 3" AR Dps, Custom OC W/ SS lines, ER FMIC, ER CP W/HKS BOV, M3 control arms, M3 guide rods, M3 upper links, M3 front & rear sway-bars, HPA rear toe arms, Wavetrac LSD, HPF Gen 2 exhaust DEFIV kit, KW clubsport, Delrin solid subframe bushings, stoptech rotors, Rogue Tranny Mounts, 1M bumper, M3 CF hood, MORR VS8.2 rims 245/295
Appreciate 0
      01-30-2013, 09:05 PM   #21
jzingerman
Second Lieutenant
United_States
7
Rep
248
Posts

 
Drives: 2011 Bmw 335i M sport
Join Date: Nov 2011
Location: Beverly Hills California

iTrader: (1)

How can you fix overboost and what is knocking exactly?

Quote:
Originally Posted by Gugs View Post
The answer is-
Your overboosting or knocking.

With the newer firmwares we have new features...

The Jb4 goes into safety mode and forces itself into map 4 until you restart the car.
look for flashing check engine lights right before it happens, 1 flash is overboost and several is knock.

This is exactly what is happening-
as its defaulting to map 4 and leaving you to OEM map/boost levels.


Put in less e85 and it will most likely help the issue.
__________________
2011 BMW 335i M Sport- Space Grey Metallic * Black Kidney Grills * Jb4 Stage 2 ISO * Injen Intake * AR 4" Downpipe * 19" VMR V710 * Michelin Pilot Super Sports 235/265 * KW V3 Coilovers * 8k Alpine Angel Eyes * Gloss Black Roof Vinyl
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:27 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST