E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > tailights malfunctioning



Reply
 
Thread Tools Search this Thread
      01-31-2013, 03:37 PM   #1
335twins
Lieutenant
335twins's Avatar
7
Rep
501
Posts

 
Drives: 2009 335i, 2012 x3 35i
Join Date: Mar 2012
Location: AZ

iTrader: (1)

tailights malfunctioning

So my rear taillight is going out, i am getting "left rear taillight malfunctioning" error message when using turn signals (i have the LED ones). I had the same thing with the right taillight which BMW replaced and problem went away. Now the dealer said they reprogrammed it and its working, well after driving it for 2 days, i used left turn signal and i get same message. Took the car back to the dealer, lets see if they replace it or fix it again....Anyone had that happened to them? 3 yr old car and both taillights died?
Appreciate 0
      02-01-2013, 01:23 AM   #2
E90Flossin
Vroooomm
2
Rep
196
Posts

 
Drives: Lci 335i
Join Date: Aug 2012
Location: Los Angeles

iTrader: (1)

I had a similar issue on my 09 when the right tail light went bad. Took it to the dealer at least once every month and they kept replacing it, for about the third time I didn't get any error. I am guessing the bulbs or the electrical component going to the rear lights aren't built too well. I am assuming they will keep replacing it until it goes out again...
Appreciate 0
      02-01-2013, 01:44 AM   #3
335twins
Lieutenant
335twins's Avatar
7
Rep
501
Posts

 
Drives: 2009 335i, 2012 x3 35i
Join Date: Mar 2012
Location: AZ

iTrader: (1)

I got it replaced the second time around. Weird thing is that both of them had the same issue, when using turn signals I would get " rear left taillight malfunction" and the light would start blinking really fast than normal and fast again and on and on until I would turn the signal off , thank god for warranty cause I think they cost around $300 each...
__________________
[i]PTF Cobb tuned, custom intakes, VRSF dp, ETS 5" FMIC
Appreciate 0
      02-01-2013, 10:54 AM   #4
nbkkvv5
Second Lieutenant
2
Rep
256
Posts

 
Drives: 09 E90 335i
Join Date: Nov 2009
Location: SF Bay Area

iTrader: (0)

I had the same exact issue when I owned my 09 as well. The dealer replaced both left and right tail light assemblies even though it was only the left one that was bad. My SA told me it was a corrosion issue and they were both replaced under warranty per a service bulletin.

As time goes on, this is becoming more of common problem with the led tail lamps. Hopefully people will have some type of warranty coverage left when the tail lights fail since they are expensive to replace.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:55 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST