E90Post
 


N54Tuning.com
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N55 Turbo Engine Tuning and Exhaust Modifications - 335i Tuning > N55 Rough Idle W/ catless dp after JB4 ISO?



Reply
 
Thread Tools Search this Thread
      02-04-2013, 07:54 PM   #23
SRT14PimPin07
Captain
SRT14PimPin07's Avatar
Armenia
25
Rep
947
Posts

 
Drives: BMW 335i Coupe
Join Date: Jun 2009
Location: Los Angeles

iTrader: (2)

Quote:
Originally Posted by mashimarho View Post
That is definitely unnatural, but this is only since ISO update?
Well about a month after ISO update it started to do it.
__________________
2011 Alpine White E92 335i M-Sport N55 Engine
Appreciate 0
      02-04-2013, 07:55 PM   #24
SRT14PimPin07
Captain
SRT14PimPin07's Avatar
Armenia
25
Rep
947
Posts

 
Drives: BMW 335i Coupe
Join Date: Jun 2009
Location: Los Angeles

iTrader: (2)

Quote:
Originally Posted by paradoxical3 View Post
Check your o2 sensors. Trust me....
That's found on my downpipe right?
__________________
2011 Alpine White E92 335i M-Sport N55 Engine
Appreciate 0
      02-04-2013, 08:38 PM   #25
SRT14PimPin07
Captain
SRT14PimPin07's Avatar
Armenia
25
Rep
947
Posts

 
Drives: BMW 335i Coupe
Join Date: Jun 2009
Location: Los Angeles

iTrader: (2)

I decided to try removing the JB4 completely, and see if the problem continues. If the problem stops then I can confirm the JB4 was causing it.
__________________
2011 Alpine White E92 335i M-Sport N55 Engine
Appreciate 0
      02-04-2013, 08:50 PM   #26
Mike@N54Tuning.com
BimmerPost Supporting Vendor
Canada
479
Rep
15,041
Posts


 
Drives: 07335i
Join Date: Dec 2008
Location: Earth

iTrader: (88)

Quote:
Originally Posted by SRT14PimPin07 View Post
I decided to try removing the JB4 completely, and see if the problem continues. If the problem stops then I can confirm the JB4 was causing it.
So, bypassing the MAF connector didn't help the car at all?

Mike
__________________
LOWEST PRICE GURANTEE ON ALL PRODUCTS - www.n54tuning.com - Email; Mike@n54tuning.com
NEW PERFORMANCE LINE N54 DOWNPIPES & M3/M4 & F30 ER DOWNPIPES NOW IN STOCK - ER N54 CHARPE PIPE SPECIALS - NEW JB4 G5 ISO for N54 and F30 N55 ON SALE - NEW S55 M3/M4 JB4 NOW SHIPPING
Appreciate 0
      04-05-2013, 07:42 PM   #27
jzingerman
Second Lieutenant
United_States
7
Rep
248
Posts

 
Drives: 2011 Bmw 335i M sport
Join Date: Nov 2011
Location: Beverly Hills California

iTrader: (1)

Ever fix the problem?
__________________
2011 BMW 335i M Sport- Space Grey Metallic * Black Kidney Grills * Jb4 Stage 2 ISO * Injen Intake * AR 4" Downpipe * 19" VMR V710 * Michelin Pilot Super Sports 235/265 * KW V3 Coilovers * 8k Alpine Angel Eyes * Gloss Black Roof Vinyl
Appreciate 0
      04-06-2013, 12:31 PM   #28
SRT14PimPin07
Captain
SRT14PimPin07's Avatar
Armenia
25
Rep
947
Posts

 
Drives: BMW 335i Coupe
Join Date: Jun 2009
Location: Los Angeles

iTrader: (2)

Quote:
Originally Posted by jzingerman View Post
Ever fix the problem?
Nope, tried putting my stock air box back in and that didn't help either. Only other engine mods are JB4, CP, DP.
__________________
2011 Alpine White E92 335i M-Sport N55 Engine
Appreciate 0
      04-06-2013, 01:32 PM   #29
gatorheel
Private First Class
United_States
2
Rep
164
Posts

 
Drives: 2007 e90 n54
Join Date: Sep 2011
Location: CLT

iTrader: (2)

I have g5, dci and catless dp. I have noticed some non-linear changes in idle since utilizing the g5iso. The idle seems to be more step-like but it is very hard to notice. Can't recall if I had the same issues w the non-g5. Idle is like 500rpm and steplike around 500-550-600.
__________________
2009 n54 e90 / ZSP / ZPP / black sapphire metallic / Logic7 / AMS FMIC / BMS 3" DP / BMS OCC / Alpina TCU Flash / ER CP + ForgeDV / Cobb
Appreciate 0
      04-06-2013, 06:22 PM   #30
jzingerman
Second Lieutenant
United_States
7
Rep
248
Posts

 
Drives: 2011 Bmw 335i M sport
Join Date: Nov 2011
Location: Beverly Hills California

iTrader: (1)

Quote:
Originally Posted by SRT14PimPin07 View Post
Nope, tried putting my stock air box back in and that didn't help either. Only other engine mods are JB4, CP, DP.
Hmm... I'm having the same problem and I have the same mods. Check your codes and see if anything comes up for the o2sensors. I got the code 2D0D which is for the o2 sensors. I'm pretty sure they are screwed up so check yours too.

Also, are you having trouble with getting boost in your car? I thought I was having a chargepipe leak when I wasn't boosting so I got a new charge pipe but the problem is still there. I took my car to BMW and had my tech look over it and he said I had a turbo fault. Maybe the ISO screws with the turbos?
__________________
2011 BMW 335i M Sport- Space Grey Metallic * Black Kidney Grills * Jb4 Stage 2 ISO * Injen Intake * AR 4" Downpipe * 19" VMR V710 * Michelin Pilot Super Sports 235/265 * KW V3 Coilovers * 8k Alpine Angel Eyes * Gloss Black Roof Vinyl
Appreciate 0
      04-06-2013, 08:13 PM   #31
SRT14PimPin07
Captain
SRT14PimPin07's Avatar
Armenia
25
Rep
947
Posts

 
Drives: BMW 335i Coupe
Join Date: Jun 2009
Location: Los Angeles

iTrader: (2)

Quote:
Originally Posted by jzingerman View Post
Hmm... I'm having the same problem and I have the same mods. Check your codes and see if anything comes up for the o2sensors. I got the code 2D0D which is for the o2 sensors. I'm pretty sure they are screwed up so check yours too.

Also, are you having trouble with getting boost in your car? I thought I was having a chargepipe leak when I wasn't boosting so I got a new charge pipe but the problem is still there. I took my car to BMW and had my tech look over it and he said I had a turbo fault. Maybe the ISO screws with the turbos?
So what are you doing about that now? I have never gotten a code 2D0D.
__________________
2011 Alpine White E92 335i M-Sport N55 Engine
Appreciate 0
      04-07-2013, 03:43 PM   #32
jzingerman
Second Lieutenant
United_States
7
Rep
248
Posts

 
Drives: 2011 Bmw 335i M sport
Join Date: Nov 2011
Location: Beverly Hills California

iTrader: (1)

Im going to be buying new o2 sensors and installing them. Hopefully this fixing the problem

Quote:
Originally Posted by SRT14PimPin07 View Post
So what are you doing about that now? I have never gotten a code 2D0D.
__________________
2011 BMW 335i M Sport- Space Grey Metallic * Black Kidney Grills * Jb4 Stage 2 ISO * Injen Intake * AR 4" Downpipe * 19" VMR V710 * Michelin Pilot Super Sports 235/265 * KW V3 Coilovers * 8k Alpine Angel Eyes * Gloss Black Roof Vinyl
Appreciate 0
      04-08-2013, 07:27 PM   #33
SRT14PimPin07
Captain
SRT14PimPin07's Avatar
Armenia
25
Rep
947
Posts

 
Drives: BMW 335i Coupe
Join Date: Jun 2009
Location: Los Angeles

iTrader: (2)

Quote:
Originally Posted by jzingerman View Post
Im going to be buying new o2 sensors and installing them. Hopefully this fixing the problem
Let me know what happens. I thought that could be the problem for my car. But considering the amount of miles I have and when I put the DP on ppl said my O2 sensors can't have gone bad this early.
__________________
2011 Alpine White E92 335i M-Sport N55 Engine
Appreciate 0
      04-08-2013, 07:57 PM   #34
emackin
First Lieutenant
4
Rep
353
Posts

 
Drives: 2011 335i e90
Join Date: Jan 2013
Location: Va beach Va

iTrader: (5)

im getting the same issues and i believe its the iso ill try disconnecting the maf sensor from the jb4 see if that helps.
Appreciate 0
      04-08-2013, 09:12 PM   #35
SRT14PimPin07
Captain
SRT14PimPin07's Avatar
Armenia
25
Rep
947
Posts

 
Drives: BMW 335i Coupe
Join Date: Jun 2009
Location: Los Angeles

iTrader: (2)

Quote:
Originally Posted by emackin View Post
im getting the same issues and i believe its the iso ill try disconnecting the maf sensor from the jb4 see if that helps.
If your talking about the one that connects to the air intake. I did that and it did not help.
__________________
2011 Alpine White E92 335i M-Sport N55 Engine
Appreciate 0
      04-10-2013, 01:08 PM   #36
Josh5442
Enlisted Member
Josh5442's Avatar
United_States
0
Rep
35
Posts

 
Drives: 2013 F10 M5
Join Date: Jan 2012
Location: Boston

iTrader: (0)

I have the same issue, except I'm stock. BMW can't seem to explain it.
Appreciate 0
      04-10-2013, 01:22 PM   #37
eyim1988
Lieutenant Colonel
eyim1988's Avatar
United_States
22
Rep
1,528
Posts

 
Drives: 2013 335i M Sport
Join Date: Feb 2011
Location: Los Angeles, CA

iTrader: (3)

this is common, happened to me a lot before with a downpipe. But once i changed to my single 3 all the way from downpipe back never had a problem.
__________________
Current: 2013 335i 6mt msport
BMS Clutch Stop, JB4, Slightly Modified OEM Muffler, ER Downpipe

Past: 2011 335i coupe
369 whp/444 torque. (Procede, Custom Turboback Exhaust, BMS Intake, ER FMIC)
Appreciate 0
      04-10-2013, 07:42 PM   #38
SRT14PimPin07
Captain
SRT14PimPin07's Avatar
Armenia
25
Rep
947
Posts

 
Drives: BMW 335i Coupe
Join Date: Jun 2009
Location: Los Angeles

iTrader: (2)

Quote:
Originally Posted by Josh5442 View Post
I have the same issue, except I'm stock. BMW can't seem to explain it.
Now that's a real problem! Keep us updated if anything changes.
__________________
2011 Alpine White E92 335i M-Sport N55 Engine
Appreciate 0
      04-24-2013, 10:32 PM   #39
Josh5442
Enlisted Member
Josh5442's Avatar
United_States
0
Rep
35
Posts

 
Drives: 2013 F10 M5
Join Date: Jan 2012
Location: Boston

iTrader: (0)

Quote:
Originally Posted by SRT14PimPin07 View Post
Now that's a real problem! Keep us updated if anything changes.
So far they've done a software update and replaced 2 Vanos units apparently. I'll update when I hear more tomorrow.
Appreciate 0
      04-25-2013, 12:56 AM   #40
jmkworld
Captain
14
Rep
626
Posts

 
Drives: 2011 335i xdrive
Join Date: Sep 2010
Location: Philly

iTrader: (3)

i just went through this same exact thing. jb4 iso with bms catless dp. tach would jump and really harsh idle. put the car back to stock and took it in for warranty. dealer replaced the fuel sensor and the o2 sensors (even though the catless dp was still installed ) Problem seems to be fixed. Have not had a chance to put the jb4 back on yet.
Appreciate 0
      04-25-2013, 04:40 PM   #41
SRT14PimPin07
Captain
SRT14PimPin07's Avatar
Armenia
25
Rep
947
Posts

 
Drives: BMW 335i Coupe
Join Date: Jun 2009
Location: Los Angeles

iTrader: (2)

Quote:
Originally Posted by jmkworld View Post
i just went through this same exact thing. jb4 iso with bms catless dp. tach would jump and really harsh idle. put the car back to stock and took it in for warranty. dealer replaced the fuel sensor and the o2 sensors (even though the catless dp was still installed ) Problem seems to be fixed. Have not had a chance to put the jb4 back on yet.
Aww man, now you got me worried. I think I should do the same.
__________________
2011 Alpine White E92 335i M-Sport N55 Engine
Appreciate 0
      04-28-2013, 11:36 PM   #42
graham999au
Private First Class
graham999au's Avatar
Australia
4
Rep
146
Posts

 
Drives: E92 335i Coupe
Join Date: Nov 2006
Location: Australia

iTrader: (0)

I believe the problems you are experiencing have been fixed in SIB 120912 (see attached).

Hope this helps.
Attached Images
File Type: pdf SIB120912.pdf (76.4 KB, 225 views)
__________________
__________________________________________________ __________________________________________________ __________________________
2011 E92 335i M Sport Coupe/DCT/Black Sapphire/Oyster/Bamboo Grain/Sunroof/OEM Performance Exhaust/Individual Audio/Heated Seats/TV/Folding Mirrors/6FL iPod/6NF Extended Connectivity/Internet/ACS Roof spoiler/ACS Aluminium Peddles
Appreciate 0
      04-29-2013, 11:29 AM   #43
TZANIDO777
Private First Class
1
Rep
169
Posts

 
Drives: 2011 BMW 135i
Join Date: Dec 2010
Location: NY

iTrader: (1)

Garage List
2011 BMW 135i  [0.00]
For what its worth, I have had my jb4 with the iso update and catless downpipe for a few months and I was experiencing the same problems with rough idle and the car stalling.

I had to take the jb4 off the car and remove the catless downpipe in order to pass my inspection here in New York and I also got my service done a few days later.

During the two weeks that I had the car completely stock, other than an intercooler and chargepipe, I experienced no rough idle and the car did not die on me once. I reinstalled the jb4 and catless downpipe this past saturday and have since been experiencing rough idle and the car has died on me twice already while driving. I have had no codes thrown and my service advisor told me everything was okay with the car before I reinstalled the jb4 and downpipe.

I am not blaming or bashing BMS for their tune or Berk for their downpipe, I am only sharing my experiences. I also would like this issue to be resolved.
Appreciate 0
      04-29-2013, 01:51 PM   #44
335Dude
Lieutenant
11
Rep
503
Posts

 
Drives: 2011 335i Coupe
Join Date: Feb 2009
Location: Potomac, MD

iTrader: (14)

anyone having a similar issue with a n54?
__________________
2011 E92 335i | 6MT | Titanium Silver | M Sport | 19" style 230 wheels | 35% tint | Cobb V2 | BMS Intake | BMS Clutch Stop

2007 E92 335i, 2008 Corvette, 1999 323i, 2001 Boxster, 1999 Carrera, 1997 Corvette, 2001 Camaro SS
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:07 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST