E90Post
 


PYSPEED
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Engine Light, studder, and clicking/knocking noise under load



Reply
 
Thread Tools Search this Thread
      01-19-2013, 11:05 PM   #1
akotten
Major
 
akotten's Avatar
 
Drives: 2007 335xi
Join Date: Mar 2011
Location: Rapid City, SD

Posts: 1,042
iTrader: (2)

Engine Light, studder, and clicking/knocking noise under load

Hi everyone,

I went to visit a friend tonight and along the way there, my engine developed a weird condition. I've had misfires happen in the past under high load, which then clear after a while or after the car has been shut off. This is different. I was climbing a hill and it began to studder. After a few seconds the ECU recognized this and threw a check engine light. After coasting for a while the light went out. Upon applying more load, the issue returned, along with the light. I got off the highway and began driving in town. While trying to accelerate, I can hear a clicking noise coming from the engine bay. I am very limited on power as it continues to studder. While at rest, if I give it a quick light rev, I can hear the same clicking noise. This is NOT the wastegates. I can hear those too, separately. This is louder and a bit more solid.

Unfortunately this is the one time I don't have my laptop with me, and everyone here only has MACs. I doubt I'll be able to find the drivers for my USB cable to pull the codes.

So...here are my thoughts. While in a cruising state, no load, the engine sounds normal without this clicking/knocking noise. I've had engines with spun bearings in the past so I know this is NOT the case, thank goodness.

A bad coil/plug won't make noise if it has failed, so not that either. An injector probably wouldn't make noise, and if it did, not this loud.

My guess is either a faulty HPFP, VANOs solenoid, or VANOs itself. However, the symptoms don't seem like a HPFP because from what I've read, it also throws a half engine light too. Within the last 5k miles, I replaced a faulty VANOs solenoid. The other seemed fine and the codes related to the bad solenoid went away after it was replaced. Could a faulty solenoid make noise? Or the VANOs system make noise because the bad solenoid isn't supplying enough oil?

Any ideas?? I really hope I can get home in the morning.


Alex
__________________
TC Kline S/A | Vorshlag Camber Plates | ///M Bushings & ARB | CP-e DPs | VRSF FMIC | Procede 2.5 w/ OpenFlash | DCI |
akotten is offline  
0
Reply With Quote
      01-20-2013, 02:08 PM   #2
akotten
Major
 
akotten's Avatar
 
Drives: 2007 335xi
Join Date: Mar 2011
Location: Rapid City, SD

Posts: 1,042
iTrader: (2)

Alright, luckily I made it home so I was able to pull the following codes.

12140/2F6C - Exhaust flapper code for Procede

10700/29CC - Multiple Cylinder Misfire

10701/29CD - Cylinder 1 Misfire

10702/29CE - Cylinder 2 Misfire

10927/2AAF - Fuel Pump Plausibility

11387/2C7B - O2 Sensor Circuit Slow Response

11388/2C7C - O2 Sensor Circuit Slow Response


I'm going to have someone rev it for me and see where the extra clicking noise is coming from. My guess is the HPFP...
__________________
TC Kline S/A | Vorshlag Camber Plates | ///M Bushings & ARB | CP-e DPs | VRSF FMIC | Procede 2.5 w/ OpenFlash | DCI |
akotten is offline  
0
Reply With Quote
      01-20-2013, 02:42 PM   #3
joec500
Brigadier General
 
Drives: it has 4 wheels
Join Date: Jul 2008
Location: San Francisco

Posts: 3,004
iTrader: (10)

Quote:
Originally Posted by akotten View Post
Alright, luckily I made it home so I was able to pull the following codes.

12140/2F6C - Exhaust flapper code for Procede

10700/29CC - Multiple Cylinder Misfire

10701/29CD - Cylinder 1 Misfire

10702/29CE - Cylinder 2 Misfire

10927/2AAF - Fuel Pump Plausibility

11387/2C7B - O2 Sensor Circuit Slow Response

11388/2C7C - O2 Sensor Circuit Slow Response


I'm going to have someone rev it for me and see where the extra clicking noise is coming from. My guess is the HPFP...

From my personal experience, misfires only under load have been caused by worn out plugs, so as most people would be suggest is a good and relatively inexpensive starting point.

But if you get a shudder and shake that causes blinking CEL, but once you re-cycle the car it goes away, this has been faulty injectors. In my case, I had intermittent misfires in my bank 2, Cylinders 4-5-6. So I started replacing one injectors at a time, which led to more head aches. My suggestion is replace all 3 injectors in the bank that's misfiring.

Looks like you're having issues in Bank 1 with some O2 sensor codes.

so in summary:

1.) You can try moving coilpacks around to make sure they are not the issue and this is super easy and free.

2.) Change out the plugs, again pretty easy about about $75 in parts

3.) Replace all 3 injectors in the mis-firing bank, which in your case is Bank1. This is about $300-400 dollars depending where you get your injectors from.
__________________
2007 E92 6MT SGM: MusicarNW Level 2, Procede Rev 2.5, FFTEC/Vishnu LPFP with Flexfuel Sensor and Flash, M3 Offset V701's, WaveTrac LSD, Michelin PSS, Downpipes, M3 Control Arms, TCKline D/A Suspension, LCI Tail lights, Lux AE's, ER Charge Pipe, DCI's, Mtech Front and Rear, M3 Sideskirts, HPF Stage 1 Clutch
joec500 is offline  
0
Reply With Quote
      01-20-2013, 10:47 PM   #4
akotten
Major
 
akotten's Avatar
 
Drives: 2007 335xi
Join Date: Mar 2011
Location: Rapid City, SD

Posts: 1,042
iTrader: (2)

I delivered the car to my favorite indy shop today. I'm a full time student so I don't have the time or money to try to diagnose the condition right now. My service contract covers injectors and coil packs as well as anything else that could cause it, so now it's a waiting game. My bet is injectors, but I'm still not convinced they could be making the loud tapping noise that it makes under load. Then again, they opperate at 200bar and they're loud at idle to begin with so a faulty injector could make a lot of noise I'm sure.
__________________
TC Kline S/A | Vorshlag Camber Plates | ///M Bushings & ARB | CP-e DPs | VRSF FMIC | Procede 2.5 w/ OpenFlash | DCI |
akotten is offline  
0
Reply With Quote
      01-27-2013, 01:39 AM   #5
akotten
Major
 
akotten's Avatar
 
Drives: 2007 335xi
Join Date: Mar 2011
Location: Rapid City, SD

Posts: 1,042
iTrader: (2)

Quick update: They will be replacing a fuel injector on Monday. I may pay the extra to just replace them all. Is this worth it or just a waste of money?
__________________
TC Kline S/A | Vorshlag Camber Plates | ///M Bushings & ARB | CP-e DPs | VRSF FMIC | Procede 2.5 w/ OpenFlash | DCI |
akotten is offline  
0
Reply With Quote
      01-31-2013, 02:57 PM   #6
akotten
Major
 
akotten's Avatar
 
Drives: 2007 335xi
Join Date: Mar 2011
Location: Rapid City, SD

Posts: 1,042
iTrader: (2)

Another update. Injector #1 was replaced as well as the mounting seals, etc. for #1 and #2. #2 was leaking apparently. Supposedly it drives normal again, but the #1 injector still isn't seating as securely as its supposed to so it has the potential to leak again in the future. They said this may require replacing the head. I'm going to talk with the technician today to find out more. Thank goodness I have a service contract to cover this!
__________________
TC Kline S/A | Vorshlag Camber Plates | ///M Bushings & ARB | CP-e DPs | VRSF FMIC | Procede 2.5 w/ OpenFlash | DCI |
akotten is offline  
0
Reply With Quote
      02-01-2013, 01:58 AM   #7
MAC335i
Second Lieutenant
 
Drives: 2007 Jet Black E90 335i
Join Date: Nov 2009
Location: California

Posts: 271
iTrader: (3)

Im interested to learn more about the service contract you have that lets you take it to the shop of your choice. How many miles do you have on the car btw?

Thanks
MAC335i is offline  
0
Reply With Quote
      02-01-2013, 11:37 AM   #8
akotten
Major
 
akotten's Avatar
 
Drives: 2007 335xi
Join Date: Mar 2011
Location: Rapid City, SD

Posts: 1,042
iTrader: (2)

I purchased a third party service contract when I bought the car with 51k miles. I don't remember the name of the company off the top of my head, and all of my documentation for it is with the car. I have 91k miles currently with coverage to 125k.
__________________
TC Kline S/A | Vorshlag Camber Plates | ///M Bushings & ARB | CP-e DPs | VRSF FMIC | Procede 2.5 w/ OpenFlash | DCI |
akotten is offline  
0
Reply With Quote
      02-08-2013, 10:32 PM   #9
akotten
Major
 
akotten's Avatar
 
Drives: 2007 335xi
Join Date: Mar 2011
Location: Rapid City, SD

Posts: 1,042
iTrader: (2)

I guess I'm finally getting new wastegates for my turbos. Has anyone had experience with this? Any extra parts that should be replaced to ensure the rattle is eliminated?
__________________
TC Kline S/A | Vorshlag Camber Plates | ///M Bushings & ARB | CP-e DPs | VRSF FMIC | Procede 2.5 w/ OpenFlash | DCI |
akotten is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:21 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST