E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Cold Start Issues after Jb4 Install



Reply
 
Thread Tools Search this Thread
      02-01-2013, 11:24 AM   #1
CJPatel
First Lieutenant
11
Rep
318
Posts

Drives: LP550-2 & F10 550i
Join Date: Dec 2006
Location: Hockessin, DE

iTrader: (4)

Cold Start Issues after Jb4 Install

I just installed a second hand JB4 G4 Board onto my E92 2009 335i. On very cold starts it struggles to start, the RPMs idle from 1200-600. But the major problem is occasionally once I get driving (after a short warm up period) the turbos don't seem to be working - feels like a 170hp car if that... Once I turn the car off after the fact and then turn it back on, it comes back to normal.

Any ideas on what it could be?

I updated the firmware (the problem still exists)
I even was running Map 0 then Map 1 (still happens).

Thanks
__________________

Weekend: Ferrari F430 Spider- F1 - Matte White
DD: 2011 550i Xdrive M-Sport
Gone: 2008 Aston Martin V8V, Stratus White, Bitter Chocolate, 6psd, Modded ~ 450hp, 2009 E92 335i M-Sport, 2003.5 E46 M3
Appreciate 0
      02-01-2013, 11:56 AM   #2
bigdaddycane
I even mod my cereal
bigdaddycane's Avatar
United_States
56
Rep
2,888
Posts

Drives: 2011 ZCP DCT M3
Join Date: Aug 2009
Location: Northern Va

iTrader: (44)

Garage List
check your connector blocks (with pins) where they connect to the DME harnesses. Also check your red power wire....make sure it's plugged in properly in the green DME power source.
__________________
2011 Mineral White M3 ZCP
Paint Correct, Opticoat, Ventureshield and some CF and an intake
Appreciate 0
      02-01-2013, 12:00 PM   #3
GTstunna612
Lieutenant
GTstunna612's Avatar
United_States
34
Rep
509
Posts

Drives: BMW
Join Date: Feb 2008
Location: Tampa, FL

iTrader: (0)

Garage List
E90 335i  [0.00]
double and triple check all your connections...scan the car and see if any codes pop up.
__________________
E90 335i Alpine White
E90 328i Titanium Silver
Appreciate 0
      02-01-2013, 01:36 PM   #4
Mike@N54Tuning.com
BimmerPost Supporting Vendor
Canada
1920
Rep
35,355
Posts


Drives: 2007 335i, 2015 M3
Join Date: Dec 2008
Location: N54tuning.com

iTrader: (89)

The JB4 is off at idle and during cold starts, so its not doing anything. If there is a connection problem or bent pin that could cause some issues. Its difficult to say as you wouldn't believe the condition I see some used JB4s come back with pins missing, wires cut, etc.

Double check all connections and double check all JB4 wires are properly seated in connector, etc.

Mike
Appreciate 0
      02-01-2013, 02:09 PM   #5
CJPatel
First Lieutenant
11
Rep
318
Posts

Drives: LP550-2 & F10 550i
Join Date: Dec 2006
Location: Hockessin, DE

iTrader: (4)

Ill run the car for any codes.

We already checked the wires since when I first installed it, the car was misfiring terribly, and found taht one connection wasn't down. So we double/triple checked everything and made sure everything is tight.


The werid thing is when I turn the car off and back on the Turbos come back 100%. Its really werid.
__________________

Weekend: Ferrari F430 Spider- F1 - Matte White
DD: 2011 550i Xdrive M-Sport
Gone: 2008 Aston Martin V8V, Stratus White, Bitter Chocolate, 6psd, Modded ~ 450hp, 2009 E92 335i M-Sport, 2003.5 E46 M3
Appreciate 0
      02-18-2013, 01:06 AM   #6
CJPatel
First Lieutenant
11
Rep
318
Posts

Drives: LP550-2 & F10 550i
Join Date: Dec 2006
Location: Hockessin, DE

iTrader: (4)

Well the issues continued. And a few days ago, after a hard drive the check enging/SES lights came on. Then went away a day later. I took it to Map 0 and took it into BMW for service. They said I need a new HFFP. Will report back once thats replaced, to see if issues continue or if that was the problem.
__________________

Weekend: Ferrari F430 Spider- F1 - Matte White
DD: 2011 550i Xdrive M-Sport
Gone: 2008 Aston Martin V8V, Stratus White, Bitter Chocolate, 6psd, Modded ~ 450hp, 2009 E92 335i M-Sport, 2003.5 E46 M3
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:11 PM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST