E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > USA - Northwest > it feels weird...



Reply
 
Thread Tools Search this Thread
      03-25-2013, 08:59 PM   #1
CivicKilla
Private
0
Rep
74
Posts

Drives: 09 E92 x-drive
Join Date: Mar 2013
Location: seattle

iTrader: (0)

it feels weird...

I just got my second E92 328ix coupe and it drives odd. Their is a delay between when I press on the gas pedal and when my head gets snapped back. I swear - its like a real bad turbo lag. The car only has 26k miles on it, and otherwise runs/drives great. Anyone suffer a similar problem?
Appreciate 0
      03-26-2013, 12:11 AM   #2
Shearer
Private First Class
1
Rep
140
Posts

Drives: '08 e90 335i
Join Date: May 2012
Location: Vancouver, BC

iTrader: (2)

Garage List
2008 e90 335i  [0.00]
Quote:
Originally Posted by CivicKilla View Post
I just got my second E92 328ix coupe and it drives odd. Their is a delay between when I press on the gas pedal and when my head gets snapped back. I swear - its like a real bad turbo lag. The car only has 26k miles on it, and otherwise runs/drives great. Anyone suffer a similar problem?
my friend had that issue and it came down to worn out tires. Replaced them and the lag was gone
Appreciate 0
      03-26-2013, 12:36 AM   #3
aDDanDrew
Private
aDDanDrew's Avatar
United_States
1
Rep
48
Posts

Drives: 2010 328xi E92
Join Date: Feb 2013
Location: New York

iTrader: (0)

Quote:
Originally Posted by CivicKilla View Post
I just got my second E92 328ix coupe and it drives odd. Their is a delay between when I press on the gas pedal and when my head gets snapped back. I swear - its like a real bad turbo lag. The car only has 26k miles on it, and otherwise runs/drives great. Anyone suffer a similar problem?
I'm not sure if my issues are similar to yours but every time I let off the gas, the car feels like it loses a tremendous amount of power. It feels like when you're down shifting, that feeling of being pulled back, but I feel it right after I let off...I remember testing driving another 328xi and never felt that lose of power.
Appreciate 0
      03-26-2013, 11:37 AM   #4
hookandpull
Lieutenant
6
Rep
573
Posts

Drives: 2008 335i Sedan
Join Date: Dec 2012
Location: Seattle WA

iTrader: (2)

What?!?!?!? So what your saying is when you let Off the gas the car loses power? Haha that's what's supposed to happen. And tires for throttle response? Lol... It's a 328 there's no such thing as turbo lag and if your that concerned do a compression test or check your plugs. Or for $50 throw your car on the dyno. A lot of times when you leave a car and come back to it especially from a faster car your ass calibration is off. What year is the 328?
__________________
19" DPE GT7's, BMS DCI, AA 3" catless downpipes, AE catless catback, JB4 G5, ETS 7" FMIC, AR Charpipe with dual -10 meth injector bungs, HFS4 Aquamist meth kit, Alpina TCU flash, M3 pedals, LED interior kit...
Appreciate 0
      03-26-2013, 11:47 AM   #5
Taran.J
Youtube.com/Taran861
Taran.J's Avatar
United_States
221
Rep
5,792
Posts

Drives: 15 X5 Msport & a lot of Merc's
Join Date: Jul 2012
Location: Tacoma/Puyallup, WA

iTrader: (7)

Send a message via Skype™ to Taran.J
^lol
__________________
Click Here For My E90's Build Thread (SOLD) http://www.e90post.com/forums/showthread.php?t=809436

Click Here For My F15's Build Thread http://f15.bimmerpost.com/forums/sho....php?t=1064084
Appreciate 0
      03-26-2013, 12:09 PM   #6
mrbillytalent
Lieutenant
5
Rep
536
Posts

Drives: '99 e46 323i & '07 e90 335i
Join Date: May 2012
Location: Toledo OH

iTrader: (1)

Sticky brakes?
Appreciate 0
      03-26-2013, 01:06 PM   #7
andybui82
Colonel
andybui82's Avatar
United_States
44
Rep
2,498
Posts

Drives: 335d
Join Date: Oct 2011
Location: Blop PNW branch

iTrader: (4)

328 have soo much turbo lag. i hated it.
__________________
Cars: SGM 325i (Retired) l BSM 135i (Retired) l SS to Gloss White S2000 (Retired) l Arctic White RS4 (Retired) l White GTi (retired) l AW 335d M-Sport
Appreciate 0
      03-26-2013, 01:17 PM   #8
hookandpull
Lieutenant
6
Rep
573
Posts

Drives: 2008 335i Sedan
Join Date: Dec 2012
Location: Seattle WA

iTrader: (2)

^ hahahaha
__________________
19" DPE GT7's, BMS DCI, AA 3" catless downpipes, AE catless catback, JB4 G5, ETS 7" FMIC, AR Charpipe with dual -10 meth injector bungs, HFS4 Aquamist meth kit, Alpina TCU flash, M3 pedals, LED interior kit...
Appreciate 0
      03-26-2013, 09:02 PM   #9
CivicKilla
Private
0
Rep
74
Posts

Drives: 09 E92 x-drive
Join Date: Mar 2013
Location: seattle

iTrader: (0)

Quote:
Originally Posted by hookandpull View Post
What?!?!?!? So what your saying is when you let Off the gas the car loses power? Haha that's what's supposed to happen. And tires for throttle response? Lol... It's a 328 there's no such thing as turbo lag and if your that concerned do a compression test or check your plugs. Or for $50 throw your car on the dyno. A lot of times when you leave a car and come back to it especially from a faster car your ass calibration is off. What year is the 328?
NOT A REAL "READER" ARE YA...
Appreciate 0
      03-26-2013, 09:06 PM   #10
CivicKilla
Private
0
Rep
74
Posts

Drives: 09 E92 x-drive
Join Date: Mar 2013
Location: seattle

iTrader: (0)

Wow - Im impressed with all the quality help I've gotten here. I'm sure that no one has ever used an analogy before and thats why you werent able to recognize it - I blame the public schools. Its good to know that such a helpful and informative place as this exists.
Appreciate 0
      03-26-2013, 09:22 PM   #11
Taran.J
Youtube.com/Taran861
Taran.J's Avatar
United_States
221
Rep
5,792
Posts

Drives: 15 X5 Msport & a lot of Merc's
Join Date: Jul 2012
Location: Tacoma/Puyallup, WA

iTrader: (7)

Send a message via Skype™ to Taran.J
Sprint booster. Your welcome.
__________________
Click Here For My E90's Build Thread (SOLD) http://www.e90post.com/forums/showthread.php?t=809436

Click Here For My F15's Build Thread http://f15.bimmerpost.com/forums/sho....php?t=1064084
Appreciate 0
      03-26-2013, 10:08 PM   #12
aDDanDrew
Private
aDDanDrew's Avatar
United_States
1
Rep
48
Posts

Drives: 2010 328xi E92
Join Date: Feb 2013
Location: New York

iTrader: (0)

Quote:
Originally Posted by hookandpull View Post
What?!?!?!? So what your saying is when you let Off the gas the car loses power? Haha that's what's supposed to happen. And tires for throttle response? Lol... It's a 328 there's no such thing as turbo lag and if your that concerned do a compression test or check your plugs. Or for $50 throw your car on the dyno. A lot of times when you leave a car and come back to it especially from a faster car your ass calibration is off. What year is the 328?
The speed of the car should gradually slow down and lose power, not fall on its face and pull you forward. The other 328 I test drove was a complete different feel when letting off the gas. Maybe its in my head but I'm gonna get it checked out either way, better safe than sorry.

Also, I think the OP meant it "FEELS" like a turbo lag not actually a turbo lag

Last edited by aDDanDrew; 03-26-2013 at 10:26 PM.
Appreciate 0
      03-26-2013, 10:44 PM   #13
hookandpull
Lieutenant
6
Rep
573
Posts

Drives: 2008 335i Sedan
Join Date: Dec 2012
Location: Seattle WA

iTrader: (2)

You never know with some of the shit that people post in here wether they are being serious or not.... Like I said these cars run on a fairly advanced digital bus and if its really that bad more then likely he would have codes . A multitude of things could cause sluggish behavior and could be something as easy as a software update. What year is the car?
__________________
19" DPE GT7's, BMS DCI, AA 3" catless downpipes, AE catless catback, JB4 G5, ETS 7" FMIC, AR Charpipe with dual -10 meth injector bungs, HFS4 Aquamist meth kit, Alpina TCU flash, M3 pedals, LED interior kit...
Appreciate 0
      03-26-2013, 10:49 PM   #14
cwarren
Captain
cwarren's Avatar
11
Rep
618
Posts

Drives: 08 e92
Join Date: Jan 2012
Location: portland

iTrader: (1)

assumed he was trolling
Appreciate 0
      03-26-2013, 10:52 PM   #15
hookandpull
Lieutenant
6
Rep
573
Posts

Drives: 2008 335i Sedan
Join Date: Dec 2012
Location: Seattle WA

iTrader: (2)

No he wasn't trolling ... I am the troll of trolls I frequently camp out under bridges just to get my troll swagger on
__________________
19" DPE GT7's, BMS DCI, AA 3" catless downpipes, AE catless catback, JB4 G5, ETS 7" FMIC, AR Charpipe with dual -10 meth injector bungs, HFS4 Aquamist meth kit, Alpina TCU flash, M3 pedals, LED interior kit...
Appreciate 0
      03-26-2013, 11:18 PM   #16
Wedge1967
Banned
United_States
27
Rep
2,172
Posts

Drives: '07 e92 AT Sport Montego Blue
Join Date: Sep 2011
Location: Portland, OR

iTrader: (3)

Quote:
Originally Posted by hookandpull View Post
No he wasn't trolling ... I am the troll of trolls I frequently camp out under bridges just to get my troll swagger on
Haha, I was watching the Hobbit the other day and I thought you looked familiar.
Appreciate 0
      03-26-2013, 11:21 PM   #17
Wedge1967
Banned
United_States
27
Rep
2,172
Posts

Drives: '07 e92 AT Sport Montego Blue
Join Date: Sep 2011
Location: Portland, OR

iTrader: (3)

Quote:
Originally Posted by CivicKilla View Post
I just got my second E92 328ix coupe and it drives odd. Their is a delay between when I press on the gas pedal and when my head gets snapped back. I swear - its like a real bad turbo lag. The car only has 26k miles on it, and otherwise runs/drives great. Anyone suffer a similar problem?
Wife's X3si was like that, but just in drive. When I would kick it over to sport it was as lagged. Under warranty I would take it to the dealer and have them fix it.
Appreciate 0
      03-27-2013, 09:01 PM   #18
CivicKilla
Private
0
Rep
74
Posts

Drives: 09 E92 x-drive
Join Date: Mar 2013
Location: seattle

iTrader: (0)

Quote:
Originally Posted by Wedge1967 View Post
Wife's X3si was like that, but just in drive. When I would kick it over to sport it was as lagged. Under warranty I would take it to the dealer and have them fix it.
kickin it to sport does seem to fix the issue. Its goin to the shop.
Appreciate 0
      03-27-2013, 11:01 PM   #19
atown88
Major
atown88's Avatar
United_States
18
Rep
1,442
Posts

Drives: e90
Join Date: Apr 2010
Location: Seattle

iTrader: (0)

Hmm, yeah I can't say that i've had the problem, although I drive in Manual mode 99% of the time. Have you tried the whole, "tranny reset" thing where you turn the car halfway on and then step down on the pedal for like, 30 seconds? Some say its supposed to reset the cars throttle response that it learned over time. Try searching that on here?

Idk..
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:19 AM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST