E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Confused.. Misfire



Reply
 
Thread Tools Search this Thread
      02-06-2013, 11:29 AM   #1
Overspooled
MurderedOut
 
Overspooled's Avatar
 
Drives: 2013 c63 AMG Coupe
Join Date: Sep 2012
Location: Montreal

Posts: 333
iTrader: (0)

Confused.. Misfire

Ok so I've been getting this misfire of something.. When I go WOT with the jb4 turned on "Only", the car hesitates and backfires like crazy, engine light goes on but leaves after a couple of seconds, or if I hit a red light it starts shaking, so I shut off the engine and restart it and then everything is fine. Ok so I called the dealer and the guy that my friends recommended was fine about the jb4. So I brought it to him and since he can see through the key fob whats wrong with it, he didn't see anything. He brought the mechanic in and he plugged in his machine and took it around the street. No misfires or codes. So he told me that it wouldn't be injectors because he would get the code on his screen.. I'm lost now and it's been a while that my car has been doing this. Any help? I know I need to get the wire for jb4 to see if it throws any codes, but does anyone have an idea?
__________________
2013 C63 AMG COUPE
Overspooled is offline   Canada
0
Reply With Quote
      02-06-2013, 08:01 PM   #2
Overspooled
MurderedOut
 
Overspooled's Avatar
 
Drives: 2013 c63 AMG Coupe
Join Date: Sep 2012
Location: Montreal

Posts: 333
iTrader: (0)

No help anyone???
__________________
2013 C63 AMG COUPE
Overspooled is offline   Canada
0
Reply With Quote
      02-06-2013, 09:04 PM   #3
menewtobmw
Private First Class
 
Drives: 2007 335i
Join Date: Jun 2010
Location: Scottsdale, AZ

Posts: 160
iTrader: (1)

Until you pull codes and post them, there is not a thing we can really do, unfortunately.
__________________
2007 335i
menewtobmw is offline  
0
Reply With Quote
      02-06-2013, 09:31 PM   #4
Overspooled
MurderedOut
 
Overspooled's Avatar
 
Drives: 2013 c63 AMG Coupe
Join Date: Sep 2012
Location: Montreal

Posts: 333
iTrader: (0)

Quote:
Originally Posted by menewtobmw View Post
Until you pull codes and post them, there is not a thing we can really do, unfortunately.
Alright thanks man, i'll be ordering the usb cable tomorrow. I tried reading codes from dash but there aren't any codes!
__________________
2013 C63 AMG COUPE
Overspooled is offline   Canada
0
Reply With Quote
      02-06-2013, 09:48 PM   #5
fun2drive
BMWCCA 149159
 
fun2drive's Avatar
 
Drives: E93 335 Vert E36 M3/4
Join Date: Jul 2006
Location: Florida Panhandle

Posts: 549
iTrader: (1)

There is a bigger body of expertise at the site exclusively dedicated to boosted cars.
You will find entire threads on various aspects of tuners such as JB, Cobb, Vishnu, AA, etc.
You might try that site. I can't post it but it has:
bimmer
boost
Our forum is a great general forum but this one caters to the boosted cars.
Expect to be overwhelmed with information and you might well find another poster that has described the same problem you have...
fun2drive is offline   United_States
0
Reply With Quote
      02-06-2013, 09:52 PM   #6
skatenc123
Captain
 
skatenc123's Avatar
 
Drives: 2007 335i coupe
Join Date: Jan 2012
Location: NC

Posts: 645
iTrader: (1)

make sure you have auto clear off. but sounds like misfires. id start with spark plugs. if that doesnt work coilpacks. theres a stcky on this under the tune section also.
skatenc123 is offline  
0
Reply With Quote
      02-06-2013, 10:03 PM   #7
Overspooled
MurderedOut
 
Overspooled's Avatar
 
Drives: 2013 c63 AMG Coupe
Join Date: Sep 2012
Location: Montreal

Posts: 333
iTrader: (0)

Quote:
Originally Posted by skatenc123 View Post
make sure you have auto clear off. but sounds like misfires. id start with spark plugs. if that doesnt work coilpacks. theres a stcky on this under the tune section also.
Yea I disabled the auto clear. Even the dealer said that he can only change my spark plugs in 15,000kms which is basically when the lease is up lol. I've been reading other posts and it seems to either be spark plugs or coils. Thanks man!
__________________
2013 C63 AMG COUPE
Overspooled is offline   Canada
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:57 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST