E90Post
 


E92-lighting
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Help: ABS, DTC, Tire Pressure Warnings



Reply
 
Thread Tools Search this Thread
      02-06-2013, 04:23 PM   #1
90SLOWE
Private
 
Drives: E90 330i MT
Join Date: May 2012
Location: Dublin, CA

Posts: 66
iTrader: (0)

Garage List
2006 330i  [0.00]
Help: ABS, DTC, Tire Pressure Warnings

To start off, I have searched and read through several threads regarding these problems but the problems seem a little different from mine. Maybe I did not search well enough so here is my post.

So this is the problem with my car. I have been getting warnings for the brakes (sometimes yellow, sometimes red), the ABS, DTC, and another triangle with an exclamation mark (I believe this is for the speed sensor) as well as one for the tire pressure. Sometimes they come together sometimes only one but they keep coming on and going off again. When this happens, the speedometer goes off for the moment any one of these is happening along with the radio and throttle, this happens for a split second so I can't tell if the whole electronics of the car goes off when this happens. My date/time and the miles driven counter have also been reset a sometimes (twice when the car was switched off and I restarted it). I haven't had a chance to go to any shops to have it looked at yet but I was hoping to get some peace of mind by knowing what it might be from the forum.
90SLOWE is offline   United_States
0
Reply With Quote
      02-07-2013, 12:34 PM   #2
90SLOWE
Private
 
Drives: E90 330i MT
Join Date: May 2012
Location: Dublin, CA

Posts: 66
iTrader: (0)

Garage List
2006 330i  [0.00]
BUMP!!

If this is not the correct section for this problem, can someone please direct me to the correct section
90SLOWE is offline   United_States
0
Reply With Quote
      02-07-2013, 12:37 PM   #3
e92oholic
Captain
 
e92oholic's Avatar
 
Drives: 2013 MINI JCW GP
Join Date: Feb 2012
Location: Buffalo NY

Posts: 852
iTrader: (6)

Seems to me you need a new wheel speed sensor. I believe the back left is the one for the speedo. You need to scan the car abs module and find the code and it will tell you what sensor is faulty.

Also check your battery/charging system. A weak battery can cause many random odd faults
__________________
2013 Mini Cooper S JCW GP #361 of 500 In USA
2008 e92 335i 6 speed, Intake SOLD
2005 Sea Doo RXT (stock for now....)
2004 545i 6 speed, lots of mods- SOLD
e92oholic is offline   United_States
0
Reply With Quote
      02-07-2013, 05:53 PM   #4
centexE9x
Private
 
Drives: e9x coupe
Join Date: Dec 2012
Location: austin

Posts: 54
iTrader: (0)

Check battery voltage while driving also. If the alternator spikes over 15.5-16v it will cause everything to shutoff for a split second and come back. Usually the dsc is the most sensitive to voltage and will set faults first before other modules.
centexE9x is offline  
0
Reply With Quote
      02-10-2013, 10:44 PM   #5
skeetx3
New Member
 
Drives: e92 328i
Join Date: Aug 2010
Location: chicahgo mang

Posts: 20
iTrader: (0)

Bro I had the same exact thing you were experiencing. Brake light would flash red and yellow, DSC light, traction control light, speedometer would cut in and out and all this would happen randomly. I thght it was a wheel sensor at first and thght it could have even been the cable that runs from the battery to the fuse box but I had the car hooked up at an Indy here and basically what was happening was that my voltage would bounce from 12, 14, and as high as 16 volts which I guess was causing all my lights to come on like that. The weird thing was that my hid while driving would stay on but my rear brake lights would flash in and out whenever the lights would come on in the dash. The awesome thing is that it got rid of my rough idle too when I was at idle. I thght I was just going to have to live with that thing forever but now it stays at 600 rpms. Hope this helps man.
skeetx3 is online now   Philippines
0
Reply With Quote
      02-10-2013, 11:16 PM   #6
Hal88
Enlisted Member
 
Drives: 06 330i
Join Date: Jan 2013
Location: san diego

Posts: 36
iTrader: (0)

How about cleaning the speed sensors first and check battery volts as well.
Keep us posted, and good luck.
Hal88 is offline  
0
Reply With Quote
      02-11-2013, 11:07 PM   #7
Craigito
Captain
 
Craigito's Avatar
 
Drives: 07' E92 335i
Join Date: Nov 2006
Location: SoCal

Posts: 728
iTrader: (0)

Quote:
Originally Posted by sbv328i
Bro I had the same exact thing you were experiencing. Brake light would flash red and yellow, DSC light, traction control light, speedometer would cut in and out and all this would happen randomly. I thght it was a wheel sensor at first and thght it could have even been the cable that runs from the battery to the fuse box but I had the car hooked up at an Indy here and basically what was happening was that my voltage would bounce from 12, 14, and as high as 16 volts which I guess was causing all my lights to come on like that. The weird thing was that my hid while driving would stay on but my rear brake lights would flash in and out whenever the lights would come on in the dash. The awesome thing is that it got rid of my rough idle too when I was at idle. I thght I was just going to have to live with that thing forever but now it stays at 600 rpms. Hope this helps man.
So what was the fix?
__________________
My Original Car 335I Coupe / Space / Black Dakota / Gray Poplar / ZSP / ZPP / Step / Paddles / Nav / Hot Seats / IPOD/ Xpel HL & Fogs/ 15% F1 Tint

http://www.bimmerfest.com/forums/sho...d.php?t=226259 (Stolen Car Thread ) http://craigsbmw-eurodelivery.blogspot.com (ED Trip)
Craigito is offline  
0
Reply With Quote
      02-14-2013, 02:20 AM   #8
90SLOWE
Private
 
Drives: E90 330i MT
Join Date: May 2012
Location: Dublin, CA

Posts: 66
iTrader: (0)

Garage List
2006 330i  [0.00]
sorry.. been away from this forum for while.. i read about the battery issues so i tightened the negative terminal.. it was a little loose.. since then 120 miles.. no lights on yet.. i'm hoping it is resolved.. else i'll have to check the battery voltages..

is there a software out there that we can connect the computer to the OBDII port and get the diagnosis of the car? I know there is one for E38s and E46s but I haven't been able to find one for the e90s... if there isn't one, how would you check the battery voltages when the car is running?
90SLOWE is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:26 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST