E90Post
 


MINHS Auto Care Center
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Adaptive light control failure



Reply
 
Thread Tools Search this Thread
      10-11-2009, 06:54 PM   #1
the_e90
Enlisted Member
 
Drives: 2006 325i Sport
Join Date: Aug 2007
Location: Chicago

Posts: 43
iTrader: (0)

Adaptive light control failure

Hi guys
did any one of you ever had the adaptive light control failure warning in dash? I have a 06 325i and was wondering what kind of expense would this be? Is it just the module that controls adaptive lights or would this require a complete new xenon assembly?

Thanks
the_e90 is offline   United_States
0
Reply With Quote
      10-11-2009, 07:32 PM   #2
pruettfan
Major
 
Drives: 2006 330i
Join Date: Jul 2009
Location: Oro Valley, AZ

Posts: 1,492
iTrader: (0)

I assume the car is out of warranty. This failure is most likely of the motor or actuator for the adaptive headlights. It should not require a whole assembly change. You may want to changing the switch position from auto to manual and see if the fault goes away. The adaptive lights only work in auto. Can you tell what light is not working correctly? I would also check fuses just in case you are lucky enough to have a simple problem.
pruettfan is offline  
0
Reply With Quote
      10-11-2009, 07:41 PM   #3
Scimitar335i
Major
 
Drives: 2007 335i
Join Date: Jun 2008
Location: Bay Area

Posts: 1,316
iTrader: (12)

other than what the other guys said its gonna cost yo about 130 bucks for a new one. Go to GetBMWParts.com but get the part number from realoem.com... good luck!!
__________________
2007 TiAg e90 335i sport. Yes, The e90 "Mustache" is cool!
Scimitar335i is offline  
0
Reply With Quote
      10-11-2009, 09:01 PM   #4
AlB
Private First Class
 
AlB's Avatar
 
Drives: 2006 330i MT gry/blk
Join Date: Jun 2007
Location: SF

Posts: 187
iTrader: (1)

i would be happy if mine failed, really messes with your head during hard conering at night
__________________
06 330i gry/blk everything but iWreck, nav & pdc
carbon splitters, door trim, grill, roof spoiler
CDV delete, B&M Short shifter, cyba scoops
AlB is offline  
0
Reply With Quote
      10-12-2009, 08:43 AM   #5
the_e90
Enlisted Member
 
Drives: 2006 325i Sport
Join Date: Aug 2007
Location: Chicago

Posts: 43
iTrader: (0)

hi guys - thanks for replies. The car is out of warranty and the annoying error comes up regardless if you keep it on auto or not.

My question is that, has anyone ever DIY'ed this problem? Can you please give me more info on the $130 part?

I heard horror stories that you need to replace the entire light assembly for $1700!
the_e90 is offline   United_States
0
Reply With Quote
      10-12-2009, 10:27 AM   #6
alq80
Lieutenant
 
alq80's Avatar
 
Drives: E92 335i
Join Date: Dec 2007
Location: PA / Kuwait

Posts: 437
iTrader: (3)

Send a message via MSN to alq80
oh man, that's bad. the thing has been going out on my car 5 times now i hate to knkow what it would be like after warranty
__________________
335i . Montego Blue . HKS Exhaust .
alq80 is offline   United_States
0
Reply With Quote
      10-26-2009, 11:57 AM   #7
OscarHotel
Registered
 
Drives: E92
Join Date: Apr 2009
Location: USA

Posts: 2
iTrader: (0)

Yes, I have a wierd problem on an 08 335. Intermittent fail that resets after a complete shutdown. Am abroad at moment, but will have it checked in UK.
OscarHotel is offline  
0
Reply With Quote
      10-26-2009, 12:06 PM   #8
Tee-Dub
Captain
 
Tee-Dub's Avatar
 
Drives: 2008 135i
Join Date: May 2009
Location: Vancouver, WA

Posts: 753
iTrader: (9)

Quote:
Originally Posted by AlB View Post
i would be happy if mine failed, really messes with your head during hard conering at night
Don't use the "auto" function and the adaptive light function is turned off.
Tee-Dub is offline   United_States
0
Reply With Quote
      10-26-2009, 12:40 PM   #9
VTECaddict
Where'd my VTEC go?
 
VTECaddict's Avatar
 
Drives: 06 330i 6MT
Join Date: Mar 2009
Location: Las Vegas, NV

Posts: 4,618
iTrader: (4)

Quote:
Originally Posted by Tee-Dub View Post
Don't use the "auto" function and the adaptive light function is turned off.
But then you have to manually turn the lights on and off when you want them! How primitive!
__________________
AW/Terra | ZSP | ZPP | ZCW | iDrive | CA
Mods: BC BR | OEM Blacklines | M-tech rear | custom dual exhaust | M3 steering wheel | BMW SSK | ZHP shift knob | BMW Performance rep spoiler
Varrstoen ES1 19x9.5+20 Front, 19x11+25 rear
VTECaddict is offline  
0
Reply With Quote
      10-26-2009, 11:39 PM   #10
lonestar22
Ground Clearance?
 
lonestar22's Avatar
 
Drives: 535i
Join Date: Jul 2009
Location: DFW

Posts: 1,425
iTrader: (-1)

omg so lazy
__________________

Slammed E90. One of the First. Stay Fitted
lonestar22 is offline   United_States
0
Reply With Quote
      01-19-2010, 08:12 AM   #11
hotnikks
Private First Class
 
hotnikks's Avatar
 
Drives: E90 330 6MT
Join Date: May 2009
Location: NY/NJ

Posts: 142
iTrader: (1)

So which part is this??
__________________
hotnikks is offline   United_States
0
Reply With Quote
      01-19-2010, 08:48 PM   #12
kevinbahnz
Lieutenant
 
kevinbahnz's Avatar
 
Drives: 2008 335xi sedan
Join Date: Aug 2008
Location: Ma-NC

Posts: 479
iTrader: (1)

happened to me when I was driving home from NC. I think I was in Wilkes-barr PA. I stopped for gas and restarted the car and It worked again and still is. But I will asked the dealer to look at it when I bring it in for my 30k oil service.
__________________
<img src=http://i189.photobucket.com/albums/z164/kevinbahnz/08-23-2008030.jpg border=0 alt= />
kevinbahnz is offline  
0
Reply With Quote
      01-19-2010, 11:00 PM   #13
boilator
Private First Class
 
Drives: 2008 E90 M3
Join Date: Aug 2009
Location: East Coast

Posts: 117
iTrader: (0)

Adaptive light control failure

I had the icon show once in the last 5 months of owning the vehicle. I was sitting in the car for an hour while my son was at an appointment. I was using the BT and radio (AUX mode). When I went to start the car up, the symbol lit up and a warning chime sounded. It only fixed itself when the car was finally garaged and went into sleep mode.

I believe something funky happened with the computer and didn't reset with a restart.

I've not taken it to the dealer for this issue; don't think I will until my next oil service. Not too worried, it's working now.

Lator
boilator is offline  
0
Reply With Quote
      09-13-2010, 05:58 PM   #14
Scotts335
Private
 
Scotts335's Avatar
 
Drives: E90 335i
Join Date: Jan 2010
Location: Dallas TX

Posts: 85
iTrader: (2)

I replaced my drivers side adaptive xenon headlight and it was around $1200. I installed it myself and I got the adaptive headlight warning. I took it to BMW and it cost more than $800 to just reprogram the damn thing. Not worth it. The light does not go away no matter what setting it is on.
__________________
2007 E90 335i | JB3 Map 5 | Magnaflow | Stett CAI | Stett Charge Pipe | Tial BOV| LUX 5.0 | M3 body kit |
Scotts335 is offline  
0
Reply With Quote
      09-14-2010, 03:12 AM   #15
Kenneto
New Member
 
Drives: 2006 BMW 330i
Join Date: Aug 2009
Location: Seattle

Posts: 5
iTrader: (0)

Lightbulb Your headlight Stepper motors might be missing

To answer your question

base on my own experience, If your car dash showing adaptive light control failure warning sign. Your car headlight stepper motors might be missing (either someone before took it out or someone steal it). "You don't need to buy the whole headlight to fix this problem."

What you need to do now is to have someone check for your headlight to see if stepper motors are there. "They might need to take out the bumper to check this."

I suggest you to buy Stepper motors from BMW dealership($180 ~$240 each) and have them reprogram for you.

PS. Stepper motors doesnt level the headlight it turns them, give BMW a call

Ken Yang
Kenneto is offline  
0
Reply With Quote
      02-13-2013, 07:45 PM   #16
chinna_n
Enlisted Member
 
Drives: 2007 BMW 328i Auto
Join Date: Jan 2013
Location: Bellevue, WA

Posts: 47
iTrader: (0)

Hi,

I know this is old thread I am resurrecting, but I was wondering how it was fixed if it was fixed. I bought 2007 328i, and it is showing that error irrespective of Manual or auto mode. But few times it skipped giving me that warning in Manual mode, but it is not consistent.

Also, I did not get any error code using scangauge. I was hoping I could find which side light has issue, so that I can open that headlight. Now I do not know which side has problem. Of course I do not know what the problem is either. The auto-leveling is working fine. It does not look like projectors are hanging out of socket.

Any suggestions on how to find out which side has issues?

Thanks
chinna_n is offline  
0
Reply With Quote
      02-13-2013, 10:39 PM   #17
mike3000fl
Eleven Bravo
 
mike3000fl's Avatar
 
Drives: 06 330i
Join Date: Feb 2010
Location: ft bragg

Posts: 2,152
iTrader: (0)

Quote:
Originally Posted by chinna_n View Post
Hi,

I know this is old thread I am resurrecting, but I was wondering how it was fixed if it was fixed. I bought 2007 328i, and it is showing that error irrespective of Manual or auto mode. But few times it skipped giving me that warning in Manual mode, but it is not consistent.

Also, I did not get any error code using scangauge. I was hoping I could find which side light has issue, so that I can open that headlight. Now I do not know which side has problem. Of course I do not know what the problem is either. The auto-leveling is working fine. It does not look like projectors are hanging out of socket.

Any suggestions on how to find out which side has issues?

Thanks
Its been awhile but there is a steering wheel position sensor, that sort of ties in with the speed and some other sensors, to send a signal to two control modules (one bolted to the bottom of each headlight), that then move stepper motors to make the actual lens move.

So basically the steering angle sensor could be bad, or another input type sensor. Or it could be a bad module or stepper motor.

How i would test motors left and right:
If it were me, I would put the car in auto mode, face a wall and turn the steering right, the lights should move right, steer center and they should center. If that happens, then the left right motors are good. Cover each headlight with something to test this individually.

How i would test motors up and down:
Then test the up down of each motor by perhaps messing with the auto level on the left front driver side control arm. Depending on how much you want this fixed, jack the car up and take the wheel off, get that sensor arm off and move it up and down and look for the lights to move.

How i would test the modules:
Remove each one and switch them left to right. If one headlight didnt move and when you switch the module it does move, then the module is bad or needs recoding.

Be prepared to remove your front bumper cover, which is not that hard.
__________________
2006 330i - Jet Black - 19" E46 M3 wheels - HR Sport - 188,000 Miles...

mike3000fl is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:41 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST