E90Post
 


N54Tuning.com
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Reduced power engine malfunction randomly?



Reply
 
Thread Tools Search this Thread
      02-14-2013, 01:16 AM   #1
jokergerm
Lieutenant
29
Rep
538
Posts

 
Drives: 335i
Join Date: Oct 2010
Location: seattle

iTrader: (0)

Reduced power engine malfunction randomly?

So sometimes mainly in higher gears my n54 starts stummbling badly The check engine comes on and it says reduced power engine malufunction. All i do is restart it and its fine, as long as i dont get into the throttle alot

Does this sound like the HFPF? It does it so randomly its annoying. Other then that it runs fine and with my Jb4 on map 0 it never does it, but on map 2 it will from time to time

Iike today it was running fine, i did some 3rd gear pulls with no issues

I searched and someone else had the same issue but it was a vacuumn line. But mine comes and goes

Its a 07 335i coupe with jb4 dci 3" d
I need a E60 M5 already
__________________
Appreciate 0
      02-14-2013, 01:24 AM   #2
TC_e90
First Lieutenant
TC_e90's Avatar
United_States
3
Rep
369
Posts

 
Drives: e90 LCI 335i
Join Date: Feb 2012
Location: SoCal

iTrader: (6)

With no mods, same happened to me. Took it in the 2nd time it popped up and it was code 2A7C Dirty Intake Vanos Solenoid.
__________________
2009 TIAG e90 LCI 335i Sport
Appreciate 0
      02-14-2013, 01:27 AM   #3
2nice89
Banned
United_States
3
Rep
242
Posts

 
Drives: 2007 e92 335i
Join Date: Aug 2012
Location: Queens Village

iTrader: (0)

Garage List
2007 335i  [0.50]
sounds like a vaccuum leak...try checking your hoses...it could be a small leak n its only noticable when u run a higher psi
Appreciate 0
      02-14-2013, 01:36 AM   #4
jokergerm
Lieutenant
29
Rep
538
Posts

 
Drives: 335i
Join Date: Oct 2010
Location: seattle

iTrader: (0)

Ok ill check tommorow

What would make it be random though? Sometimes its fine during wot pulls
__________________
Appreciate 0
      02-14-2013, 06:13 AM   #5
skyguy
Private
skyguy's Avatar
0
Rep
82
Posts

 
Drives: 2007 e90 335i 6MT
Join Date: May 2012
Location: NH

iTrader: (0)

When I put in jb4 mine did that. It was the plugs.
Appreciate 0
      02-15-2013, 02:53 AM   #6
jokergerm
Lieutenant
29
Rep
538
Posts

 
Drives: 335i
Join Date: Oct 2010
Location: seattle

iTrader: (0)

Yea i have 78k on the oem plugs.
I will change them tommorow

Does this issue sound like the hpfp failing at all?
__________________
Appreciate 0
      02-15-2013, 05:05 AM   #7
n54gte
First Lieutenant
3
Rep
359
Posts

 
Drives: 07 335i
Join Date: Jun 2012
Location: CA

iTrader: (0)

sounds like misfires. change plugs then coils
Appreciate 0
      02-15-2013, 03:38 PM   #8
jokergerm
Lieutenant
29
Rep
538
Posts

 
Drives: 335i
Join Date: Oct 2010
Location: seattle

iTrader: (0)

i went to order my new plugs today and they will be here tommorow

On the way home i opened it up in 2nd gear and the half engine light came on for a second and the check engine light and then i let off and it went away

I really hope its not the HPFP but it may be
__________________
Appreciate 0
      02-15-2013, 03:42 PM   #9
tmo24
Captain
tmo24's Avatar
United_States
11
Rep
911
Posts

 
Drives: 2010 335i e90 Msport
Join Date: Aug 2010
Location: Las Vegas

iTrader: (3)

Mine had a similar issue and the dealer replaced all 6 injectors.
__________________
2010 335i AW e90 Msport
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:21 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST