E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Fuel pump question



Reply
 
Thread Tools Search this Thread
      03-09-2018, 11:17 PM   #1
jschmitty19
Private
3
Rep
92
Posts

Drives: 08 bmw 135i
Join Date: May 2015
Location: lasalle, il

iTrader: (0)

Fuel pump question

I have a 2008 bmw 335i with 105,000 miles. I started to bog down when I would accelerate hard but if I drove "normal" I would have no issues. Its has a fuel pump plausible code with service engine soon light on dash. I never went to limp mode. I uninstalled the programmer and now I can drive the car had with no issues so I'm kinda confused, is my fuel pump just failing and can't handle the added power/fuel supply or is there something else I should be looking at. I just thought it was the fuel pump but haven't got a limp mode message and it's been running fine without tune for a few weeks now as if there's nothing wrong.

Any info would be greatly appreciated before I go ordering parts to fix

Thanks
Appreciate 0
      03-11-2018, 04:27 PM   #2
jschmitty19
Private
3
Rep
92
Posts

Drives: 08 bmw 135i
Join Date: May 2015
Location: lasalle, il

iTrader: (0)

Thanks for all the help... Smh
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 06:17 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST