E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > Top strut mounts question



Reply
 
Thread Tools Search this Thread
      02-17-2013, 04:01 PM   #1
GAM
Lieutenant
 
GAM's Avatar
 
Drives: 2011 E92 M3
Join Date: Mar 2012
Location: Palm Beach

Posts: 463
iTrader: (1)

Top strut mounts question

I changed the front strut mounts on my 335i e92 with sport package with the ECS tuning ones, they are cheaper than the OEM ones. I changed them, because my car has 80k miles and recently lowered it on HR sport springs and I had a sound coming from the struts every time I was turning the steering wheel, some kind of "clac clac clac..."
Everything went well on the swap but the car steering kinda feel a little loose when accelerating hard at speeds above 50mph. Like when the weight of the car is shifting to the rear. Not something I felt before with the older strut mounts. No change while cruising, it feels kinda loose only in good accelerations.

Can it be due to the new strut mounts not being of the same quality? Probably lower quality due to lower price..

Thanks
GAM is offline  
0
Reply With Quote
      02-17-2013, 04:26 PM   #2
pits200
Lieutenant Colonel
 
Drives: 09 335i X-Drive Black Sapphire
Join Date: Mar 2010
Location: Pittsburgh

Posts: 1,897
iTrader: (0)

No, a cheap part like a strut mount won't be immediately noticeable like stated. It may not last as long but if you're hearing it right away then it's mostly install error.
pits200 is offline   United_States
0
Reply With Quote
      02-17-2013, 05:52 PM   #3
GAM
Lieutenant
 
GAM's Avatar
 
Drives: 2011 E92 M3
Join Date: Mar 2012
Location: Palm Beach

Posts: 463
iTrader: (1)

Quote:
Originally Posted by pits200
No, a cheap part like a strut mount won't be immediately noticeable like stated. It may not last as long but if you're hearing it right away then it's mostly install error.
Thanks, then it might be something different, I'll keep looking, thanks for your answer
GAM is offline  
0
Reply With Quote
      02-17-2013, 07:30 PM   #4
mike-y
just another bmw douche bag
 
Drives: 1.9L of fury
Join Date: Nov 2008
Location: Los Angeles, CA

Posts: 3,383
iTrader: (4)

Quote:
Originally Posted by Gfabry View Post
recently lowered it on HR sport springs and I had a sound coming from the struts every time I was turning the steering wheel, some kind of "clac clac clac...
sounds like you had one (or both) washers below the upper strut mounts installed upside down, which can cause rubbing of the parts when you turn the wheel.
mike-y is offline   United_States
0
Reply With Quote
      02-17-2013, 07:47 PM   #5
stilov
Lieutenant
 
Drives: 07 335i
Join Date: Mar 2009
Location: Allen, TX

Posts: 415
iTrader: (2)

the rubber in mine started tearing on both sides and I got a sound when turning the wheel...almost a plasticy sound. Gone now that I changed them.
stilov is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:06 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST