E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Radio n SOS issue



Reply
 
Thread Tools Search this Thread
      02-20-2013, 11:29 PM   #1
mightye90
New Member
 
Drives: Black e90 325i
Join Date: Nov 2012
Location: Palmdale Ca basically LA

Posts: 27
iTrader: (0)

Radio n SOS issue

Alright so the other day I got in to my car pushed the cluch pedal an started it . In a couple of seconds the SOS light on my dash popped up an had a cross threw it so I thought maybe the fuse. So I turn on the radio. It's runs fine xm am fm cd but no audio is playing out of them I look in the trunk the amp is not turning on. So I looked Around the forms an there's to many different subject about it. One of them is the amp went out. Or the fuse . Or something with a wire. An the some relay issues ext.. I really would like to here from u you guys. Maybe a DIY ? Thanks all
mightye90 is offline   United_States
0
Reply With Quote
      02-20-2013, 11:49 PM   #2
ctuna
Brigadier General
 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

Posts: 3,981
iTrader: (0)

What kind of sound system do you have?

What kind of sound system do you have?
If its L7 the amp is connected to the most bus .
Anything bad on the most bus breaks the Most Bus Loop.
And that makes all the devices on the Most Bus look bad.
Depending on the year of your car an options there
could be several devices in the loop. TCU , sdars , bmw assist are some of the common ones.
The TCU is the telephone control unit.
The thing that most commonly fails is the L7 amp.


http://www.e90post.com/forums/attach...2&d=1260829447

http://www.bawarec.ru/manuals/3er/e9...3er-e90-12.pdf

There are some places to get the amp repaired.
Repair resources
http://www.e90post.com/forums/showthread.php?t=635672
http://www.bmwgm5.com/Logic7_6941681.htm
http://cgi.ebay.com/ebaymotors/BMW-C...ioQ5fVideo#ht_
http://www.diyparadise.net/bmw_cd73_repair.html
http://www.bmwradiorepair.com/?gclid...FccbQgodIEn0Cg

Last edited by ctuna; 02-20-2013 at 11:55 PM.
ctuna is offline  
0
Reply With Quote
      02-21-2013, 02:25 AM   #3
mightye90
New Member
 
Drives: Black e90 325i
Join Date: Nov 2012
Location: Palmdale Ca basically LA

Posts: 27
iTrader: (0)

It's a 07 325i with the logic 7 it think it's a big silver amp in the trunk. I believe it's the logic 7 one sounds amazing
mightye90 is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:48 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST