E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Chargepipe leak?



Reply
 
Thread Tools Search this Thread
      02-25-2013, 09:28 PM   #1
solow
Just to sweet
United_States
7
Rep
245
Posts

Drives: 07 335i
Join Date: May 2012
Location: New York

iTrader: (0)

Exclamation Chargepipe leak?

I recently installed a ER chargepipe on my 335i and today i notices that there was some oil around the connection the the engine---i used the original clamp(clip).I have pulled on it with some strenght and it doesnt seem to be comming off..any idea why there might be some oil around that connection and if i can do something for a tighter seal...?
Appreciate 0
      02-25-2013, 09:41 PM   #2
135Hoser
Custom User Title
135Hoser's Avatar
3
Rep
261
Posts

Drives: 09 135i
Join Date: Jul 2011
Location: Canada, Eh

iTrader: (0)

If its oil then it's likely your turbo seals are going, or you are getting excessive blow-by past the rings.

You'll either want an oil catch can, or to investigate new turbos as that's likely the cause.

Standard worm clamps are the best way to go. You could try doubling up, or spraying a little bit of hairspray on the inside of the silicone connector after cleaning all the oil residue off of all surfaces.
__________________
2009 135i
AR Resonated DPs, Line Lock Kit | HPF FMIC | Forge DV's | BMW PE | BMS DCI, OCC, JB4 G5 | Meth
Still todo: Wavetrac LSD, Suspension bits
Appreciate 0
      02-25-2013, 09:44 PM   #3
solow
Just to sweet
United_States
7
Rep
245
Posts

Drives: 07 335i
Join Date: May 2012
Location: New York

iTrader: (0)

you think my turbos might be going??? or should i lean towards the catch can
Appreciate 0
      02-25-2013, 10:06 PM   #4
solow
Just to sweet
United_States
7
Rep
245
Posts

Drives: 07 335i
Join Date: May 2012
Location: New York

iTrader: (0)

bump
Appreciate 0
      02-25-2013, 10:24 PM   #5
E90Company
Major General
E90Company's Avatar
No_Country
79
Rep
6,136
Posts

Drives: Car
Join Date: Mar 2012
Location: FL

iTrader: (2)

Did you install the o-ring inside ER's pipe from the stock CP?
Appreciate 0
      02-25-2013, 11:13 PM   #6
solow
Just to sweet
United_States
7
Rep
245
Posts

Drives: 07 335i
Join Date: May 2012
Location: New York

iTrader: (0)

No i didn't i just read that in another forum so i will have to fix that tomorow. Tx for your input.:-)


Quote:
Originally Posted by E90Company View Post
Did you install the o-ring inside ER's pipe from the stock CP?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 09:05 AM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST