E90Post
 


Motormavericks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > All-Wheel-Drive (Xi / xDrive) Talk > Clicking Noise From Drivers Front



Reply
 
Thread Tools Search this Thread
      02-25-2013, 05:46 PM   #1
isd8266
Enlisted Member
United_States
1

 
isd8266's Avatar
 
Drives: 2009 335i Xdrive
Join Date: Aug 2012
Location: central ny


Posts: 47
iTrader: (0)

Clicking Noise From Drivers Front

Hey Guys,

I have a 2009 335i Xdrive with 60k miles on it. Has anyone every had a slight clicking noise when turning into a parking lot at a higher speed? I have noticed it probably about 5 times so far and it happens when I am turning into a parking lot going at a higher speed. It's a clicking noise that comes from the drivers front. I'm afraid it may be the final drive but I'm not a 100% sure. Has anyone else had this issue and if so what did it turn out to be?

Thanks in advance
Appreciate 0
      02-26-2013, 12:44 PM   #2
stratplaya06
Captain
United_States
11

 
stratplaya06's Avatar
 
Drives: 2008 E92 335xi
Join Date: May 2008
Location: Maryland


Posts: 886
iTrader: (7)

Sounds like a CV joint clicking to me. Mine click just a bit around parking lots and I am at 87k and have had to replace the boot/repack the joint on the driver front once. Nothing really to worry about until it gets worse IMO.
__________________

| PROcede Rev3 | Vishnu Meth | DCI | BMW Perf. Exhaust | AR Coated/Catless | CP-E FMIC | Quaife |
Appreciate 0
      02-28-2013, 09:37 AM   #3
StevenIam
Private
0

 
Drives: just fine (2009 335i)
Join Date: Feb 2013
Location: Toronto


Posts: 76
iTrader: (0)

Definitely sounds like the cv joint. Get it checked out as soon as possible, it will only get worse if you don't.
Appreciate 0
      03-01-2013, 01:44 PM   #4
vapore0n
Lieutenant
4

 
Drives: 2010 335i
Join Date: Jul 2011
Location: MA


Posts: 461
iTrader: (0)

Same vote.

Now, I used to have a chevy car that had the clicking noise. The only thing I did to fix it was replace the boot grease. Car had around 90k miles and when I took the boot out, the grease was liquid.
Removing the joint might have helped in putting things back in place through.
Clicking went away, no need to replace anything but the boot and grease
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:05 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST