E90Post
 


N54Tuning.com
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Right taillight malfunction sign comes up, but taillight seems to be fine?



Reply
 
Thread Tools Search this Thread
      02-27-2013, 10:23 PM   #1
Newmember343
Private First Class
 
Drives: 07 E92 328xi
Join Date: Jan 2013
Location: Chicago, IL

Posts: 171
iTrader: (2)

Right taillight malfunction sign comes up, but taillight seems to be fine?

The right taillight brake malfunction sign comes up when I start my car, i checked my taillight and everything was lighting fine? Why am I getting this message?
Newmember343 is offline  
0
Reply With Quote
      02-28-2013, 01:23 AM   #2
Fun w/N54
First Lieutenant
 
Drives: '11 E92 335is AW/CR/DCT
Join Date: Apr 2011
Location: WI

Posts: 356
iTrader: (0)

Same here today then drove around and it went away. Not sure if related or not but do recall more than a few bulb replacements showing up on carfax's when I was looking.
Fun w/N54 is offline   United_States
0
Reply With Quote
      02-28-2013, 01:28 AM   #3
Taaaaaam
New Member
 
Drives: 2009 328i coupe
Join Date: May 2012
Location: Los Angeles

Posts: 21
iTrader: (0)

Maybe it's the bulb for when you sharp brake.
Taaaaaam is offline   United_States
0
Reply With Quote
      02-28-2013, 02:22 AM   #4
raleedy
Lieutenant Colonel
 
Drives: F10 528i MY 2013
Join Date: Jul 2005
Location: Portland, Oregon

Posts: 1,820
iTrader: (0)

It could be helpful to know when your car was built. A batch of E92 cars built before late January 2008 had bad socket panels for the outer taillights. Wear and corrosion cause discontinuity and intermittent bulb warnings. Do a search if your car falls in this range. The parts were redesigned. Replacements are cheap and easy to install.
raleedy is offline   United_States
0
Reply With Quote
      02-28-2013, 07:03 AM   #5
Fun w/N54
First Lieutenant
 
Drives: '11 E92 335is AW/CR/DCT
Join Date: Apr 2011
Location: WI

Posts: 356
iTrader: (0)

1/2009 build for me. Will check panel if frequency increases.

thanks
Fun w/N54 is offline   United_States
0
Reply With Quote
      02-28-2013, 07:16 AM   #6
HPF 335i #1
Captain
 
Drives: 2008 E92 335i 6AT
Join Date: Sep 2009
Location: Ft. Riley Kansas

Posts: 858
iTrader: (0)

My car did that for about 3 months... one to two times a day... then it just stoped. Its a 2008, 12/07 build.
__________________
FFTEC Single Turbo, HPF FMIC, HPF OCC, HPF Exhaust, KW V1, M3 Front & Rear Roll Bars, M3 Control Arms, Rear Toe Arms, M3 Sub Bushings, WT LSD, VMR 710s, Stop Tech Brakes, AEM Boost Pods, CF Boot Lid, Vented CF Hood, M-Tech Front, Aluminum Pedals, LED Shifter, Mat Black front Grill.
HPF 335i #1 is offline  
0
Reply With Quote
      02-28-2013, 10:48 AM   #7
Newmember343
Private First Class
 
Drives: 07 E92 328xi
Join Date: Jan 2013
Location: Chicago, IL

Posts: 171
iTrader: (2)

I believe mine is april 2007, so that puts so that puts me in the bad socket range
Newmember343 is offline  
0
Reply With Quote
      02-28-2013, 11:02 AM   #8
georgelb
First Lieutenant
 
georgelb's Avatar
 
Drives: E92 335i
Join Date: Apr 2010
Location: DFW, TX

Posts: 316
iTrader: (1)

Garage List
2007 335i  [4.00]
2000 Civic  [3.50]
Someone backed into my parked car (yay) and broke the cover on the driver's trunk lid light. The bulbs still function, but I'm getting two separate errors for the bulbs in that assembly every time I start the car.

So, just because the bulb lights, doesn't mean there isn't something wrong. The bulb might be going bad and is outside the normal load range or something; I'd probably go ahead and replace it.
__________________
georgelb is offline   United_States
0
Reply With Quote
      02-28-2013, 07:22 PM   #9
C.D.335xi
Private First Class
 
C.D.335xi's Avatar
 
Drives: 2014 Z4 35is
Join Date: Apr 2008
Location: CDN embassies around the world

Posts: 181
iTrader: (0)

Garage List
2014 Z4 35is  [0.00]
There is an SIB for this issue - see attached.
Attached Images
File Type: pdf BMW SIB for rear bulb failure.pdf (113.9 KB, 189 views)
__________________
2014 Z4 35is Deep Sea Blue
2009 E92 335i X-Drive 6MT - Sold
C.D.335xi is offline   Canada
0
Reply With Quote
      02-28-2013, 07:28 PM   #10
John 070
Lieutenant General
 
Drives: 335i cpe
Join Date: Oct 2006
Location: ZSP/ZPP/ZCW

Posts: 11,265
iTrader: (0)

This happened to me before Xmas....put one new 921LL in and been good ever since. Same thing, right brake failure but bulbs worked. One that came out was a little black in color.
John 070 is offline  
0
Reply With Quote
      03-01-2013, 12:16 PM   #11
Newmember343
Private First Class
 
Drives: 07 E92 328xi
Join Date: Jan 2013
Location: Chicago, IL

Posts: 171
iTrader: (2)

Thanks for all the input guys, gonna pick up some new bulbs!
Newmember343 is offline  
0
Reply With Quote
      03-01-2013, 12:39 PM   #12
GoRomeo
Lieutenant Colonel
 
GoRomeo's Avatar
 
Drives: 330i
Join Date: Feb 2006
Location: San Diego CA

Posts: 1,920
iTrader: (0)

Garage List
2006 330i  [2.83]
check for loose wires, connections etc. Sometimes this causes warning light to got off Ive heard.
GoRomeo is offline  
0
Reply With Quote
      03-01-2013, 02:00 PM   #13
Fun w/N54
First Lieutenant
 
Drives: '11 E92 335is AW/CR/DCT
Join Date: Apr 2011
Location: WI

Posts: 356
iTrader: (0)

Quote:
Originally Posted by C.D.335xi View Post
There is an SIB for this issue - see attached.
Thank you sir...my Jan 2009 build falls into this boat.
Fun w/N54 is offline   United_States
0
Reply With Quote
      04-02-2013, 06:53 AM   #14
virtualbong
Major
 
virtualbong's Avatar
 
Drives: 2007 E92 328xi
Join Date: Jun 2009
Location: Boston, MA

Posts: 1,490
iTrader: (2)

Quote:
Originally Posted by C.D.335xi View Post
There is an SIB for this issue - see attached.
Thanks! I believe I am still under CPO so this should be taken care of by the dealership.
__________________
2007 e92 328xi (Jet Black)
virtualbong is offline  
0
Reply With Quote
      04-02-2013, 10:15 AM   #15
Prissy
Brigadier General
 
Prissy's Avatar
 
Drives: e92
Join Date: Sep 2008
Location: nyc

Posts: 3,632
iTrader: (3)

Have the dealer replace the WHOLE housing and not just the light bulb. It's a well known problem for e92s
Prissy is offline   Taiwan
0
Reply With Quote
      04-04-2013, 03:34 PM   #16
Ron1n
Speed Demon
 
Ron1n's Avatar
 
Drives: '10 335d E90
Join Date: Oct 2009
Location: The 858

Posts: 3,248
iTrader: (4)

Garage List
2010 335d  [5.00]
The SIB actually calls for both tails to be replaced. Just had mine done last week.
Ron1n is offline   United_States
0
Reply With Quote
      04-04-2013, 04:22 PM   #17
1QuikWS6
No 55mph
 
1QuikWS6's Avatar
 
Drives: 09 E92 328iX N51 3-Stage
Join Date: Jul 2009
Location: Blitzburgh, PA

Posts: 4,124
iTrader: (78)

Garage List
Had this happen on my 2009 E92 (2/09 Build Date) - it was NOT the bulbs.

Took it to the dealer, they stated 3-series cars weren't affected by the TSB - only 1 series??? Pulled out a copy of the TSB - they ended up replacing both bulb holders & bam! no more ghost errors

These should be replaced BOTH sides with new version:



Shown are the new versions - couldn't really tell any difference between the old & new, but I didn't spend a lot of time comparing...
__________________
2009 328ix E92//SGM//ACS Roof Spoiler//MTech Aero Lip+Trunk Spoiler//M3 Side Skirts//CF Roundels+Grilles//M3 Novillo Interior//Perf Shift Lever+Boot//MPerf DCT Wheel//M3 GT3 eBrake Handle+Boot//ACS Pedals//M3 Mirrors//LCI Tails w/LUX Rev//DTEC V7 AE+MTec 6000K D1S+HPB HID 6000K Fogs//HPB LED Interior//RPI Scoops//CF Euro Airbox+Underhood Hsgs//K&N//BMW PE//MTech Rear Bumper-iS Sport Diffuser//CF Strut Brace//Vishnu OFT//BMW 193M's+Kumho 4X
1QuikWS6 is offline   United_States
0
Reply With Quote
      04-04-2013, 06:04 PM   #18
virtualbong
Major
 
virtualbong's Avatar
 
Drives: 2007 E92 328xi
Join Date: Jun 2009
Location: Boston, MA

Posts: 1,490
iTrader: (2)

I am dropping off my car to the dealership on Monday. The guy kept on saying that they would have to check it out even after I told him that there was a TSB for it and that my brake lights were working just fine. I am going to bring the printout of it so that they have it.

Also getting the recall power wire done too.
__________________
2007 e92 328xi (Jet Black)
virtualbong is offline  
0
Reply With Quote
      04-05-2013, 11:56 AM   #19
DarkNemesis
Lieutenant
 
Drives: 2007 BMW 335i Sedan
Join Date: Oct 2012
Location: Vancouver

Posts: 418
iTrader: (0)

Got the car, all lights worked, but idrive and dash stated rear signal lights malfunction.

Went to mechanic.
He stated it was the bulbs, and told me which ones. But all my lights worked....hmmm.

Changed them, and malfunction gone.

The thing to note: my 335i Sedan is a Sept 2006 built.
Also when I said my cars lights all worked.... Kinda not true.
I didn't realize it, till I paid attention to another e90 I was following.
Then I realized, my turn signals were lighting up a different bulb.
Hmmmm.
BMW has smarts in it, that if a bulb goes out, it compensates to use another, so, that the safety of the driver is not sacrificed.
Hence why we see a malfunction, rather than a really fast turn signal.

Just thought I put my experience to you.

DN
DarkNemesis is offline  
0
Reply With Quote
      04-05-2013, 12:30 PM   #20
bimmer_335
Captain
 
Drives: 335i Coupe
Join Date: Jul 2009
Location: Plano, TX

Posts: 781
iTrader: (1)

Does this still apply when your car is out of warranty?
bimmer_335 is offline  
0
Reply With Quote
      04-05-2013, 02:11 PM   #21
ERIC212NYC
Second Lieutenant
 
ERIC212NYC's Avatar
 
Drives: 2009 328i
Join Date: Feb 2009
Location: Queens, NY

Posts: 238
iTrader: (1)

Quote:
Originally Posted by bimmer_335 View Post
Does this still apply when your car is out of warranty?
I like to know as well since that warning is annoying.
ERIC212NYC is offline   United_States
0
Reply With Quote
      04-05-2013, 03:03 PM   #22
VNeBLOB42
Lieutenant Colonel
 
VNeBLOB42's Avatar
 
Drives: 14' GMC Terrain SLT-2
Join Date: May 2011
Location: Folsom, Ca

Posts: 1,678
iTrader: (0)

Garage List
007 335i E92  [3.83]
Send a message via Skype™ to VNeBLOB42
Quote:
Originally Posted by raleedy View Post
It could be helpful to know when your car was built. A batch of E92 cars built before late January 2008 had bad socket panels for the outer taillights. Wear and corrosion cause discontinuity and intermittent bulb warnings. Do a search if your car falls in this range. The parts were redesigned. Replacements are cheap and easy to install.
THIS

mine started doing this about 3 months ago. Comes back here and there. So freaking annoying.

EDIT:

just sent the PDF to my SA, I'll see what he says and post with an update.
__________________

SOLD:: PTF Pro eTune by Dzenno / COBB S1+ E50
Alpina B3 Flash / ETS FMIC / ER CP / CPE DCI

Last edited by VNeBLOB42; 04-05-2013 at 03:10 PM.
VNeBLOB42 is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:25 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST