E90Post
 


MINHS Auto Care Center
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > G5 ISO weak compared to G4



Closed Thread
 
Thread Tools Search this Thread
      03-04-2013, 04:23 AM   #1
andrew335i
Banned
2
Rep
96
Posts

 
Drives: 2009 335i e92
Join Date: Jan 2013
Location: Newburgh, NY

iTrader: (0)

G5 ISO weak compared to G4

Me and my friend both up graded our G4 boards to the new G5 ISO. We both got the same results... weaker pull. It is more smooth, ill give it that.. but its weaker. I cant break traction in 2nd gear anymore.. with the G4 I would. I can get logs later but as ive seen a few other people with this problem, as well as my friend... im wondering if the iso version isnt as good as we thought? I didnt change a thing on my car while going from g4 to g5 iso. I seen a thread in which someone had this issue and had luck when they went back to G5 NON ISO. Imt hinking about this route...
Appreciate 0
      03-04-2013, 07:09 AM   #2
rush jamaica
Captain
rush jamaica's Avatar
6
Rep
697
Posts

 
Drives: 2006 330i bmw
Join Date: Feb 2010
Location: ga

iTrader: (0)

Garage List
2006 E90  [0.00]
Hmm did it too yesterday and it feels real good to me but I did notice the 2nd did not break traction (as much as) when I had the G4 but that G5 is sick man I had an open road to auto tune and got wide open woo that's all I could say.
Appreciate 0
      03-04-2013, 07:45 AM   #3
andrew335i
Banned
2
Rep
96
Posts

 
Drives: 2009 335i e92
Join Date: Jan 2013
Location: Newburgh, NY

iTrader: (0)

Quote:
Originally Posted by rush jamaica
Hmm did it too yesterday and it feels real good to me but I did notice the 2nd did not break traction (as much as) when I had the G4 but that G5 is sick man I had an open road to auto tune and got wide open woo that's all I could say.
It's still strong... I just feel like I've lost 1-2psi in auto tune.
Appreciate 0
      03-04-2013, 08:12 AM   #4
Transport3r
Maaaaaaaaaaaaaad
Transport3r's Avatar
14
Rep
1,206
Posts

 
Drives: N54 E92 & N52 Z4
Join Date: Sep 2010
Location: Melbourne, FL

iTrader: (2)

Quote:
Originally Posted by andrew335i View Post
t is more smooth, ill give it that.. but its weaker. I cant break traction in 2nd gear anymore.. with the G4 I would.
That's why. Jerky acceleration causes traction loss. Smooth is good.
Same thing happened to me 2 years ago when the procede started running dynamic ignition correction. It smoothened the whole curve out, giving the impression of less power. It's just a feeling though, i doubt you actually lost power. If anything you gained a little..
__________________
Josh-

Appreciate 0
      03-04-2013, 08:38 AM   #5
andrew335i
Banned
2
Rep
96
Posts

 
Drives: 2009 335i e92
Join Date: Jan 2013
Location: Newburgh, NY

iTrader: (0)

Quote:
Originally Posted by Transport3r
Quote:
Originally Posted by andrew335i View Post
t is more smooth, ill give it that.. but its weaker. I cant break traction in 2nd gear anymore.. with the G4 I would.
That's why. Jerky acceleration causes traction loss. Smooth is good.
Same thing happened to me 2 years ago when the procede started running dynamic ignition correction. It smoothened the whole curve out, giving the impression of less power. It's just a feeling though, i doubt you actually lost power. If anything you gained a little..
I understand but boost gauge was showing 1-2psi less as well.
Appreciate 0
      03-04-2013, 09:11 AM   #6
rush jamaica
Captain
rush jamaica's Avatar
6
Rep
697
Posts

 
Drives: 2006 330i bmw
Join Date: Feb 2010
Location: ga

iTrader: (0)

Garage List
2006 E90  [0.00]
I think when the new update comes it will feel better and we need to try and mess with the wastegate setting I see my gauge fall when it hits the target so I think it was just the auto tune working in
Appreciate 0
      03-04-2013, 09:31 AM   #7
Transport3r
Maaaaaaaaaaaaaad
Transport3r's Avatar
14
Rep
1,206
Posts

 
Drives: N54 E92 & N52 Z4
Join Date: Sep 2010
Location: Melbourne, FL

iTrader: (2)

Quote:
Originally Posted by andrew335i View Post
I understand but boost gauge was showing 1-2psi less as well.
I'd do some datalogging and confirm you are running less boost by comparing to older logs, then increase the boost!
__________________
Josh-

Appreciate 0
      03-04-2013, 09:34 AM   #8
andrew335i
Banned
2
Rep
96
Posts

 
Drives: 2009 335i e92
Join Date: Jan 2013
Location: Newburgh, NY

iTrader: (0)

Quote:
Originally Posted by Transport3r
Quote:
Originally Posted by andrew335i View Post
I understand but boost gauge was showing 1-2psi less as well.
I'd do some datalogging and confirm you are running less boost by comparing to older logs, then increase the boost!
I don't have older logs. I'm just going off of the fuel gauge hijacking.
Appreciate 0
      03-04-2013, 06:04 PM   #9
psmitty95
Brigadier General
psmitty95's Avatar
United_States
104
Rep
3,772
Posts

 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

iTrader: (8)

Idk why but I felt like my iso was weaker also... Here's my threads from a few months back

http://www.e90post.com/forums/showthread.php?t=781177
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: Cobb V3 w/ Motiv Tune, VRSF DP/FMIC, ER CP, Roc-Euro DCI, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
Appreciate 0
      03-04-2013, 06:10 PM   #10
Jeff@TopGearSolutions
BimmerPost Supporting Vendor
Jeff@TopGearSolutions's Avatar
United_States
247
Rep
18,427
Posts


 
Drives: C6 Z06, GSXR-750, 09 335i
Join Date: Dec 2008
Location: TopGearSolutions.com

iTrader: (32)

Send a message via AIM to Jeff@TopGearSolutions
What is the boost graph compared from G4 to G5? Car should feel the same if the boost is the same unless ignition is less.

Do a before and after datalog and that will likely lead you to your answer.
Appreciate 0
      03-04-2013, 06:15 PM   #11
andrew335i
Banned
2
Rep
96
Posts

 
Drives: 2009 335i e92
Join Date: Jan 2013
Location: Newburgh, NY

iTrader: (0)

Quote:
Originally Posted by psmitty95
Idk why but I felt like my iso was weaker also... Here's my threads from a few months back

http://www.e90post.com/forums/showthread.php?t=781177
Did you find a fix? Or did you go back to non ISO?
Appreciate 0
      03-04-2013, 06:15 PM   #12
andrew335i
Banned
2
Rep
96
Posts

 
Drives: 2009 335i e92
Join Date: Jan 2013
Location: Newburgh, NY

iTrader: (0)

Quote:
Originally Posted by Jeff@TopGearSolutions
What is the boost graph compared from G4 to G5? Car should feel the same if the boost is the same unless ignition is less.

Do a before and after datalog and that will likely lead you to your answer.
Sent terry my logs

Also- in 4th gear wot at around 125mph the engine picture pops up and car goes into limp mode did this with g4 too
Appreciate 0
      03-04-2013, 06:18 PM   #13
Sparky68
Brigadier General
Sparky68's Avatar
United Kingdom
51
Rep
3,205
Posts

 
Drives: e90 335i JB4
Join Date: Oct 2012
Location: Cambs

iTrader: (10)

Garage List
2007 BMW 335i  [0.00]
Quote:
Originally Posted by andrew335i View Post
Sent terry my logs

Also- in 4th gear wot at around 125mph the engine picture pops up and car goes into limp mode did this with g4 too
30FF ?
__________________

LM Reps - Borla Exhaust - Active Autowerks Chargepipe and Blow Off - JB4 G5 ISO - Burger Tuning Intake - Koni Street Shocks - Apex Springs - Whiteline Bushes - M3 rear Arms
Appreciate 0
      03-04-2013, 06:26 PM   #14
PR3CI5N
need4speed
PR3CI5N's Avatar
United_States
15
Rep
1,240
Posts

 
Drives: 2010 E90 M 335i
Join Date: Jun 2010
Location: West Coast

iTrader: (15)

What are your mods? And were you running E-85?
__________________
N54
Appreciate 0
      03-04-2013, 06:44 PM   #15
andrew335i
Banned
2
Rep
96
Posts

 
Drives: 2009 335i e92
Join Date: Jan 2013
Location: Newburgh, NY

iTrader: (0)

Quote:
Originally Posted by PR3CI5N
What are your mods? And were you running E-85?
No e85. Mods are VRSF DPs and DCI.
Appreciate 0
      03-04-2013, 06:51 PM   #16
4doorbmwpower
Captain
4doorbmwpower's Avatar
United_States
13
Rep
701
Posts

 
Drives: Montego Blue E90 335i
Join Date: Nov 2010
Location: North Carolina

iTrader: (1)

Send a message via Skype™ to 4doorbmwpower
well with the G5 you can actually run more PSI (18 in race map up from 16.5) and you have more control but loosing traction doesnt mean your car is faster it means your PSI is starting too heavy.. in the G5 it has a great curve and reaches higher levels when you wont get wheelspin and tappers off well.. although in autotune it may need a few pulls to reconfig (it is a learning device)
Appreciate 0
      03-04-2013, 06:53 PM   #17
PR3CI5N
need4speed
PR3CI5N's Avatar
United_States
15
Rep
1,240
Posts

 
Drives: 2010 E90 M 335i
Join Date: Jun 2010
Location: West Coast

iTrader: (15)

Quote:
Originally Posted by andrew335i View Post
No e85. Mods are VRSF DPs and DCI.
Well the G5 ISO board is intended for higher horsepower cars so I'd try running some E-85 and try a few WOT's. I have virtually the same mods and when I upgraded to the G5 ISO I felt a huge increase in smoothness and power. I definitely don't have a problem with breaking my tires loose, more like trying to save the tread on my PSS's.
__________________
N54
Appreciate 0
      03-04-2013, 07:14 PM   #18
Jeff@TopGearSolutions
BimmerPost Supporting Vendor
Jeff@TopGearSolutions's Avatar
United_States
247
Rep
18,427
Posts


 
Drives: C6 Z06, GSXR-750, 09 335i
Join Date: Dec 2008
Location: TopGearSolutions.com

iTrader: (32)

Send a message via AIM to Jeff@TopGearSolutions
Quote:
Originally Posted by andrew335i View Post
Sent terry my logs

Also- in 4th gear wot at around 125mph the engine picture pops up and car goes into limp mode did this with g4 too
Probably a misfire, that's why you need to read the codes...

Did you read the Sticky for new tuners? http://www.e90post.com/forums/showthread.php?t=631829
Appreciate 0
      03-04-2013, 09:07 PM   #19
andrew335i
Banned
2
Rep
96
Posts

 
Drives: 2009 335i e92
Join Date: Jan 2013
Location: Newburgh, NY

iTrader: (0)

Terry replied and said "given the timing, the jb4 seems to be hitting its targets" so I'm left with no answer to why I lost power.

Who wants to trade their g5 for g5 ISO? My car no likeyyy
Appreciate 0
      03-04-2013, 09:14 PM   #20
Jeff@TopGearSolutions
BimmerPost Supporting Vendor
Jeff@TopGearSolutions's Avatar
United_States
247
Rep
18,427
Posts


 
Drives: C6 Z06, GSXR-750, 09 335i
Join Date: Dec 2008
Location: TopGearSolutions.com

iTrader: (32)

Send a message via AIM to Jeff@TopGearSolutions
Quote:
Originally Posted by andrew335i View Post
Terry replied and said "given the timing, the jb4 seems to be hitting its targets" so I'm left with no answer to why I lost power.

Who wants to trade their g5 for g5 ISO? My car no likeyyy
Why are you so quick to get rid of it? Did you even troubleshoot your CEL ?

You realize the G5 is fine, you need to do your due diligence here....

Find out what the CEL is for and fix that, first. You may be misfiring, or have a boost leak.
Appreciate 0
      03-04-2013, 09:23 PM   #21
andrew335i
Banned
2
Rep
96
Posts

 
Drives: 2009 335i e92
Join Date: Jan 2013
Location: Newburgh, NY

iTrader: (0)

Quote:
Originally Posted by Jeff@TopGearSolutions View Post
Why are you so quick to get rid of it? Did you even troubleshoot your CEL ?

You realize the G5 is fine, you need to do your due diligence here....

Find out what the CEL is for and fix that, first. You may be misfiring, or have a boost leak.
dude that CEL has nothing to do with the power loss. Like previously stated.. I got that on my G4 too. Okay the power loss happened immediately going from g4 to g5iso. NOTHING changed but that... its the g5 iso. anyways.. heres my log if you guys know how to read this and can give me some input. Im sorry but 13 PSI on autotune with DPs, and DCI is not correct.

Appreciate 0
      03-04-2013, 09:27 PM   #22
Jeff@TopGearSolutions
BimmerPost Supporting Vendor
Jeff@TopGearSolutions's Avatar
United_States
247
Rep
18,427
Posts


 
Drives: C6 Z06, GSXR-750, 09 335i
Join Date: Dec 2008
Location: TopGearSolutions.com

iTrader: (32)

Send a message via AIM to Jeff@TopGearSolutions
Quote:
Originally Posted by andrew335i View Post
dude that CEL has nothing to do with the power loss. Like previously stated.. I got that on my G4 too. Okay the power loss happened immediately going from g4 to g5iso. NOTHING changed but that... its the g5 iso. anyways.. heres my log if you guys know how to read this and can give me some input. Im sorry but 13 PSI on autotune with DPs, and DCI is not correct.

Dude?

Do you know what a boost leak is or a misfire?

I'm trying to help but you clearly just dont want to think your G5 magically made your car slow when there can be systematic and logical approaches to figure out how.
Appreciate 0
Closed Thread

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:35 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST