E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Brake Pad Light on



Reply
 
Thread Tools Search this Thread
      08-31-2007, 10:12 AM   #1
Crimson92
Smiling Politely
Crimson92's Avatar
United_States
301
Rep
28,648
Posts

 
Drives: Like a boss
Join Date: Jun 2007
Location: Whales Vagina

iTrader: (3)

Brake Pad Light on

My cluster has a picture of my car on a lift in red and the brake light on.

I checked the book and apparently its the brake pad light. I only have 1k miles , is there any reason why it would turn on.

Should I remove my JB when I take it to the dealer?
__________________
Quote:
Some people are like slinkies...not really good for much but you can't help but smile when you see one tumble down the stairs"
Appreciate 0
      08-31-2007, 10:46 AM   #2
nmulax
Brigadier General
nmulax's Avatar
United_States
68
Rep
4,324
Posts

 
Drives: '07 Z4 M Coupe
Join Date: May 2006
Location: Metro-Detroit

iTrader: (5)

Garage List
2007 Z4M Coupé  [3.83]
Hmm... brake pad light after 1k miles; something's wrong. Could be a problem with the pad sensor, or an electrical glitch.

As for removing the JB; I don't think it'll show up on a computer scan. So I guess it just depends on if the tech visually sees it. How tough is it to remove?
__________________
Appreciate 0
      08-31-2007, 11:10 AM   #3
Crimson92
Smiling Politely
Crimson92's Avatar
United_States
301
Rep
28,648
Posts

 
Drives: Like a boss
Join Date: Jun 2007
Location: Whales Vagina

iTrader: (3)

takes about 5 mins, 10 if youre really careful....i guess ill take it off tonight and take it to the dealer tomorrow
__________________
Quote:
Some people are like slinkies...not really good for much but you can't help but smile when you see one tumble down the stairs"
Appreciate 0
      09-01-2007, 02:22 AM   #4
M3 Piotr
Lieutenant Colonel
M3 Piotr's Avatar
Poland
56
Rep
1,711
Posts

 
Drives: E90 M3 Frozen Black
Join Date: Apr 2007
Location: K-Town, Germany / Andrews AFB, MD

iTrader: (1)

Garage List
Hey,
check this link, might be helpful. I have the same issue, already went to dealer once, and they reset it, inspected the brakes and everything was fine, light came back couple days later, and since I'm close to my service, they just want to do it all at once. SA claims it's a software glitch, since it shows that i'm due for brake pads, but the reading from the key is telling them that brake pads are good for another "397,000 miles"...crazy. I do show the same red brake pad error, and when I first start the car it's the car on the lift display. Some people had their calipers worked on because of that.

http://www.e90post.com/forums/showthread.php?t=77199
__________________

2011 E90 M3 Frozen Black (1 of 1)
///M Flight
Appreciate 0
      09-01-2007, 04:25 PM   #5
Crimson92
Smiling Politely
Crimson92's Avatar
United_States
301
Rep
28,648
Posts

 
Drives: Like a boss
Join Date: Jun 2007
Location: Whales Vagina

iTrader: (3)

Turns out it was just a glitch...but im sure that light will come back
__________________
Quote:
Some people are like slinkies...not really good for much but you can't help but smile when you see one tumble down the stairs"
Appreciate 0
      09-02-2007, 12:50 PM   #6
Soni
Major General
Soni's Avatar
Canada
99
Rep
8,377
Posts

 
Drives: Just a car
Join Date: Feb 2007
Location: CANADA eh!

iTrader: (35)

Garage List
2007 335i Coupe  [4.50]
my came on when I was at 2000k, when to dealer and they reset it for me. it came on again on 5000k, took it to dealer again, this time they replaced the sensors.
Appreciate 0
      09-13-2007, 11:14 PM   #7
sambonator
Samtaro!
sambonator's Avatar
United_States
44
Rep
2,549
Posts

 
Drives: a car
Join Date: May 2007
Location: Milky Way Galaxy

iTrader: (6)

My light just came on yesterday. I have just under 3900 miles on the car .
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:54 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST