E90Post
 


GT Haus
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Downpipes and Exhaust!



Reply
 
Thread Tools Search this Thread
      08-31-2007, 10:42 PM   #1
rideelement247
Lieutenant Colonel
United_States
24
Rep
1,677
Posts

 
Drives: 08 335i, 67 Camaro SS
Join Date: May 2007
Location: South Florida

iTrader: (2)

Send a message via AIM to rideelement247
Downpipes and Exhaust!

Well my Ultimate Racing downpipes and full exhaust were installed yesterday. I stuck with the catless DP because of the extra HP and the meaner sound. They sound REAAAAAAAAAAAALLLLY loud and mean, omg it is so hard to put this amazing sound into words.

But, two problems I want to ask the forums about (hopefully Riss Racing will read this because I'm comparing their product to Ultimate Racing)

I threw an engine code today in the afternoon...must have been about 98 - 100 degress outside. was racing around with my friends in South Florida for about 10 - 15 minutes, then had to meet my girlfriend for lunch. As I pulled into the parking lot I got a code: yellow light with half of the engine blacked out, which I understood to be limp mode. Strange thing is, I didn't seem to lose any power whatsoever, if anything it was more sluggish before the code than after lol. I had put a total of about 20 - 30 miles on the exhaust at the point and believe it is because its the end of a so called "driving cycle" in which the ECU monitors everything and counts stops and gos, etc. and then throws a code after the driving cycle. So I ate lunch for about an hour worrying about my warranty because BMW mmight be sneaky and count the O2 sensor in the DP as electrical and void my warranty - my biggest concern is the 4 yr free service warranty...if that is voided, I'm shafted(does anyone know if my service warranty is voided now???). After lunch, went to the car...no more error. Drove about 4 - 5 miles and got the same error code, and once again I did not feel like I lost any power. About 30 minutes later, I restarted the car and the CEL was gone but now my SERVICE ENGINE SOON light is on and has remained on all day. Does anyone know what is causing the CEL? The place that installed my DP + exhaust configuration claims they did everything by the book, they took all the old stuff off and replaced it with the new stuff and put everything back in the original place. If the Riss Racing DPs are catless, then they must be just pipes like mine are, so what in the world is throwing the CEL, if the Riss Racing DPs aren't throwing any???(Riss if you read this, please please please pm me with a checklist of things to look for on the car from one BMW owner to another please, thanks).

The second problem is with the sound of the exhaust. When in park and revving the car sounds amazing, same in neutral and revving(automatic trans). But when I am driving down the road and only push the pedal about 1/4 to 1/2 of the way down to moderately accelerate I get a raspy noise like a giant metal vibration noise(which sounds ricey). It mostly happens in the 1.5 - 2 RPM range, but any moderate acceleration does it as well. Does anyone have any thoughts on this issue? I thought it could be a poor welding job, or the exhaust is loose, or that the exhaust is rubbing/touching something. That, or does anyone believe that it is the natural sound of the exhaust? The tips didnt exactly fit under the bumper of the car, the guys at the shop had to cut off some of the underside inner edge of the bumper, about a half inch. The tips are still resting on the inside of the bumper, however. To smewhat clarify this, the tip on the driver's side is somewhat sitting on the right side of the cutout-hole for the exhaust tip, and visa versa for the tip on the passenger side(with it sitting on the left side of the bumper). Could this also be attributed to the sound?

Sorry if I was too detailed in writing this up, just making sure I provide you all wil as much as I can to help me diagnose these problems. Thanks guys.

And if Riss Racing gets a hold of this thread, thanks if you can give me any help.
__________________
Legal Disclaimer: Anything I or anyone else says about my vehicle on this website(e90post.com or any affiliated or nonaffiliated sites), pertaining to modifications, is only to gain acceptance from my/our peers, and does not actually represent anything actually existing on my car, and thus, cannot be held against me in any issues, i.e. warranty claims, that may arise.
Appreciate 0
      08-31-2007, 10:48 PM   #2
E90ice
Banned
E90ice's Avatar
51
Rep
2,004
Posts

 
Drives: 2008 335xi Coupe
Join Date: May 2006
Location: WA

iTrader: (0)

Do you have a code reader? Try buying one...for like $60. That will tell us exectly what the problem is.
__________________
Appreciate 0
      08-31-2007, 10:54 PM   #3
rideelement247
Lieutenant Colonel
United_States
24
Rep
1,677
Posts

 
Drives: 08 335i, 67 Camaro SS
Join Date: May 2007
Location: South Florida

iTrader: (2)

Send a message via AIM to rideelement247
No code reader on-hand. I will see if I can get the code read tomorrow after work at the place I got the stuff installed at. If not, could you give a guess to what is the issue?
__________________
Legal Disclaimer: Anything I or anyone else says about my vehicle on this website(e90post.com or any affiliated or nonaffiliated sites), pertaining to modifications, is only to gain acceptance from my/our peers, and does not actually represent anything actually existing on my car, and thus, cannot be held against me in any issues, i.e. warranty claims, that may arise.
Appreciate 0
      08-31-2007, 10:55 PM   #4
sflgator
Major General
sflgator's Avatar
82
Rep
5,389
Posts

 
Drives: '09 MB C63 AMG & '08 MB GL450
Join Date: Oct 2006
Location: U.S.

iTrader: (1)

Geez....I hope you get all this resolved. The raspy sounds you hear may just be the exhaust; what kind of exhaust...the same UR or another exhaust? Does it have an X pipe or just straight dual pipes?

Anyway, I'm sure much more experienced ppl will chime in to help. This is one reason why I've resisted from getting DPs and/or an exhaust...just too many potential issues -- possible codes, possible droning, possible raspy sounds, too loud, possible install problems/errors, etc...uggghh! Sorry about your issues; hopefully, you can get them resolved and enjoy your new mods.
__________________

|2009 RENNtech MB C63 AMG | Black/Black Leather/Black Maple | Premium II | MultiMedia | iPod |
| TeleAid | Charcoal Filter Delete | BMC High-Flow Air Filters | High-Flow Secondary Cats | Clear Side Markers |
Appreciate 0
      08-31-2007, 10:57 PM   #5
335iheLLraiseR
اوليسيس
335iheLLraiseR's Avatar
United_States
70
Rep
4,661
Posts

 
Drives: e92 335
Join Date: Jun 2007
Location: sfl

iTrader: (8)

Garage List
2007 e92 335  [5.00]
hey, congrats on the install! can't help you much with out the C-reader like E90ice mentioned. Do you have a PROcede installed, because they usually come with one. I have one if you need it.

have you felt a difference?

where in South Florida are you, i'd love an opportunity to hear that thing.

edit: out of curiosity, what shop did you go to?
__________________
Quote:
Originally Posted by lawdude View Post
Anyone who can transition seamlessly from defending one vendor and bashing another vendor to bashing the one he formally defended and defending the one he formally bashed has a instant credibility problem.
<---Sign up Now for Bonus Storage! Up to 10gb!
Appreciate 0
      08-31-2007, 10:59 PM   #6
rideelement247
Lieutenant Colonel
United_States
24
Rep
1,677
Posts

 
Drives: 08 335i, 67 Camaro SS
Join Date: May 2007
Location: South Florida

iTrader: (2)

Send a message via AIM to rideelement247
The pipes are all UR piping, except for the cans and the tips. The resonator cans are Magnaflow and the tips I believe are Magnaflow as well.

When I opened the package, the welding looked clean, and the guy who installed it agreed.

It is a true X-pipe, btw.
__________________
Legal Disclaimer: Anything I or anyone else says about my vehicle on this website(e90post.com or any affiliated or nonaffiliated sites), pertaining to modifications, is only to gain acceptance from my/our peers, and does not actually represent anything actually existing on my car, and thus, cannot be held against me in any issues, i.e. warranty claims, that may arise.
Appreciate 0
      08-31-2007, 11:01 PM   #7
rideelement247
Lieutenant Colonel
United_States
24
Rep
1,677
Posts

 
Drives: 08 335i, 67 Camaro SS
Join Date: May 2007
Location: South Florida

iTrader: (2)

Send a message via AIM to rideelement247
Quote:
Originally Posted by 335iheLLraiseR View Post
hey, congrats on the install! can't help you much with out the C-reader like E90ice mentioned. Do you have a PROcede installed, because they usually come with one. I have one if you need it.

have you felt a difference?

where in South Florida are you, i'd love an opportunity to hear that thing.
Man I am in Ft Lauderdale!!! AWESOME! Come see me this weekend, or we can meet halfway somewhere. The things sound amazing. I do not own a PROcede, but i would LOVE to have one. I'll trade you a audio hearing of my exhaust for the PROcede .

Anyways, could you help meread the code this weekend? I would greatly appreciate it. I don't have the buckaroos to spend on a C-reader or to have it read at a shop.

And yes, there is a considerable difference in power. With DTC on the wheels squeal like a beaten pig. With it off they rip a little and then launch. It really is amazing.
__________________
Legal Disclaimer: Anything I or anyone else says about my vehicle on this website(e90post.com or any affiliated or nonaffiliated sites), pertaining to modifications, is only to gain acceptance from my/our peers, and does not actually represent anything actually existing on my car, and thus, cannot be held against me in any issues, i.e. warranty claims, that may arise.
Appreciate 0
      08-31-2007, 11:02 PM   #8
sflgator
Major General
sflgator's Avatar
82
Rep
5,389
Posts

 
Drives: '09 MB C63 AMG & '08 MB GL450
Join Date: Oct 2006
Location: U.S.

iTrader: (1)

Quote:
Originally Posted by rideelement247 View Post
The pipes are all UR piping, except for the cans and the tips. The resonator cans are Magnaflow and the tips I believe are Magnaflow as well.

When I opened the package, the welding looked clean, and the guy who installed it agreed.

It is a true X-pipe, btw.
Did you contact UR for help?
__________________

|2009 RENNtech MB C63 AMG | Black/Black Leather/Black Maple | Premium II | MultiMedia | iPod |
| TeleAid | Charcoal Filter Delete | BMC High-Flow Air Filters | High-Flow Secondary Cats | Clear Side Markers |
Appreciate 0
      08-31-2007, 11:07 PM   #9
rideelement247
Lieutenant Colonel
United_States
24
Rep
1,677
Posts

 
Drives: 08 335i, 67 Camaro SS
Join Date: May 2007
Location: South Florida

iTrader: (2)

Send a message via AIM to rideelement247
I haven't had time to contat UR about the problem.

When they sold them to me, they said as long as the install went ok, the DP wouldnt throw a code, as their car did not throw any codes on their 1500 miles or so of testing. They did say it COULD, but they said it wasn't likely.

Not sure how to approach them on it, because, from what I understand, if the O2 sensor was installed wrong the CEL would have been thrown immediately. But then again, maybe it took the "drive cycle" to have it show anything. The install guys had no instructions or anything to work off of, so maybe they confused the O2 sensors, but I doubt it.
__________________
Legal Disclaimer: Anything I or anyone else says about my vehicle on this website(e90post.com or any affiliated or nonaffiliated sites), pertaining to modifications, is only to gain acceptance from my/our peers, and does not actually represent anything actually existing on my car, and thus, cannot be held against me in any issues, i.e. warranty claims, that may arise.
Appreciate 0
      08-31-2007, 11:08 PM   #10
heyitzkian
Private
0
Rep
75
Posts

 
Drives: E92 335i
Join Date: Dec 2006
Location: Miami

iTrader: (0)

I'm assuming since you have DP's and full exhaust, you have no cats on your car now, that's the main reason why you have a CEL code going off. I'm new to the bimmer scene, but I was wondering if anybody including Riss or UR has come up with a 02 Simulator [either mechanical or through wire splicing] solution.
Appreciate 0
      08-31-2007, 11:11 PM   #11
sflgator
Major General
sflgator's Avatar
82
Rep
5,389
Posts

 
Drives: '09 MB C63 AMG & '08 MB GL450
Join Date: Oct 2006
Location: U.S.

iTrader: (1)

Quote:
Originally Posted by rideelement247 View Post
I haven't had time to contat UR about the problem.

When they sold them to me, they said as long as the install went ok, the DP wouldnt throw a code, as their car did not throw any codes on their 1500 miles or so of testing. They did say it COULD, but they said it wasn't likely.

Not sure how to approach them on it, because, from what I understand, if the O2 sensor was installed wrong the CEL would have been thrown immediately. But then again, maybe it took the "drive cycle" to have it show anything. The install guys had no instructions or anything to work off of, so maybe they confused the O2 sensors, but I doubt it.
Hmmm....that's the first thing I would've dome...call UR! Yes, call them and explain exactly what happened; I'm sure they can help you out, or at the very least, give you some ideas as to what happened and how to possibly resolve. Just b/c their car didn't throw any codes doesn't mean other cars won't...and they should stand behind their product and assist their customers who have problems.
__________________

|2009 RENNtech MB C63 AMG | Black/Black Leather/Black Maple | Premium II | MultiMedia | iPod |
| TeleAid | Charcoal Filter Delete | BMC High-Flow Air Filters | High-Flow Secondary Cats | Clear Side Markers |
Appreciate 0
      08-31-2007, 11:11 PM   #12
rideelement247
Lieutenant Colonel
United_States
24
Rep
1,677
Posts

 
Drives: 08 335i, 67 Camaro SS
Join Date: May 2007
Location: South Florida

iTrader: (2)

Send a message via AIM to rideelement247
Quote:
Originally Posted by heyitzkian View Post
I'm assuming since you have DP's and full exhaust, you have no cats on your car now, that's the main reason why you have a CEL code going off. I'm new to the bimmer scene, but I was wondering if anybody including Riss or UR has come up with a 02 Simulator [either mechanical or through wire splicing] solution.
Very possible the CEL from no cats, but Riss' downpipes don't throw any codes. And they are caless as well.

To be honest, I love these things so much, I think losing the warranty might be worth it, if it comes to that.

Service shouldnt be that bad, as long as I don't blow my turbos or engine lol.
__________________
Legal Disclaimer: Anything I or anyone else says about my vehicle on this website(e90post.com or any affiliated or nonaffiliated sites), pertaining to modifications, is only to gain acceptance from my/our peers, and does not actually represent anything actually existing on my car, and thus, cannot be held against me in any issues, i.e. warranty claims, that may arise.
Appreciate 0
      08-31-2007, 11:12 PM   #13
grymattr
Private
0
Rep
82
Posts

 
Drives: 2007 335i
Join Date: Apr 2007
Location: Earth

iTrader: (0)

The raspiness is there to stay - the reason is you don't have resonators on the pipes you replaced the cats with. If you had gone with the high flow cats you'd not be hearing that. I do not know if anyone makes those pipes with resonators or not.

BTW - this is a rather common problem on many cars if you do a cat delete. I had the same problem on my Z - test pipes. It's unbearable in that car after a while with that sound.

On the plus side - your ride sounds incredible - I'm envious.

Keep the peace





Dean
Appreciate 0
      08-31-2007, 11:12 PM   #14
335iheLLraiseR
اوليسيس
335iheLLraiseR's Avatar
United_States
70
Rep
4,661
Posts

 
Drives: e92 335
Join Date: Jun 2007
Location: sfl

iTrader: (8)

Garage List
2007 e92 335  [5.00]
Quote:
Originally Posted by sflgator View Post
Hmmm....that's the first thing I would've dome...call UR! Yes, call them and explain exactly what happened; I'm sure they can help you out, or at the very least, give you some ideas as to what happened and how to possibly resolve. Just b/c their car didn't theow any codes doesn't mean other cars won't...and they should stand behind their product and assist their customers who have problems.
+1
__________________
Quote:
Originally Posted by lawdude View Post
Anyone who can transition seamlessly from defending one vendor and bashing another vendor to bashing the one he formally defended and defending the one he formally bashed has a instant credibility problem.
<---Sign up Now for Bonus Storage! Up to 10gb!
Appreciate 0
      08-31-2007, 11:14 PM   #15
sflgator
Major General
sflgator's Avatar
82
Rep
5,389
Posts

 
Drives: '09 MB C63 AMG & '08 MB GL450
Join Date: Oct 2006
Location: U.S.

iTrader: (1)

Quote:
Originally Posted by heyitzkian View Post
I'm assuming since you have DP's and full exhaust, you have no cats on your car now, that's the main reason why you have a CEL code going off. I'm new to the bimmer scene, but I was wondering if anybody including Riss or UR has come up with a 02 Simulator [either mechanical or through wire splicing] solution.
That's what I was thinking; I wonder if he can call UR and switch the DPs out to the high-flow catted DPs instead (@ n/c to the customer of course )?
__________________

|2009 RENNtech MB C63 AMG | Black/Black Leather/Black Maple | Premium II | MultiMedia | iPod |
| TeleAid | Charcoal Filter Delete | BMC High-Flow Air Filters | High-Flow Secondary Cats | Clear Side Markers |
Appreciate 0
      08-31-2007, 11:15 PM   #16
sflgator
Major General
sflgator's Avatar
82
Rep
5,389
Posts

 
Drives: '09 MB C63 AMG & '08 MB GL450
Join Date: Oct 2006
Location: U.S.

iTrader: (1)

Quote:
Originally Posted by rideelement247 View Post
Very possible the CEL from no cats, but Riss' downpipes don't throw any codes. And they are caless as well.

To be honest, I love these things so much, I think losing the warranty might be worth it, if it comes to that.

Service shouldnt be that bad, as long as I don't blow my turbos or engine lol.
Yeah, but you DON'T want to throw codes on a daily basis either.

Dude, I know it sounds great now, but you might get sick of the raspiness and the CELs...very quickly. I feel bad for 'ya...live and learn though.

btw -- for the $$ you spent on the DPs and exhaust, you could just get PROcede v2.0, return the DPs and exhaust (if possible) and go back to your stock exhaust?????? Your car may not sound as good, but it would still be A LOT faster!!!!!
__________________

|2009 RENNtech MB C63 AMG | Black/Black Leather/Black Maple | Premium II | MultiMedia | iPod |
| TeleAid | Charcoal Filter Delete | BMC High-Flow Air Filters | High-Flow Secondary Cats | Clear Side Markers |
Appreciate 0
      08-31-2007, 11:19 PM   #17
rideelement247
Lieutenant Colonel
United_States
24
Rep
1,677
Posts

 
Drives: 08 335i, 67 Camaro SS
Join Date: May 2007
Location: South Florida

iTrader: (2)

Send a message via AIM to rideelement247
Quote:
Originally Posted by sflgator View Post
Yeah, but you DON'T want to throw codes on a daily basis either.
True, but the codes havent been thrown after the second one, and I've started/restarted my car at least 3 - 5 times after it happened and made a considerable driv eeach time.

All that happens is that my Service Engine Soon light is on. Which I can deal with, since I am not losing any power . I would prefer to get it off tho lol.

335ihellraiser is going to visit me this weekend hopefully and bring his C-Reader toread the code and we can post the info on here about which code it is, etc.

Thanks for all the input though guys, keep it coming.
__________________
Legal Disclaimer: Anything I or anyone else says about my vehicle on this website(e90post.com or any affiliated or nonaffiliated sites), pertaining to modifications, is only to gain acceptance from my/our peers, and does not actually represent anything actually existing on my car, and thus, cannot be held against me in any issues, i.e. warranty claims, that may arise.
Appreciate 0
      08-31-2007, 11:21 PM   #18
rideelement247
Lieutenant Colonel
United_States
24
Rep
1,677
Posts

 
Drives: 08 335i, 67 Camaro SS
Join Date: May 2007
Location: South Florida

iTrader: (2)

Send a message via AIM to rideelement247
The raspy sound isn't so bad when you are in sports drive. Odd, but idk why. Maybe because it accelerates to a higher RPM quicker, which avoids that 1.5 - 2 RPM range where if I am at 1.5 - 2 and mash the gas in drive, a raspy sound occurs.

I think I can live with it kowing that people who are outside my car think it sounds sick.
__________________
Legal Disclaimer: Anything I or anyone else says about my vehicle on this website(e90post.com or any affiliated or nonaffiliated sites), pertaining to modifications, is only to gain acceptance from my/our peers, and does not actually represent anything actually existing on my car, and thus, cannot be held against me in any issues, i.e. warranty claims, that may arise.
Appreciate 0
      08-31-2007, 11:24 PM   #19
rideelement247
Lieutenant Colonel
United_States
24
Rep
1,677
Posts

 
Drives: 08 335i, 67 Camaro SS
Join Date: May 2007
Location: South Florida

iTrader: (2)

Send a message via AIM to rideelement247
Quote:
Originally Posted by sflgator View Post
btw -- for the $$ you spent on the DPs and exhaust, you could just get PROcede v2.0, return the DPs and exhaust (if possible) and go back to your stock exhaust?????? Your car may not sound as good, but it would be A LOT faster!!!!!
Indeed, that is true. But my parents won't let me chip it until I am 18 and insurance in my name, liability is mine, etc. Good thing October 24 is coming close!!
__________________
Legal Disclaimer: Anything I or anyone else says about my vehicle on this website(e90post.com or any affiliated or nonaffiliated sites), pertaining to modifications, is only to gain acceptance from my/our peers, and does not actually represent anything actually existing on my car, and thus, cannot be held against me in any issues, i.e. warranty claims, that may arise.
Appreciate 0
      08-31-2007, 11:27 PM   #20
sflgator
Major General
sflgator's Avatar
82
Rep
5,389
Posts

 
Drives: '09 MB C63 AMG & '08 MB GL450
Join Date: Oct 2006
Location: U.S.

iTrader: (1)

Quote:
Originally Posted by rideelement247 View Post
Indeed, that is true. But my parents won't let me chip it until I am 18 and insurance in my name, liability is mine, etc. Good thing October 24 is coming close!!
No offense, but your parents should be kicking themselves for getting you a highly-moddable sub-5 sec. F/I Twin Turbo car like the 335i in the first place. j/k
__________________

|2009 RENNtech MB C63 AMG | Black/Black Leather/Black Maple | Premium II | MultiMedia | iPod |
| TeleAid | Charcoal Filter Delete | BMC High-Flow Air Filters | High-Flow Secondary Cats | Clear Side Markers |
Appreciate 0
      08-31-2007, 11:29 PM   #21
rideelement247
Lieutenant Colonel
United_States
24
Rep
1,677
Posts

 
Drives: 08 335i, 67 Camaro SS
Join Date: May 2007
Location: South Florida

iTrader: (2)

Send a message via AIM to rideelement247
Quote:
Originally Posted by sflgator View Post
No offense, but your parents should be kicking themselves for getting your a sub-5 sec. car like the 335i in the first place. j/k
no lol. grandma bought i for me b/c my 18th was coming up and I was doing so well in school. besides she can drop money like that with no problem. She likes the idea of helping out a poor grandson.
__________________
Legal Disclaimer: Anything I or anyone else says about my vehicle on this website(e90post.com or any affiliated or nonaffiliated sites), pertaining to modifications, is only to gain acceptance from my/our peers, and does not actually represent anything actually existing on my car, and thus, cannot be held against me in any issues, i.e. warranty claims, that may arise.
Appreciate 0
      08-31-2007, 11:30 PM   #22
sflgator
Major General
sflgator's Avatar
82
Rep
5,389
Posts

 
Drives: '09 MB C63 AMG & '08 MB GL450
Join Date: Oct 2006
Location: U.S.

iTrader: (1)

Quote:
Originally Posted by rideelement247 View Post
no lol. grandma bought i for me b/c my 18th was coming up and I was doing so well in school. besides she can drop money like that with no problem. She likes the idea of helping out a poor grandson.
As long as you don't kill yourself or others while enjoying it so much. Anyway, good luck...I hope you get all this resolved.

btw -- where are u going to college next year? UF????
__________________

|2009 RENNtech MB C63 AMG | Black/Black Leather/Black Maple | Premium II | MultiMedia | iPod |
| TeleAid | Charcoal Filter Delete | BMC High-Flow Air Filters | High-Flow Secondary Cats | Clear Side Markers |
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:31 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST