E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Instrument cluster blank



Reply
 
Thread Tools Search this Thread
      03-09-2013, 09:07 PM   #1
fizzerd
Captain
 
fizzerd's Avatar
 
Drives: 328i
Join Date: May 2007
Location: Canada

Posts: 706
iTrader: (11)

Instrument cluster blank

Have an e90 and my cluster is totally blank since today. Radio, heating work. Clock and dates on the radio are blank and when I tried to set it, it cannot be set.

Any ideas? My car is an '07. Since radio, windows and everything else is working, I dont think it can be the battery..
fizzerd is offline   Canada
0
Reply With Quote
      03-19-2013, 01:12 PM   #2
chargingbear
Private
 
Drives: E91 330D
Join Date: Oct 2012
Location: London

Posts: 60
iTrader: (3)

Just had this happen to me today, did you resolve the issue?
chargingbear is offline  
0
Reply With Quote
      03-19-2013, 03:15 PM   #3
ctuna
Brigadier General
 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

Posts: 4,208
iTrader: (0)

Check fuses first.

Check fuses first.
The fuse panel is behind the glove compartment
there is a fuse map there to.
The 07 and on ward have a recall for the fuse panel
connector also the connector on for the hot line is known
to intermittently fail . This can be verified by shaking the hot
line. It can cause the car to stop operating while you are driving
it.
ctuna is offline  
0
Reply With Quote
      03-20-2013, 08:37 AM   #4
chargingbear
Private
 
Drives: E91 330D
Join Date: Oct 2012
Location: London

Posts: 60
iTrader: (3)

Well I have checked the cluster fuse and it blows immediately a new one in put in so there's my problem. It's an issue with fuse 74 - the OBD and cluster fuse (for lci cars that is). So looks like its a short or an earth issue. I will investigate further later on tonight and hopefully find the issue myself otherwise can see a nasty bill coming
chargingbear is offline  
0
Reply With Quote
      03-21-2013, 04:35 PM   #5
christopherboyce
Enlisted Member
 
Drives: 2009 328i xDrive, 2006 325i
Join Date: Mar 2013
Location: Kansas City

Posts: 30
iTrader: (0)

Garage List
Disconnect your battery and then insert the fuse - reconnect the battery. I had a similar issue happen in my '06 (fuses kept blowing when replaced).
christopherboyce is offline   United_States
0
Reply With Quote
      03-25-2013, 02:19 PM   #6
chargingbear
Private
 
Drives: E91 330D
Join Date: Oct 2012
Location: London

Posts: 60
iTrader: (3)

Thanks for that, will give it a try tomorrow and post back.
chargingbear is offline  
0
Reply With Quote
      03-26-2013, 10:49 AM   #7
chargingbear
Private
 
Drives: E91 330D
Join Date: Oct 2012
Location: London

Posts: 60
iTrader: (3)

Quote:
Originally Posted by christopherboyce
Disconnect your battery and then insert the fuse - reconnect the battery. I had a similar issue happen in my '06 (fuses kept blowing when replaced).
Many thanks followed your advice and worked a treat, cheers.
chargingbear is offline  
+1
Reply With Quote
      10-11-2013, 09:45 PM   #8
christopherboyce
Enlisted Member
 
Drives: 2009 328i xDrive, 2006 325i
Join Date: Mar 2013
Location: Kansas City

Posts: 30
iTrader: (0)

Garage List
Quote:
Originally Posted by chargingbear View Post
Thanks for that, will give it a try tomorrow and post back.
Good to hear! Also, this works with pretty much any vehicle (I've had to do the same for others, as well, that kept popping upon insert).
christopherboyce is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:52 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST