E90Post
 


MINHS Auto Care Center
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > DTC, ABS, Start Assist and Cruise Control Failure



Reply
 
Thread Tools Search this Thread
      03-10-2013, 06:18 PM   #1
tmarshall57
Lieutenant
 
Drives: E90 330d
Join Date: Apr 2008
Location: Bury, Lancs, UK

Posts: 452
iTrader: (0)

Garage List
DTC, ABS, Start Assist and Cruise Control Failure

I have the 3 warnings (ABS, DTC and Start Assist) plus Cruise Control doesn't work.

Can this be anything else other than a failed ABS Hydro unit?
__________________
e90 330d, Montego Blue, Beige Dakota Leather, Auto, Nav Pro, Bluetooth Prep, BMW Connected Drive, Voice Control, Sports Seats, Split Rear Seat, 18" Ellipsoid Wheels Style 162 Burr Walnut Trim
tmarshall57 is offline   United Kingdom
0
Reply With Quote
      03-10-2013, 06:21 PM   #2
chris_s1
Major
 
Drives: 2012 E92 335d MSport
Join Date: Jun 2009
Location: Swindon, UK

Posts: 1,078
iTrader: (0)

Garage List
2012 E92 335d  [4.33]
How strange I came on here to post almost the exact same message! This just started happening to me today. From what I've read it seems a wheel speed sensor or the steering angle sensor are the most likely culprits.

I used a generic fault code reader and read the code "C09F2" but I can't find anything on what this might relate to.....
__________________
2012 Alpine White E92 335d M Sport LCI | Coral Red Dakota Leather | Media Package - BMW Professional | 313 Wheels | Evolved |
Previously - 2009 Alpine White 325d M Sport LCI | Auto + Paddles | Media Package - BMW Professional | BMW Performance Front, Sideskirts and 313P Wheels | Black Grilles |
Carbon Black E46 ///M3 '04 | Manual | Evolved |
chris_s1 is offline   United Kingdom
0
Reply With Quote
      03-10-2013, 06:36 PM   #3
makkan00
Major General
 
makkan00's Avatar
 
Drives: E91 330D
Join Date: Dec 2011
Location: Essex

Posts: 6,797
iTrader: (47)

It could be early signs of battery failure as well.
Start with battery health check first.
__________________
makkan00 is offline   United Kingdom
0
Reply With Quote
      03-10-2013, 06:37 PM   #4
tmarshall57
Lieutenant
 
Drives: E90 330d
Join Date: Apr 2008
Location: Bury, Lancs, UK

Posts: 452
iTrader: (0)

Garage List
Hi Chris

I've read the same as you but the most common solution appears to be repairing the DSC Hydro Unit (the mechanical pump rather than the electrical module). There is a common issue in that a pressure detector fails which causes the warning lights. I have had this problem since January and the warning lights occasionally disappear. When the lights are on the ABS is definitely inoperative. When the lights are off - the ABS works. I have ordered an INPA cable to check the codes.

If it does prove to be the Hydro Unit then the repair kit for my part number is £800. Other almost identical part on 3 and 1 series are around£140.

If it proves to be the Hydo unit I plan to have it repaired by Bbareman or ECU Testing or suchlike.

I would just like to know 100% whether the hydro dsc unit is the cause.
__________________
e90 330d, Montego Blue, Beige Dakota Leather, Auto, Nav Pro, Bluetooth Prep, BMW Connected Drive, Voice Control, Sports Seats, Split Rear Seat, 18" Ellipsoid Wheels Style 162 Burr Walnut Trim
tmarshall57 is offline   United Kingdom
0
Reply With Quote
      03-10-2013, 06:42 PM   #5
chris_s1
Major
 
Drives: 2012 E92 335d MSport
Join Date: Jun 2009
Location: Swindon, UK

Posts: 1,078
iTrader: (0)

Garage List
2012 E92 335d  [4.33]
I see thanks. Mine is slightly different - despite what the lights are saying the ABS actually works all the time, but the TCS etc does not function. After a couple of minutes of driving everything clears and all systems work normally again. But the fault reappears everytime the car is restarted......

I've just remembered I have an INPA cable already, I'll read the codes properly
__________________
2012 Alpine White E92 335d M Sport LCI | Coral Red Dakota Leather | Media Package - BMW Professional | 313 Wheels | Evolved |
Previously - 2009 Alpine White 325d M Sport LCI | Auto + Paddles | Media Package - BMW Professional | BMW Performance Front, Sideskirts and 313P Wheels | Black Grilles |
Carbon Black E46 ///M3 '04 | Manual | Evolved |
chris_s1 is offline   United Kingdom
0
Reply With Quote
      03-10-2013, 06:43 PM   #6
tmarshall57
Lieutenant
 
Drives: E90 330d
Join Date: Apr 2008
Location: Bury, Lancs, UK

Posts: 452
iTrader: (0)

Garage List
Quote:
Originally Posted by makkan00 View Post
It could be early signs of battery failure as well.
Start with battery health check first.
I'll check the battery but the error/warning lights came on suddenly at the end of a trip from the NW to London in January when the battery should have been showing full charge. The warnings lights also sometimes disappear a few minutes into a new journey.
__________________
e90 330d, Montego Blue, Beige Dakota Leather, Auto, Nav Pro, Bluetooth Prep, BMW Connected Drive, Voice Control, Sports Seats, Split Rear Seat, 18" Ellipsoid Wheels Style 162 Burr Walnut Trim
tmarshall57 is offline   United Kingdom
0
Reply With Quote
      03-10-2013, 07:26 PM   #7
PowerCorrupts
Private First Class
 
Drives: E92 325d
Join Date: Apr 2012
Location: Cambridgeshire

Posts: 129
iTrader: (1)

I had this problem - a similar light show on my dash came up a few weeks back but they were on constantly and would never go away.

It turned out to be the steering angle sensor - I tried resetting it my self (Didn't seem to work), Ended up paying a local specialist £62 to do the same thing and turn the wheel a few times ...

Could be worth a try to see if you can get it to work though
PowerCorrupts is offline   United Kingdom
0
Reply With Quote
      03-11-2013, 06:06 PM   #8
tmarshall57
Lieutenant
 
Drives: E90 330d
Join Date: Apr 2008
Location: Bury, Lancs, UK

Posts: 452
iTrader: (0)

Garage List
Quote:
Originally Posted by PowerCorrupts View Post
I had this problem - a similar light show on my dash came up a few weeks back but they were on constantly and would never go away.

It turned out to be the steering angle sensor - I tried resetting it my self (Didn't seem to work), Ended up paying a local specialist £62 to do the same thing and turn the wheel a few times ...

Could be worth a try to see if you can get it to work though
Thanks, I've seen this as the cheapest way to eliminate the problem, or at least a potential cause. I'm away for a few days now but my plan is to extract the codes and take it from there.

Am I right in assuming that the warning lights will cause MOT failure (due in April)?
__________________
e90 330d, Montego Blue, Beige Dakota Leather, Auto, Nav Pro, Bluetooth Prep, BMW Connected Drive, Voice Control, Sports Seats, Split Rear Seat, 18" Ellipsoid Wheels Style 162 Burr Walnut Trim
tmarshall57 is offline   United Kingdom
0
Reply With Quote
      03-12-2013, 10:14 AM   #9
chris_s1
Major
 
Drives: 2012 E92 335d MSport
Join Date: Jun 2009
Location: Swindon, UK

Posts: 1,078
iTrader: (0)

Garage List
2012 E92 335d  [4.33]
Well mine turned out to be a wheel speed sensor faulty. Although since it first appeared right after I'd washed the car, its more than likely that some dirt got it or I somehow ruined it with the sprayer...

Impressed with Dick Lovett Swindon - phoned them up yesterday afternoon, they advised me to bring it in next day - dropped off at 8.30, they had diagnosed, ordered the part, had it delivered, fitted it and ready to go by 3pm.....not bad indeed.
__________________
2012 Alpine White E92 335d M Sport LCI | Coral Red Dakota Leather | Media Package - BMW Professional | 313 Wheels | Evolved |
Previously - 2009 Alpine White 325d M Sport LCI | Auto + Paddles | Media Package - BMW Professional | BMW Performance Front, Sideskirts and 313P Wheels | Black Grilles |
Carbon Black E46 ///M3 '04 | Manual | Evolved |
chris_s1 is offline   United Kingdom
0
Reply With Quote
      03-12-2013, 05:17 PM   #10
Dr Dave
Zummerzet Zyder Drinker!
 
Dr Dave's Avatar
 
Drives: '06 330D Le Mans Blue
Join Date: May 2009
Location: Somerset

Posts: 5,540
iTrader: (3)

Garage List
Quote:
Originally Posted by tmarshall57 View Post
Am I right in assuming that the warning lights will cause MOT failure (due in April)?
Yes, correct - an MOT fail for the ABS light not going out.
__________________
Dr Dave is offline   United Kingdom
0
Reply With Quote
      03-15-2013, 03:57 PM   #11
MattBlack
New Member
 
Drives: 325i M Sport Auto
Join Date: Jan 2013
Location: London

Posts: 8
iTrader: (0)

steering angle sensor, does the indicators stay on?
MattBlack is offline  
0
Reply With Quote
      03-16-2013, 12:49 PM   #12
Davidlindsey
Private First Class
 
Davidlindsey's Avatar
 
Drives: E92 335i Coupe
Join Date: Feb 2013
Location: United Kingdom

Posts: 172
iTrader: (0)

well that's a conicidence !
just coming back on a 120 mile motorway journey and my 335i suddenly flagged up some lights, hill start assist has gone down , cruise, dtc and abs apparently.

here's the lights on the dash....is that familiar to anyone ?.....what is the most likely failed part ?


Davidlindsey is offline  
0
Reply With Quote
      03-16-2013, 01:49 PM   #13
lemonukas
Second Lieutenant
 
Drives: 325i e91
Join Date: Jun 2012
Location: hemel hempstead

Posts: 281
iTrader: (0)

Quote:
Originally Posted by Davidlindsey
well that's a conicidence !
just coming back on a 120 mile motorway journey and my 335i suddenly flagged up some lights, hill start assist has gone down , cruise, dtc and abs apparently.

here's the lights on the dash....is that familiar to anyone ?.....what is the most likely failed part ?


ABS sensor, wheel bearing, ABS unit. Or just good clean where sensor sits
lemonukas is offline  
0
Reply With Quote
      03-16-2013, 03:01 PM   #14
PowerCorrupts
Private First Class
 
Drives: E92 325d
Join Date: Apr 2012
Location: Cambridgeshire

Posts: 129
iTrader: (1)

Quote:
Originally Posted by MattBlack View Post
steering angle sensor, does the indicators stay on?
Well when mine wasn't working (DTC, ABS lights etc) I think the indicators still turned off automatically so I guess not.
PowerCorrupts is offline   United Kingdom
0
Reply With Quote
      03-16-2013, 03:05 PM   #15
chris_s1
Major
 
Drives: 2012 E92 335d MSport
Join Date: Jun 2009
Location: Swindon, UK

Posts: 1,078
iTrader: (0)

Garage List
2012 E92 335d  [4.33]
Quote:
Originally Posted by Davidlindsey View Post
well that's a conicidence !
just coming back on a 120 mile motorway journey and my 335i suddenly flagged up some lights, hill start assist has gone down , cruise, dtc and abs apparently.

here's the lights on the dash....is that familiar to anyone ?.....what is the most likely failed part ?
That's EXACTLY what my dash looked like last week. Wheel speed sensor (front left) was my problem, high chance your is the same...
__________________
2012 Alpine White E92 335d M Sport LCI | Coral Red Dakota Leather | Media Package - BMW Professional | 313 Wheels | Evolved |
Previously - 2009 Alpine White 325d M Sport LCI | Auto + Paddles | Media Package - BMW Professional | BMW Performance Front, Sideskirts and 313P Wheels | Black Grilles |
Carbon Black E46 ///M3 '04 | Manual | Evolved |
chris_s1 is offline   United Kingdom
0
Reply With Quote
      03-16-2013, 05:27 PM   #16
Davidlindsey
Private First Class
 
Davidlindsey's Avatar
 
Drives: E92 335i Coupe
Join Date: Feb 2013
Location: United Kingdom

Posts: 172
iTrader: (0)

Quote:
Originally Posted by chris_s1 View Post
That's EXACTLY what my dash looked like last week. Wheel speed sensor (front left) was my problem, high chance your is the same...
any idea on cost for the part and how easy to fit ?
thankyou
D
Davidlindsey is offline  
0
Reply With Quote
      03-16-2013, 05:31 PM   #17
chris_s1
Major
 
Drives: 2012 E92 335d MSport
Join Date: Jun 2009
Location: Swindon, UK

Posts: 1,078
iTrader: (0)

Garage List
2012 E92 335d  [4.33]
I've no idea sorry, the dealership did it under warranty. Bit it didn't take them very long so it must be a fairly simple job. I would guess at £30 for sensor probably
__________________
2012 Alpine White E92 335d M Sport LCI | Coral Red Dakota Leather | Media Package - BMW Professional | 313 Wheels | Evolved |
Previously - 2009 Alpine White 325d M Sport LCI | Auto + Paddles | Media Package - BMW Professional | BMW Performance Front, Sideskirts and 313P Wheels | Black Grilles |
Carbon Black E46 ///M3 '04 | Manual | Evolved |
chris_s1 is offline   United Kingdom
0
Reply With Quote
      03-16-2013, 05:33 PM   #18
chris_s1
Major
 
Drives: 2012 E92 335d MSport
Join Date: Jun 2009
Location: Swindon, UK

Posts: 1,078
iTrader: (0)

Garage List
2012 E92 335d  [4.33]
By the way 35.7mpg in a 335i? That's good going, I only get slightly better than that in my D.
__________________
2012 Alpine White E92 335d M Sport LCI | Coral Red Dakota Leather | Media Package - BMW Professional | 313 Wheels | Evolved |
Previously - 2009 Alpine White 325d M Sport LCI | Auto + Paddles | Media Package - BMW Professional | BMW Performance Front, Sideskirts and 313P Wheels | Black Grilles |
Carbon Black E46 ///M3 '04 | Manual | Evolved |
chris_s1 is offline   United Kingdom
0
Reply With Quote
      03-17-2013, 02:52 AM   #19
lemonukas
Second Lieutenant
 
Drives: 325i e91
Join Date: Jun 2012
Location: hemel hempstead

Posts: 281
iTrader: (0)

Quote:
Originally Posted by Davidlindsey
Quote:
Originally Posted by chris_s1 View Post
That's EXACTLY what my dash looked like last week. Wheel speed sensor (front left) was my problem, high chance your is the same...
any idea on cost for the part and how easy to fit ?
thankyou
D
Sensor is about 70-80 and about 20min job. You need read faults first.
lemonukas is offline  
0
Reply With Quote
      03-17-2013, 03:46 AM   #20
Davidlindsey
Private First Class
 
Davidlindsey's Avatar
 
Drives: E92 335i Coupe
Join Date: Feb 2013
Location: United Kingdom

Posts: 172
iTrader: (0)

Quote:
Originally Posted by chris_s1 View Post
By the way 35.7mpg in a 335i? That's good going, I only get slightly better than that in my D.
i find it very good on fuel tbh, i did Sheffield too Nottingham last week and got 40.1 mpg average, i was only cruising like, but even so that's very good imo, all things considered.

some great info on this thread, thanks everyone.
Davidlindsey is offline  
0
Reply With Quote
      03-18-2013, 12:54 PM   #21
Davidlindsey
Private First Class
 
Davidlindsey's Avatar
 
Drives: E92 335i Coupe
Join Date: Feb 2013
Location: United Kingdom

Posts: 172
iTrader: (0)

had my car on the diagnostic machine today , and it turns out the abs hydraulic pump has failed. Apparently if its just the hydraulic side its 320 pounds for the part but if its both the electric part and the hydraulic part then its just over a thousand pounds for the whole thing.....and the fault codes do suggest its the whole thing that's needed.
This price for the part was quoted by series 9 in Nottingham, Stratstone at derby quoted 2250 for the complete job

Sheesh i'm glad i didn't buy private , infact it was only me wanting a warranty that stopped me buying private.........wise decision it seems.!

hope its sorted quickly, ive only had the car a week and a half and i need to drive it

apparently its a very common fail is this correct ?
Davidlindsey is offline  
0
Reply With Quote
      03-18-2013, 01:19 PM   #22
chris_s1
Major
 
Drives: 2012 E92 335d MSport
Join Date: Jun 2009
Location: Swindon, UK

Posts: 1,078
iTrader: (0)

Garage List
2012 E92 335d  [4.33]
Wow unlucky mate, good job getting the warranty!

I'm not sure I'd call it a common fault, I don't remember seeing it come up much on the boards before but then everything that happens more than twice on the internet immediately seems to be labelled a 'common problem' these days and then gets rolled out everytime someone needs an argument for/against a particular make/model......
__________________
2012 Alpine White E92 335d M Sport LCI | Coral Red Dakota Leather | Media Package - BMW Professional | 313 Wheels | Evolved |
Previously - 2009 Alpine White 325d M Sport LCI | Auto + Paddles | Media Package - BMW Professional | BMW Performance Front, Sideskirts and 313P Wheels | Black Grilles |
Carbon Black E46 ///M3 '04 | Manual | Evolved |
chris_s1 is offline   United Kingdom
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:12 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST