E90Post
 


 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > DTC, ABS, Start Assist and Cruise Control Failure



Reply
 
Thread Tools Search this Thread
      07-10-2013, 03:19 AM   #45
T9Gjn
Captain
 
Drives: E90 330d M-Sport
Join Date: Sep 2009
Location: London

Posts: 55
iTrader: (0)

for me it turned out to be the alternator - 550 +100 to install from independent.
__________________
T9Gjn is offline   United Kingdom
0
Reply With Quote
      11-28-2013, 02:18 PM   #46
rs32
Team UK - Hybrid Audio Technologies
 
rs32's Avatar
 
Drives: 335d M Sport
Join Date: Nov 2013
Location: Warwickshire, UK

Posts: 51
iTrader: (0)

Sorry to revive on older thread - but this seems to be a pretty common fault so nothing gained by starting a new one.

Today I've had exactly the same fault as described by the OP. On a 2007 335d E90 with 22.4k miles covered since new.

What's the betting I get stung for a large sum of cash as I only took out the BMW insured warranty 2 days ago and BMW don't offer me any goodwill on a part that's only lasted 22000 miles !

Hopefully it's just a sensor but I'm going to bet hydro pump etc ...



Have to say Rybrook BMW in Warwick have been superb as always after I rocked up at lunchtime today and they dropped my off to my office then got me in a loan car by 6pm tonight
__________________
rs32 is offline  
0
Reply With Quote
      12-02-2013, 08:32 AM   #47
a11y
Second Lieutenant
 
a11y's Avatar
 
Drives: E90 330i M Sport
Join Date: Jun 2012
Location: Central Scotland

Posts: 278
iTrader: (0)

Garage List
Quote:
Originally Posted by rs32 View Post
Sorry to revive on older thread - but this seems to be a pretty common fault so nothing gained by starting a new one.

Today I've had exactly the same fault as described by the OP. On a 2007 335d E90 with 22.4k miles covered since new.

What's the betting I get stung for a large sum of cash as I only took out the BMW insured warranty 2 days ago and BMW don't offer me any goodwill on a part that's only lasted 22000 miles !

Hopefully it's just a sensor but I'm going to bet hydro pump etc ...



Have to say Rybrook BMW in Warwick have been superb as always after I rocked up at lunchtime today and they dropped my off to my office then got me in a loan car by 6pm tonight
See my thread - hydro pump's not the end of the world. I've just had the same fault and ECU Testing repaired my hydro (DSC/ABS) unit for 240: http://www.e90post.com/forums/showthread.php?t=906185. This was for a 6-cyl 330i so should be same./similar costs for a 335. The 4-pots are a cheaper fix.

PM me if you want more detail.
__________________
BMW e90 330i M Sport
a11y is offline   Scotland
0
Reply With Quote
      12-02-2013, 08:36 AM   #48
a11y
Second Lieutenant
 
a11y's Avatar
 
Drives: E90 330i M Sport
Join Date: Jun 2012
Location: Central Scotland

Posts: 278
iTrader: (0)

Garage List
Oh, and big thanks to tmarshall57 and others for posting their own experiences on this fault - helped greatly
__________________
BMW e90 330i M Sport
a11y is offline   Scotland
0
Reply With Quote
      12-17-2013, 02:16 PM   #49
chris325
Enlisted Member
 
chris325's Avatar
 
Drives: 325i msport coupe
Join Date: Feb 2012
Location: sussex

Posts: 43
iTrader: (0)

lot of help on here, my 325i has the same fault lights, and is out of warranty. The car seems perfectly driveable, but no traction control, cruise control or hill assist. I took it to my local garage (BMW Spires couldn't fit it in for a fortnight and wanted 100 + cat to run the diagnostics).

I got told they could repair the Hydro unit but would take 2-3 weeks and 1000+.

Look like it will wait until after Christmas now, but will find a 2nd opinion first
chris325 is offline  
0
Reply With Quote
      12-17-2013, 04:22 PM   #50
a11y
Second Lieutenant
 
a11y's Avatar
 
Drives: E90 330i M Sport
Join Date: Jun 2012
Location: Central Scotland

Posts: 278
iTrader: (0)

Garage List
Quote:
Originally Posted by chris325 View Post
lot of help on here, my 325i has the same fault lights, and is out of warranty. The car seems perfectly driveable, but no traction control, cruise control or hill assist. I took it to my local garage (BMW Spires couldn't fit it in for a fortnight and wanted 100 + cat to run the diagnostics).

I got told they could repair the Hydro unit but would take 2-3 weeks and 1000+.

Look like it will wait until after Christmas now, but will find a 2nd opinion first
Can't recommend ECU Testing enough - see link in my thread two above. 240 all-in repair cost on my 2007 330i, the unit was away from me for exactly 7 days inc the weekend. Only actual difficult work is bleeding the brakes when refitting, and unfortunately you can't drive the car until they're done so you can't even refit yourself then drive to a garage for a brake bleed.
__________________
BMW e90 330i M Sport
a11y is offline   Scotland
0
Reply With Quote
      12-17-2013, 04:34 PM   #51
acerboo
Brigadier General
 
Drives: e92 335d lci
Join Date: Jul 2008
Location: kent

Posts: 3,482
iTrader: (2)

its about time bmw recalled all these cars and fixed the wheel sensors and the hydro pump problems, simply not acceptable on such an expensive car.
acerboo is offline   England
0
Reply With Quote
      12-25-2013, 04:00 PM   #52
Roy Keane's dog
New Member
 
Drives: E92 325d M Sport
Join Date: Dec 2013
Location: N Ireland

Posts: 5
iTrader: (0)

Hi Guys, not going to open an new thread on this as I have recently joined the ABS Hydro pump unit fail gang. ECUtesing.com are currently closed for Christmas and before I contact them I am going to check the ABS pump unit part number. I looked at the unit and the number printed on it was 3451 677 6068. Is this the only number needed for ECUtesting to determine whether or not it's a fixable unit or do I need the p/n of the electronic side of the unit as well?

BTW, I changed the original 18" wheels & RFTs to 17" non-RFT winter tyres about 4 weeks before the lights first came on and might change back to eliminate the different wheel set up. Local Indy says fault code is for the ABS Hydro pump, but will see.

Cheers
Roy Keane's dog is offline  
0
Reply With Quote
      01-01-2014, 03:18 PM   #53
Roy Keane's dog
New Member
 
Drives: E92 325d M Sport
Join Date: Dec 2013
Location: N Ireland

Posts: 5
iTrader: (0)

Changed back to original wheels/tyres set-up and warning lights still on. Independent mechanic read the fault codes as follows:

5DF0 Hydraulic Unit: pump motor
5DF1 Hydraulic Unit: pump motor connector faulty

Will send to ECU Testing for rebuild next week. Hopefully that will solve the problem.

Rgds

CH

Last edited by Roy Keane's dog; 01-01-2014 at 03:19 PM. Reason: emoticon inserted wrongly
Roy Keane's dog is offline  
0
Reply With Quote
      01-18-2014, 05:53 PM   #54
Roy Keane's dog
New Member
 
Drives: E92 325d M Sport
Join Date: Dec 2013
Location: N Ireland

Posts: 5
iTrader: (0)

Unit returned from ECUtesing.com last Thurs and fitted on Friday and so far it's real good like Gielgud
Would recommend these guys.
Roy Keane's dog is offline  
0
Reply With Quote
      01-30-2014, 07:40 AM   #55
-TARBY-
Private First Class
 
-TARBY-'s Avatar
 
Drives: 07 330d M Sport Saloon 6 Speed
Join Date: Jun 2012
Location: Orpington

Posts: 159
iTrader: (0)

I'm having this issue at the moment.. I didn't realise what a common occurrence it is..

http://www.e90post.com/forums/showthread.php?t=934971

I will have to wait till i get mine sorted as I am travelling soon.

Errors I get

ABS Light, DTC Light, cruise control failure and all the related idrive error descriptions.

5DF0 Hydraulic unit: pump motor
5DF1 Hydraulic unit: pump motor connector faulty

When I get back I might try some of the easy options but my Indie says that with my OBD errors and that this seems to be a common issue with 2007 models that I should get the pump repaired.

Ill keep you all posted..

P
__________________
2007(07) : e90 - 330d - M Sport - Saloon - 6 Speed
-TARBY- is offline   England
0
Reply With Quote
      01-30-2014, 10:19 AM   #56
seanblee
Captain
 
seanblee's Avatar
 
Drives: E92 335i SE
Join Date: Dec 2008
Location: Enfield, UK

Posts: 747
iTrader: (2)

Send a message via MSN to seanblee
I had the same with my 2007 last year, so it looks like another one of those 'when not if' things - luckily BMW extended warranty covered a replacement hydro unit.
__________________
2007 E92 335i SE auto | Quaife LSD | Birds B3 ARBs | Evolve Stage 1 | Morel Hybrid 402 | Rainbow IL-W8F | JL 10W3v3 | RF 3sixty.3 | Alpine PDX-V9

seanblee is offline   United Kingdom
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:32 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST