E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > Hesitant/Stuttering 335i



Reply
 
Thread Tools Search this Thread
      03-11-2013, 07:19 AM   #1
norman1979
Private First Class
 
Drives: V8 M3
Join Date: Apr 2011
Location: London

Posts: 109
iTrader: (0)

Hesitant/Stuttering 335i

Upon driving the 335i over the weekend, I noticed that it was hesitant when accelerating between around 2k-3k revs in all gears. Its an Auto - not sure if that makes any difference.
No engine management light on the On Board Computer.

Any ideas? Im thinking possibly MAF sensor

Last edited by norman1979; 03-11-2013 at 07:30 AM.
norman1979 is offline  
0
Reply With Quote
      03-11-2013, 07:45 AM   #2
doughboy
Major General
 
doughboy's Avatar
 
Drives: E91 335i Sold.
Join Date: Jan 2009
Location: UK

Posts: 6,375
iTrader: (2)

N54's don't have a MAF, so you can be confident it's not that!

Have you not run it for a while? Different fuel? Maybe go for a blast and see if it clears up?
__________________
335i gone E63 AMG here at last!
doughboy is offline   United Kingdom
0
Reply With Quote
      03-11-2013, 07:57 AM   #3
C.J
Registered?
 
C.J's Avatar
 
Drives: E92 335i
Join Date: Jan 2012
Location: UK

Posts: 180
iTrader: (0)

Plugs / injectors? Carbon build up?
__________________
C.J is offline   United Kingdom
0
Reply With Quote
      03-11-2013, 07:58 AM   #4
phil200tdi
Colonel
 
phil200tdi's Avatar
 
Drives: 335i M Sport E90 LCI manual
Join Date: Jan 2011
Location: Aylesbury

Posts: 2,629
iTrader: (1)

Sounds like a misfire but could also be Vanos solenoids.

Any codes?
__________________
Car: 2010 Jaguar XFR (Stock - For now)
Gone but not forgotten: Highly Modified E90 335i LCI M Sport Manual (circa 480BHP/500lb ft)
phil200tdi is offline   United Kingdom
0
Reply With Quote
      03-11-2013, 08:07 AM   #5
NH335i
First Lieutenant
 
Drives: 335i
Join Date: Dec 2012
Location: NH

Posts: 304
iTrader: (0)

Garage List
2007 335i  [0.00]
Mine does that somehwhat.
I just attributed to being in regular "econ" drive mode rather than sport or "m" mode.
NH335i is offline   United_States
0
Reply With Quote
      03-11-2013, 08:50 AM   #6
norman1979
Private First Class
 
Drives: V8 M3
Join Date: Apr 2011
Location: London

Posts: 109
iTrader: (0)

Its only driven occasionally but it was last driven around a week ago. I took it for a blast yesterday hoping that it would clear up but it didn't.
Surely the plugs/injectors would show up the engine management light?

Weird thing is that its fine when revving in Manual Mode.
norman1979 is offline  
0
Reply With Quote
      03-11-2013, 09:56 AM   #7
doughboy
Major General
 
doughboy's Avatar
 
Drives: E91 335i Sold.
Join Date: Jan 2009
Location: UK

Posts: 6,375
iTrader: (2)

Engine lights will only show when misfires are significant, so it has to be quite bad for that to happen.

There is a auto gearbox adaptation reset procedure that i've seen on here somewhere, maybe try that?
__________________
335i gone E63 AMG here at last!
doughboy is offline   United Kingdom
0
Reply With Quote
      03-13-2013, 07:24 AM   #8
impys
Impys
 
Drives: BMW 335i
Join Date: Aug 2012
Location: Leeds

Posts: 29
iTrader: (0)

Quote:
Originally Posted by norman1979 View Post
Upon driving the 335i over the weekend, I noticed that it was hesitant when accelerating between around 2k-3k revs in all gears. Its an Auto - not sure if that makes any difference.
No engine management light on the On Board Computer.

Any ideas? Im thinking possibly MAF sensor
Mine did this a few weeks ago so took to into BMW, they changed the High Pressure Fuel Pump...luckily under warranted

Before that they changed the injectors under a past recall that had not been done
impys is offline   England
0
Reply With Quote
      03-18-2013, 05:07 AM   #9
norman1979
Private First Class
 
Drives: V8 M3
Join Date: Apr 2011
Location: London

Posts: 109
iTrader: (0)

I tried the gearbox reset adaption and it seemed like it fixed it at first but stuttering returned later but now it is more intermittent
I haven't had a chance to get it diagnosed it but I have also noticed that the heaters are working intermittently. The climate control panel works as normal but the heaters just stop and start working randomly.
Perhaps the stuttering and the heater issue could be linked?
norman1979 is offline  
0
Reply With Quote
      03-18-2013, 06:06 AM   #10
Josh1a1h
Brigadier General
 
Josh1a1h's Avatar
 
Drives: AzuriteBlack 335i E92
Join Date: Aug 2011
Location: Central North to West London

Posts: 3,866
iTrader: (2)

Good luck getting this sorted mate.
__________________
| Resprayed Azurite Black Individual | Custom LED Headlights | M3 Individual Interior |
|1M Front & Custom Carbon splitter | M3 Side Skirts & Carbon Side Splitters | CSL Boot | LCI Lights | Duke Dynamics Carbon Diffuser |
| Full Air Lift w/ Accuair E-level & I-level management | SSR Professor MS1 8.5"/10.5" 3-Piece Rims| PB Big Brake Kit Front 380mm 8 pot |
Josh1a1h is offline   United Kingdom
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:57 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST