E90Post
 


N54Tuning.com
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Car Stumbles at Idle



Reply
 
Thread Tools Search this Thread
      03-19-2013, 10:18 PM   #1
sgtpeper
Private First Class
United_States
2

 
Drives: '09 e90 335i xDrive
Join Date: Feb 2008
Location: Denver


Posts: 102
iTrader: (0)

Car Stumbles at Idle

Hey all,

So my car has an AP and DCI. I replaced the plugs at my last oil change. Often times at idles there is a sort of stumble in the RPMs. I'm not throwing any codes according to my AP. Is this a normal N54 thing or something I can fix?

Thanks in advance for any and all help!
__________________
Jeff
'09 e90 335i xDrive 6MT
'74 Alfa Romeo Spider
Appreciate 0
      03-20-2013, 04:57 PM   #2
sgtpeper
Private First Class
United_States
2

 
Drives: '09 e90 335i xDrive
Join Date: Feb 2008
Location: Denver


Posts: 102
iTrader: (0)

Bump. Anyone?
__________________
Jeff
'09 e90 335i xDrive 6MT
'74 Alfa Romeo Spider
Appreciate 0
      03-20-2013, 05:01 PM   #3
Amini77
Brigadier General
United_States
60

 
Amini77's Avatar
 
Drives: SGM E90 330xi
Join Date: Nov 2011
Location: Tarzana, CA


Posts: 4,585
iTrader: (1)

Garage List
2006 330XI  [3.75]
I think my friend has the same problem, shoot him a PM. He's on my friends list, its OmidHariri.
__________________

instagram: amini77
| KW V1 | LCI rear | 359m Style | Michelin PSS | AA Stage 2 | Gruppe M | Remus | Mtech Rear | M3 Front |
Appreciate 0
      03-20-2013, 05:06 PM   #4
rewired87
Private
1

 
rewired87's Avatar
 
Drives: 2007 335i coupe (Black)
Join Date: Apr 2007
Location: Vancouver


Posts: 67
iTrader: (1)

I had the same problem and it was due to really dirty intake valves. Walnut shell blasting serviced fixed it. Very smooth now.
Appreciate 0
      03-20-2013, 05:47 PM   #5
mike3000fl
Eleven Bravo
28

 
mike3000fl's Avatar
 
Drives: 06 330i
Join Date: Feb 2010
Location: Tampa


Posts: 2,234
iTrader: (0)

check coils.
__________________
2006 330i - Jet Black - 19" E46 M3 wheels - HR Sport - 206,000 Miles...

Appreciate 0
      03-20-2013, 05:49 PM   #6
boris
Борис
United_States
4

 
boris's Avatar
 
Drives: e92 n54 335i
Join Date: Nov 2012
Location: CT


Posts: 445
iTrader: (0)

Quote:
Originally Posted by rewired87 View Post
I had the same problem and it was due to really dirty intake valves. Walnut shell blasting serviced fixed it. Very smooth now.
This..

having the same problem...

Did a full service on the car a few weekends ago to make sure everything was good....

Intake Valve cleaning are next!!
__________________
07 SG 335i
COBB - Burger Motorsports -Ultimate Racing - Evolution Racewerks - TiAL- AMS
In Winter Mode - Dunlop Wintersport 3D/Sport Edition Wheels
Appreciate 0
      03-20-2013, 05:52 PM   #7
Cuticuti
Private
0

 
Drives: 2011 355i sedan
Join Date: May 2012
Location: Dfw, Texas


Posts: 50
iTrader: (0)

Try bottle of Techron on a full gas tank. I did it twice back to back (2 tanks of gas)
Appreciate 0
      03-20-2013, 05:57 PM   #8
GoRomeo
Colonel
26

 
GoRomeo's Avatar
 
Drives: 330i
Join Date: Feb 2006
Location: San Diego CA


Posts: 2,344
iTrader: (0)

Garage List
2006 330i  [2.83]
Clean your MAF sensor and replace air filter. It does not hurt...
Appreciate 0
      03-20-2013, 06:02 PM   #9
boris
Борис
United_States
4

 
boris's Avatar
 
Drives: e92 n54 335i
Join Date: Nov 2012
Location: CT


Posts: 445
iTrader: (0)

Quote:
Originally Posted by GoRomeo View Post
Clean your MAF sensor and replace air filter. It does not hurt...
404: MAF NOT FOUND
__________________
07 SG 335i
COBB - Burger Motorsports -Ultimate Racing - Evolution Racewerks - TiAL- AMS
In Winter Mode - Dunlop Wintersport 3D/Sport Edition Wheels
Appreciate 0
      03-20-2013, 06:07 PM   #10
GoRomeo
Colonel
26

 
GoRomeo's Avatar
 
Drives: 330i
Join Date: Feb 2006
Location: San Diego CA


Posts: 2,344
iTrader: (0)

Garage List
2006 330i  [2.83]
Quote:
Originally Posted by boris View Post
404: MAF NOT FOUND
Really? Try this:

http://www.e90post.com/forums/showth...ghlight=sensor
Appreciate 0
      03-20-2013, 06:16 PM   #11
boris
Борис
United_States
4

 
boris's Avatar
 
Drives: e92 n54 335i
Join Date: Nov 2012
Location: CT


Posts: 445
iTrader: (0)




Was being an asshole. OP has 335i.

No MAF.



Quote:
Originally Posted by GoRomeo View Post
__________________
07 SG 335i
COBB - Burger Motorsports -Ultimate Racing - Evolution Racewerks - TiAL- AMS
In Winter Mode - Dunlop Wintersport 3D/Sport Edition Wheels
Appreciate 0
      03-20-2013, 06:18 PM   #12
335xiRacer
Private First Class
1

 
Drives: 2008 335xi
Join Date: Mar 2013
Location: Lowell, MA


Posts: 179
iTrader: (2)

I actually have this same issue since the dealer replaced my plugs and air filter
Appreciate 0
      03-20-2013, 06:21 PM   #13
GoRomeo
Colonel
26

 
GoRomeo's Avatar
 
Drives: 330i
Join Date: Feb 2006
Location: San Diego CA


Posts: 2,344
iTrader: (0)

Garage List
2006 330i  [2.83]
Quote:
Originally Posted by boris View Post



Was being an asshole. OP has 335i.

No MAF.
OK Mr asshole LOL ... oh shoot sorry my bad...
Appreciate 0
      03-20-2013, 06:25 PM   #14
boris
Борис
United_States
4

 
boris's Avatar
 
Drives: e92 n54 335i
Join Date: Nov 2012
Location: CT


Posts: 445
iTrader: (0)

Quote:
Originally Posted by GoRomeo View Post
OK Mr asshole LOL ... oh shoot sorry my bad...
__________________
07 SG 335i
COBB - Burger Motorsports -Ultimate Racing - Evolution Racewerks - TiAL- AMS
In Winter Mode - Dunlop Wintersport 3D/Sport Edition Wheels
Appreciate 0
      03-20-2013, 08:19 PM   #15
mxa121
Lieutenant
12

 
mxa121's Avatar
 
Drives: M
Join Date: Apr 2012
Location: Atlanta, United States


Posts: 558
iTrader: (0)

Quote:
Originally Posted by 335xiRacer View Post
I actually have this same issue since the dealer replaced my plugs and air filter
+1

I'm getting irritated. On cold starts it stumbles badly. Once warm it is less noticeable.
New plugs and it runs worse
__________________
2009 E92 M3 Jerez Black Metallic DCT 33k miles
2010 E92 335i Le Mans Blue Metallic 6MT 64k miles - sold
2009 E90 328i Le Mans Blue Metallic 6AT 58k miles
Appreciate 0
      03-20-2013, 09:46 PM   #16
SharkBait
Second Lieutenant
2

 
Drives: 2010 E92 335i
Join Date: Jan 2013
Location: Lost Angeles


Posts: 297
iTrader: (0)

Garage List
Quote:
Originally Posted by Cuticuti View Post
Try bottle of Techron on a full gas tank. I did it twice back to back (2 tanks of gas)
Techron in a DI motor does SFA. OP most likely needs a walnut blasting.
Appreciate 0
      03-21-2013, 01:23 AM   #17
sgtpeper
Private First Class
United_States
2

 
Drives: '09 e90 335i xDrive
Join Date: Feb 2008
Location: Denver


Posts: 102
iTrader: (0)

I guess I'll try walnut blasting. The car just rolled 35k miles! She's still brand new! haha

I supposed I could check the coils as well. Could it be the tune? If the car was in fact missing would it throw a code?

Thanks!
__________________
Jeff
'09 e90 335i xDrive 6MT
'74 Alfa Romeo Spider
Appreciate 0
      03-21-2013, 01:29 AM   #18
galahad05
Colonel
25

 
galahad05's Avatar
 
Drives: '07 335i e90
Join Date: Mar 2008
Location: Long Island NY


Posts: 2,515
iTrader: (0)

A dealer-done walnut shell blast is going to cost around $800. Consider just borescoping the valves or even one weekend open the top-end up and eyeball things if you can.
35k miles is pretty low for having a bad case of carbon fouling. Not saying impossible, but unusual I think. Unless maybe you've got a tune (don't answer this).
__________________
Always laugh when you can. It is cheap medicine
--Lord Byron
Appreciate 0
      03-21-2013, 07:56 AM   #19
rich123321
Captain
United_States
13

 
rich123321's Avatar
 
Drives: BMW 325i E90
Join Date: Jan 2012
Location: South Florida


Posts: 795
iTrader: (1)

Garage List
2006 BMW E90  [4.17]
I have the same issue. Sputtering and stalls. I don't have a warranty at the moment but check these out. Replace your camshaft sensor if you have one (I have a 325). It's relatively inexpensive. 40$ and labor. After, check your fuel pumps including the dtml emissions pump. Might need replacement. Mine does but I can't do shit because I don't have a warranty...
Appreciate 0
      03-21-2013, 08:14 AM   #20
TittoBlunt
Private
0

 
Drives: 2007 328i, 2013 328i M-Sport
Join Date: Nov 2012
Location: Northern VA


Posts: 80
iTrader: (0)

Quote:
Originally Posted by mxa121 View Post
+1

I'm getting irritated. On cold starts it stumbles badly. Once warm it is less noticeable.
New plugs and it runs worse
Maybe incorrect plug gaps? You would hope the dealer checks the gaps before installing but you never know.
Appreciate 0
      03-21-2013, 08:33 AM   #21
OrangeInOhio
Private
United_States
0

 
Drives: 2008 328i Sedan
Join Date: Jun 2012
Location: Dayton, OH


Posts: 84
iTrader: (0)

Garage List
Quote:
Originally Posted by mxa121 View Post
+1

I'm getting irritated. On cold starts it stumbles badly. Once warm it is less noticeable.
New plugs and it runs worse
I replaced my air filter back in December and I get the same thing. I have a 328i and it stumbles for the first 10 seconds or so when starting up then runs smooth. On warm days I haven't noticed it. My gas mileage has been shot to hell too. I was averaging 26-27 MPG before that and not I'm getting anywhere from 21-23. I've had it less than a year though, so I guess it could just be the cold weather... I'm going to look into it more when it gets warmer if it doesn't get better.
__________________
Appreciate 0
      03-21-2013, 10:21 AM   #22
boris
Борис
United_States
4

 
boris's Avatar
 
Drives: e92 n54 335i
Join Date: Nov 2012
Location: CT


Posts: 445
iTrader: (0)

Quote:
Originally Posted by TittoBlunt

Maybe incorrect plug gaps? You would hope the dealer checks the gaps before installing but you never know.
I was under the impression that n54 plugs with the 3 grounds are pretty much not able to be gapped any more than they Are due to their design. When I did plugs, they didn't need to be gapped, nor did anyone I spoke to who are BMW techs sai they needed to be gapped if you bought OEM plugs. The NGK's are a different story... But why would the dealer put in NGK?
__________________
07 SG 335i
COBB - Burger Motorsports -Ultimate Racing - Evolution Racewerks - TiAL- AMS
In Winter Mode - Dunlop Wintersport 3D/Sport Edition Wheels
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:20 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST