E90Post
 


GT Haus
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Help



Reply
 
Thread Tools Search this Thread
      03-22-2013, 07:04 PM   #1
335iTurbo'd
Enlisted Member
1
Rep
34
Posts

 
Drives: Jet Black 335i
Join Date: Mar 2012
Location: High Point NC

iTrader: (0)

Help

I have spent the last 2 hours searching for answers only to be more confused. I was driving this evening and went to pass a car and hit limp mode ses light half engine light no power. I pulled over restarted car still the same would not even rev up. Reset ses light will crank up and run but shakes badly and sounds like a diesel running. The SES light keeps flashing. Getting the following codes.

12474--30BA
10700--29CC
10701--29CD
10702--29CE
10703--29CF

Thanks for your input!!!
Appreciate 0
      03-22-2013, 07:20 PM   #2
135Pats
Turbo's Here
135Pats's Avatar
United_States
61
Rep
5,679
Posts

 
Drives: 135i
Join Date: May 2012
Location: Maryland

iTrader: (2)

P29cc is multiple cylinder misfires iirc.
Appreciate 0
      03-29-2013, 01:09 PM   #3
335iTurbo'd
Enlisted Member
1
Rep
34
Posts

 
Drives: Jet Black 335i
Join Date: Mar 2012
Location: High Point NC

iTrader: (0)

Update

In order of repairs

3 injectors--still running badly could not clear SES light
replaced DME
replaced all 6 coil packs

Now running as it should!!!
Appreciate 0
      03-29-2013, 01:39 PM   #4
marv85
Colonel
marv85's Avatar
United_States
25
Rep
2,558
Posts

 
Drives: '07 335i MT
Join Date: Jun 2010
Location: Portland

iTrader: (5)

you probably should have started with the easy stuff like coils
__________________
'10 E92 335i , COBB
Appreciate 0
      03-29-2013, 01:39 PM   #5
marv85
Colonel
marv85's Avatar
United_States
25
Rep
2,558
Posts

 
Drives: '07 335i MT
Join Date: Jun 2010
Location: Portland

iTrader: (5)

but anyway, glad you got it sorted out
__________________
'10 E92 335i , COBB
Appreciate 0
      03-29-2013, 05:25 PM   #6
Freefreefive
Private First Class
Australia
3
Rep
129
Posts

 
Drives: 335i Coupe
Join Date: Feb 2012
Location: Melbourne

iTrader: (0)

The giveaway is the 30BA code - it means a MOSFET in your DME failed - I got the same codes as you and same symptoms. You can get a new MOSFET for $2 and have a computer or tv repair place solder it back on for you for $30 or so.

I just had this happen to me 3 weeks ago.

Just google 335i DME died and you'll see lots about it and a DIY by a guy called Roy Cromier I think that explains it - that's how I fixed mine.
Appreciate 0
      03-29-2013, 05:54 PM   #7
marv85
Colonel
marv85's Avatar
United_States
25
Rep
2,558
Posts

 
Drives: '07 335i MT
Join Date: Jun 2010
Location: Portland

iTrader: (5)

^ Oh yeah, missed that code.
__________________
'10 E92 335i , COBB
Appreciate 0
      03-29-2013, 07:48 PM   #8
335iTurbo'd
Enlisted Member
1
Rep
34
Posts

 
Drives: Jet Black 335i
Join Date: Mar 2012
Location: High Point NC

iTrader: (0)

Warranty work from dealer. That was their process of repair.
Appreciate 0
      04-01-2013, 07:40 AM   #9
Freefreefive
Private First Class
Australia
3
Rep
129
Posts

 
Drives: 335i Coupe
Join Date: Feb 2012
Location: Melbourne

iTrader: (0)

With all due respect, replacement is not the same as repair. Happy you got it solved - just keep it in mind if it happens again in future or for anyone else that is out of warranty and reading this.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:28 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST