E90Post
 


 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > HELP with code 2DEB



Reply
 
Thread Tools Search this Thread
      03-24-2013, 02:26 AM   #1
2nice89
Banned
 
Drives: 2007 e92 335i
Join Date: Aug 2012
Location: Queens Village

Posts: 242
iTrader: (0)

Garage List
2007 335i  [0.50]
HELP with code 2DEB

was sitting in the car at idle and out of nowhere i get the code 2DEB...every light comes on in the car, water pump shuts off and i get the red temp light due to all the power in the car going crazy, car starts and can only drive a few feet before it goes completly dead....thought it may be a jb4 glitch..i removed the jb4 n put that car back stock and still the same thing..any1 have any idea what this may be related to before i dealer it? i heard something about ibs. n don't think its a loose cable bcuz it happened while the car was parked.

2DEB:
2DEB Power management, vehicle wiring system control
Error will not cause a warning light
Error is not currently present
Test conditions have been completed
Signal or value below threshold
2nice89 is offline   United_States
0
Reply With Quote
      03-26-2014, 10:49 PM   #2
335ispooling
Banned
 
Drives: White e90
Join Date: Aug 2013
Location: denver

Posts: 117
iTrader: (0)

same happened to me today
335ispooling is offline  
0
Reply With Quote
      03-27-2014, 02:39 AM   #3
1QuikWS6
No 55mph
 
1QuikWS6's Avatar
 
Drives: 09 E92 328iX N51 3-Stage
Join Date: Jul 2009
Location: Blitzburgh, PA

Posts: 4,560
iTrader: (81)

Garage List
I had the exact same error come up at end of last year. I would delete the code, but it would keep coming back. Car ran fine other than the code being thrown - only thing I could relate to the error was a battery on it's way out.

Never got the yellow or red battery warning on dash during the code being thrown.

I charged the battery with a hi end charger made for AGM batteries - it would only take 90% of full charge.

Turns out that was exactly the problem - took the car in, had the battery tested @ dealer, the reserve capacity was way down from it's rated specs - they replaced the battery for free.

My car is an 09' with 34k miles on it so battery was 4yrs old when this happened. Apparently, there was a batch of batteries used at one time that are known to be sub standard - or at least that's what they put on the invoice 'replaced under warranty' when they did the swap...

After new battery never had the problem/code again
__________________
2009 328ix E92//SGM//ACS Roof Spoiler//MTech Aero Lip+Trunk Spoiler//M3 Side Skirts//CF Roundels+Grilles//M3 Novillo Interior//Perf Shift Lever+Boot//MPerf DCT Wheel//M3 GT3 eBrake Handle+Boot//ACS Pedals//M3 Mirrors//LCI Tails w/LUX Rev//DTEC V7 AE+MTec 6000K D1S+HPB HID 6000K Fogs//HPB LED Interior//RPI Scoops//CF Euro Airbox+Underhood Hsgs//K&N//BMW PE//MTech Rear Bumper-iS Sport Diffuser//CF Strut Brace//Vishnu OFT//BMW 193M's+Kumho 4X
1QuikWS6 is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:03 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST