E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Spark plugs? Injectors? or JB4? Need help



Reply
 
Thread Tools Search this Thread
      03-29-2013, 04:55 AM   #1
Shawn 335xi
JB4//KW V3//VMR 19" 701//INJEN DCI
 
Drives: 2008 335xi E90
Join Date: Mar 2013
Location: 'Merica

Posts: 35
iTrader: (0)

Spark plugs? Injectors? or JB4? Need help

On stock map my car will fully rev no problem, accelerates fast no problem at all. I use 93 octane. I have 46000 miles on the car and when I go to map 1,2, or 5 and smash the gas down, my car mis fires and the engine shakes, and the service engine soon light comes on until it idles for a few minutes and then is normal again, but if I smash the gas again after it idles and fault/problem clears it will repeat the same problem. What do I need to change/ fix?
Thanks in advance.
Shawn 335xi is offline   United Kingdom
0
Reply With Quote
      03-29-2013, 06:11 AM   #2
e90domz
Private
 
e90domz's Avatar
 
Drives: 10' bmw 335i
Join Date: Feb 2012
Location: Honolulu

Posts: 75
iTrader: (0)

Garage List
2007 BMW 335i  [0.00]
Quote:
Originally Posted by Shawn 335xi View Post
On stock map my car will fully rev no problem, accelerates fast no problem at all. I use 93 octane. I have 46000 miles on the car and when I go to map 1,2, or 5 and smash the gas down, my car mis fires and the engine shakes, and the service engine soon light comes on until it idles for a few minutes and then is normal again, but if I smash the gas again after it idles and fault/problem clears it will repeat the same problem. What do I need to change/ fix?
Thanks in advance.
Deff sounds like JB4.... try removing it and testing it
e90domz is offline  
0
Reply With Quote
      03-29-2013, 06:39 AM   #3
Pete Schweaty
Lieutenant
 
Pete Schweaty's Avatar
 
Drives: 2007 335i E90
Join Date: Jun 2011
Location: MD

Posts: 590
iTrader: (0)

A common issue with tunes. The tune places extra strain on the ignition system and the weak points come out. Read the codes and find out which cylinder is misfiring. You can then work on fixing it. Watch this, it explains it all.

http://www.youtube.com/watch?feature...&v=FsNK1ySAlSo
__________________

JB4 / BMS DCI / Alpina Flash / MTEC V3 / Blacklines
M3 Front Bumper / HID Fogs / M3 Style Spoiler
Pete Schweaty is offline  
0
Reply With Quote
      03-29-2013, 07:05 AM   #4
gpb
First Lieutenant
 
Drives: 335i Cabrio
Join Date: Sep 2012
Location: Atlanta

Posts: 393
iTrader: (0)

I believe the 335i spark plug change interval is 45000 miles.

Dealer changed mine out within the 4yr/50k mile maintenance at 45k.
gpb is offline  
0
Reply With Quote
      03-29-2013, 07:37 AM   #5
g0at23
Second Lieutenant
 
Drives: 09' 335i coupe M-sport
Join Date: Feb 2009
Location: NYC

Posts: 248
iTrader: (0)

It's not spark plugs. Known problem, clogged injectors... My car is in the shop for the same exact reason. Eventually... Within a week or two your car will be misfiring, turbo lagging, reduced power and shaking will be 10x worst... it wont be drivable and huge smoke stacks will come out of your exhaust. you will be stranded on the side of the road waiting for BMW roadside assistance. Do yourself a favor and trade your car in for a more reliable car. If not, replace your injectors and wait for your HPFP or water pump to go out. It's not a matter of if... It's a matter of when it will happen...
g0at23 is offline  
0
Reply With Quote
      03-29-2013, 07:39 AM   #6
g0at23
Second Lieutenant
 
Drives: 09' 335i coupe M-sport
Join Date: Feb 2009
Location: NYC

Posts: 248
iTrader: (0)

BTW my spark plugs were replaced less than 500 miles before this happened to me. 100% not spark plugs. The coils could have done this too. So demand injectors and coils be checked. Good luck on your POS ill need it on mine too.
g0at23 is offline  
0
Reply With Quote
      03-29-2013, 08:35 AM   #7
JYohay
Banned
 
Drives: 2011 X5
Join Date: Mar 2012
Location: NY

Posts: 2,011
iTrader: (3)

cant tell anything until you read the codes.
it can be for a number of reasons.
Low Pressure Fuel Sensor
Low Pressure Fuel Pump
High Pressure Fuel Pump
Coils
Spark Plugs
Injectors
just read the codes and it will tell you (hopefully)
saying that i had the same issue you have and had the Low Pressure Fuel Sensor Electrical Error.
got it changed under warranty but i still have the problem.
i have errors but none that have descriptions.
if i WOT i get misfires but if i 75% throttle i can go to about 12 PSI.
JYohay is offline  
0
Reply With Quote
      03-29-2013, 09:06 AM   #8
cisach
Second Lieutenant
 
cisach's Avatar
 
Drives: 2007 335i Coupe BSM/CR
Join Date: Nov 2009
Location: Jax

Posts: 218
iTrader: (2)

Garage List
2007 335i Coupe  [0.00]
Quote:
Originally Posted by g0at23 View Post
It's not spark plugs. Known problem, clogged injectors... My car is in the shop for the same exact reason. Eventually... Within a week or two your car will be misfiring, turbo lagging, reduced power and shaking will be 10x worst... it wont be drivable and huge smoke stacks will come out of your exhaust. you will be stranded on the side of the road waiting for BMW roadside assistance. Do yourself a favor and trade your car in for a more reliable car. If not, replace your injectors and wait for your HPFP or water pump to go out. It's not a matter of if... It's a matter of when it will happen...
This guy. He so mad.
http://www.e90post.com/forums/showthread.php?t=821414
__________________
2007 335i BSM/Coral Red | White DCI | Alpina AT Flash |
cisach is offline  
0
Reply With Quote
      03-29-2013, 09:32 AM   #9
Pete Schweaty
Lieutenant
 
Pete Schweaty's Avatar
 
Drives: 2007 335i E90
Join Date: Jun 2011
Location: MD

Posts: 590
iTrader: (0)

Quote:
Originally Posted by cisach View Post
And misinformed (although it sounds like he got a lemon). OP, dont listen to this guy . . . your fix could be as easy as a $15 spark plug.
__________________

JB4 / BMS DCI / Alpina Flash / MTEC V3 / Blacklines
M3 Front Bumper / HID Fogs / M3 Style Spoiler
Pete Schweaty is offline  
0
Reply With Quote
      03-29-2013, 09:34 AM   #10
wahooooman
First Lieutenant
 
wahooooman's Avatar
 
Drives: 2007 335xi, Tiag
Join Date: May 2011
Location: NORTH SHORE Ma

Posts: 319
iTrader: (3)

Had the exact same issue, when passing on the highway, about WOT, violent shaking.(check engine light).
Read codes got, 29cd (cylinder 1 misfire) , and 29e9 (Misfire, low tank fill level). changed spark plugs, nothing changed. Then swapped coils and wherever i moved coil 1 the misfire followed.

i Returned plugs ( my old ones had 15k on them)

Bought coil ($50)+beer($10) changed coil = problem gone. $60 bucks
dealer wanted $200ish

Good luck.
__________________
2007 335xi, dci, JB4, debaged, Tints, Front splitters,Mtec V3 angel eyes. M-tech rear, VRSF downpipes. 19' style 95 rims, 18' 260M, 19" matte black Euro tek rims, and lots of E85, 70/30mix with 93
wahooooman is offline   United_States
0
Reply With Quote
      03-29-2013, 09:39 AM   #11
Shawn 335xi
JB4//KW V3//VMR 19" 701//INJEN DCI
 
Drives: 2008 335xi E90
Join Date: Mar 2013
Location: 'Merica

Posts: 35
iTrader: (0)

Thanks for all the replies. Ill check out what my codes are and then update on here. It will be a month before I get back home because I'm deployed right now, but I will get back ASAP on this issue. great video Pete

Thanks again

And goat23, man I'm sorry to hear that, but keep your head up bro. KCCO
Shawn 335xi is offline   United Kingdom
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:04 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST