E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Stereo noob seeking advice



Reply
 
Thread Tools Search this Thread
      03-29-2013, 08:25 PM   #1
Cuba
Cuba
 
Cuba's Avatar
 
Drives: 07 328xi
Join Date: Jul 2010
Location: PA

Posts: 1,582
iTrader: (11)

Stereo noob seeking advice

My subwoofer popped (could have been old age) But wanted to see if im running my setup correctly.

Looking for any tips. I dont really know how to set up the amp but here is my current setup.

Amp :Rockford Fosgate 500w 2 channel
Sub : JL audio W3

Amp has a Right and Left Positive and negative output.
Subwoofer has a right and left positive and negative input
Sub box has one Positive and one negative input.


Any input is appreciated.

Let me know if anything is unclear

Thank you
Attached Images
   
__________________
07 328xi Monaco Blue|Premium|Cold|Navi|CA|LLumar|Mtec|DDM|aFe|Ambe r-Gone|Rear Fogs|Bimmian|PY-Speed|OEM|e92-lighting|V1|BavAuto|Weisslicht|Cyba|Beyern|Falken| Sonic Tuning|ECS Tuning|JL Audio|Rockford Fosgate
Cuba is offline   United_States
0
Reply With Quote
      04-02-2013, 11:46 AM   #2
garagemethods
Enlisted Member
 
Drives: '08 328i Sport
Join Date: Jun 2012
Location: Dallas, Tx

Posts: 37
iTrader: (0)

Garage List
2008 BMW 328i  [0.00]
what's the impedance of the sub?
garagemethods is offline   United_States
0
Reply With Quote
      04-02-2013, 01:14 PM   #3
Cuba
Cuba
 
Cuba's Avatar
 
Drives: 07 328xi
Join Date: Jul 2010
Location: PA

Posts: 1,582
iTrader: (11)

heres a spec sheet. Seems to be dual 4 ohms
Attached Images
 
__________________
07 328xi Monaco Blue|Premium|Cold|Navi|CA|LLumar|Mtec|DDM|aFe|Ambe r-Gone|Rear Fogs|Bimmian|PY-Speed|OEM|e92-lighting|V1|BavAuto|Weisslicht|Cyba|Beyern|Falken| Sonic Tuning|ECS Tuning|JL Audio|Rockford Fosgate
Cuba is offline   United_States
0
Reply With Quote
      04-02-2013, 01:18 PM   #4
bmw325i
Brigadier General
 
Drives: 2006 BMW 325i
Join Date: Oct 2010
Location: United States

Posts: 3,960
iTrader: (5)

On your picture it looks like you have one RCA cable plugged into each channel, and you are only using 1 channel on the amp. The sub is wired fine you should have a 2 ohm load.

What is your gain at? Do you have a multimeter?
bmw325i is offline  
0
Reply With Quote
      04-02-2013, 01:50 PM   #5
Cuba
Cuba
 
Cuba's Avatar
 
Drives: 07 328xi
Join Date: Jul 2010
Location: PA

Posts: 1,582
iTrader: (11)

Quote:
Originally Posted by bmw325i View Post
On your picture it looks like you have one RCA cable plugged into each channel, and you are only using 1 channel on the amp. The sub is wired fine you should have a 2 ohm load.

What is your gain at? Do you have a multimeter?
Gain is around 4

I do not have a multimeter
__________________
07 328xi Monaco Blue|Premium|Cold|Navi|CA|LLumar|Mtec|DDM|aFe|Ambe r-Gone|Rear Fogs|Bimmian|PY-Speed|OEM|e92-lighting|V1|BavAuto|Weisslicht|Cyba|Beyern|Falken| Sonic Tuning|ECS Tuning|JL Audio|Rockford Fosgate
Cuba is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:14 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST