E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > E91 audio upgrade with lots of pics: Mosconi, Gladen, stealth



Reply
 
Thread Tools Search this Thread
      07-25-2013, 03:38 PM   #89
Mr Singh
Banned
 
Drives: E91 330D M Sport Auto
Join Date: Oct 2011
Location: Milton Keynes

Posts: 773
iTrader: (3)

Quote:
Originally Posted by Shaun69 View Post
You don't need dsp or coding but both option will give you better sound quality.
This. But I'd recommend the Hifi coding as the EQ curve is better to my ears, from the get go the upgrade will have you grinning from ear to ear anyway so doing that a later date once things have bedded in and your ears in tune with the sound is a better way to go about it.

After almost 12 months and selling like hot cakes I have just switched to a Gladen Mosconi ONE 120.4DSP, it didn't require much adjustment with the given level of control that's available I found the tailored file from Gladen for the E90 to be pretty much bang on!
Mr Singh is offline   United Kingdom
0
Reply With Quote
      07-25-2013, 03:55 PM   #90
106turbo
Boost Junkie
 
Drives: 106 Gti T
Join Date: Jun 2012
Location: Notts

Posts: 107
iTrader: (1)

Quote:
Originally Posted by Mr Singh View Post
This. But I'd recommend the Hifi coding as the EQ curve is better to my ears, from the get go the upgrade will have you grinning from ear to ear anyway so doing that a later date once things have bedded in and your ears in tune with the sound is a better way to go about it.

After almost 12 months and selling like hot cakes I have just switched to a Gladen Mosconi ONE 120.4DSP, it didn't require much adjustment with the given level of control that's available I found the tailored file from Gladen for the E90 to be pretty much bang on!
Thats good because its confirmed what i thought. Run it as it is for now and let it wear in. When i get bored i'll add a sub in the boot floor and code to Hi-fi!

Thanks again for the help people this thread has been amazing!

Btw Mr.Singh thanks for pointing me towards monster audio. They've been very helpfull and got me my kit in great time and packaged well. Quite local as well so if i get stuck i can always make a day trip
106turbo is offline   United Kingdom
0
Reply With Quote
      07-26-2013, 02:29 AM   #91
KAL 335D
First Lieutenant
 
Drives: E90 LCI 320D M Sport
Join Date: Dec 2009
Location: London

Posts: 319
iTrader: (5)

Quote:
Originally Posted by Shaun69 View Post
You don't need dsp or coding but both option will give you better sound quality.
+1
__________________
E90 LCI 320D M Sport ... Mods to come.....
E92 320D M Sport Coupe - Gloss Black Grill - MV3's
E92 335D M Sport Coupe - Gloss Black Grill - CSL Alloys
6 Series M Sport - M6 Alloys - Upgraded Rings
E46 M3 Silver - Black Grill - Black Side Vents
KAL 335D is offline   United Kingdom
0
Reply With Quote
      07-26-2013, 02:10 PM   #92
106turbo
Boost Junkie
 
Drives: 106 Gti T
Join Date: Jun 2012
Location: Notts

Posts: 107
iTrader: (1)

Well i've got so far,

Again this is an e91, same as the OP. Had a mare getting the seat bolts out so that set me back. Should have enough rear trim out to feed most cables in and I've loosened the pass seat and removed the speaker (also fitted the Gladen 8" in to the Bmw housing).

Tomorrow i'll take the dash bits out, fit the harness and run it down the pass side, then fit both subs and run cable to the rear and then fit the amp. Does anybody require any specific photos while i do this? I have a few general ones but i can take any you need.

Also i hope OP doesn't mind me posting in here but it might help others if its all in one place.

106turbo is offline   United Kingdom
0
Reply With Quote
      07-26-2013, 03:15 PM   #93
anielsen71
Lieutenant
 
Drives: E91 330dA
Join Date: Mar 2012
Location: Naestved, Denmark

Posts: 485
iTrader: (0)

Garage List
Hi there
Yes, I would like to see some pictures of where you get the wiring to the headunit if you can shoot some of that?
__________________
Brgds
Allan
'06 E91 330dA Sparkling Graphite|19" VMR703 Black Matte|335i brakes|Eibach|Wagner|Ecotune|Turbo Dynamics
anielsen71 is offline   Denmark
0
Reply With Quote
      07-27-2013, 05:02 AM   #94
106turbo
Boost Junkie
 
Drives: 106 Gti T
Join Date: Jun 2012
Location: Notts

Posts: 107
iTrader: (1)

Quote:
Originally Posted by anielsen71 View Post
Hi there
Yes, I would like to see some pictures of where you get the wiring to the headunit if you can shoot some of that?
I'm about to pull the dash to bits now so i'l' try and get some detailed pics for you.
__________________
106 Gti Turbo

Currently 311bhp Atf.. Soon to be 300bhp Atw

E91 320D Workhorse
106turbo is offline   United Kingdom
0
Reply With Quote
      07-27-2013, 02:40 PM   #95
106turbo
Boost Junkie
 
Drives: 106 Gti T
Join Date: Jun 2012
Location: Notts

Posts: 107
iTrader: (1)

Ok so an update with my progress...

Installed the gladen Quadlock including the little cables for my idrive system. It was a tight squeeze but it eventually went back in! I ran this down the passenger side up to the rear wheel arch and around to the amp.

I then ran two sets of speaker cable from the under seat gladens to the rear. Left sub down the left side, right sub down the right. The drivers sub contact were both cross threaded so woudn't screw back in. I tightened them as slowly and lightly as possible but they still got so tight then loosened. I had to improvise and use bigger screws eventually.

The underseats fit the existing holders perfectly and were a doddle to fit! Stripping the car took most the time.

It started raining so i called it a day before pulling the front doorcards off and fitting the fronts.

Anyway plugged everything in to the amp and let rip with the power. Constant hissing from the front passenger speaker. Underseat was working but again just like a speaker. Front drivers speaker working, nothing at all from the underseat

Too dark and wet to problem solve now. But for tomorrow can anyone give me some good settings for the manual adjustment below.



Also just to check. Ive got the four wires from the gladen harness in the top four slots, and then the underseats in the +/- of the respective sides along the bottom set.(left sub and right sub) this is correct? Cant see why the drivers underseat isnt working.



P.s WOW the gongs are loud! Can i turn them down or do i need to code them quieter?

Any help appreciated

Last edited by 106turbo; 07-27-2013 at 02:47 PM.
106turbo is offline   United Kingdom
0
Reply With Quote
      07-27-2013, 04:47 PM   #96
mob17
Brigadier General
 
mob17's Avatar
 
Drives: E92 335D
Join Date: Mar 2012
Location: East Middle Land, UK

Posts: 3,477
iTrader: (4)

A mid and underseat from my set were cross threaded too. Maybe we got the same batch!
__________________
2008 E92 335D SE
2010 E90 320D SE
1994 E36 318I SE
1996 E36 316I SE
mob17 is offline   United Kingdom
0
Reply With Quote
      07-28-2013, 04:09 AM   #97
106turbo
Boost Junkie
 
Drives: 106 Gti T
Join Date: Jun 2012
Location: Notts

Posts: 107
iTrader: (1)

I hope thats nto the reason the speaker sub isnt working

Just about to pull the doorcards off and fit the door speakers.

Update:

Ok so door speakers + tweeters are in. Drivers underseat still not working. When the rain stops i may try and swap underseats over to see if its the sub or the wiring.

Drivers side door speaker also sounds a bit quiet. Dongs are very loud and the sound cuts out when the dongs go. Seems i have some work ahead of me
__________________
106 Gti Turbo

Currently 311bhp Atf.. Soon to be 300bhp Atw

E91 320D Workhorse

Last edited by 106turbo; 07-28-2013 at 07:33 AM.
106turbo is offline   United Kingdom
0
Reply With Quote
      07-28-2013, 07:54 AM   #98
mob17
Brigadier General
 
mob17's Avatar
 
Drives: E92 335D
Join Date: Mar 2012
Location: East Middle Land, UK

Posts: 3,477
iTrader: (4)

You should try and solder the wires onto the speakers whose terminals are cross threaded.

Also re underseats, did your original underseat wiring loom have 2 or 4 wires? Did you use jumpers?
__________________
2008 E92 335D SE
2010 E90 320D SE
1994 E36 318I SE
1996 E36 316I SE
mob17 is offline   United Kingdom
0
Reply With Quote
      07-28-2013, 08:11 AM   #99
106turbo
Boost Junkie
 
Drives: 106 Gti T
Join Date: Jun 2012
Location: Notts

Posts: 107
iTrader: (1)



I connected 1 to 2 and 3 to 4, both sides of the car. Working perfectly on the passenger side. Also the drivers door speaker is working so I'm guessing the jumper cables are working but the speaker is either dud or the wiring is.

Heres how I've fitted the cables (sorry for the scruffy pic I've banged it all together to make sure it all works, it will be tidied up lol)



The top two are the left and right of the Gladen harness.

The bottom two are the left and right sub in the positive and negatives.

Update:

Soldered them on to the contacts and unscrewed the screws and its working fine! No cutting out now either! LOTS of bass just need to play with the settings and also find the source of the hissing when no music is being played. I suppose i'd better put my interior back together. Thanks for the input

Last edited by 106turbo; 07-28-2013 at 09:22 AM.
106turbo is offline   United Kingdom
0
Reply With Quote
      07-28-2013, 11:30 AM   #100
mob17
Brigadier General
 
mob17's Avatar
 
Drives: E92 335D
Join Date: Mar 2012
Location: East Middle Land, UK

Posts: 3,477
iTrader: (4)

Good to know its all working and now you can enjoy the bass!

Did you cut both cable loops on the xover as Gladen suggest? Apparantly if the original system did not have tweeters then you should cut them, which should cut noise.
__________________
2008 E92 335D SE
2010 E90 320D SE
1994 E36 318I SE
1996 E36 316I SE
mob17 is offline   United Kingdom
0
Reply With Quote
      07-28-2013, 01:06 PM   #101
106turbo
Boost Junkie
 
Drives: 106 Gti T
Join Date: Jun 2012
Location: Notts

Posts: 107
iTrader: (1)

Quote:
Originally Posted by mob17 View Post
Good to know its all working and now you can enjoy the bass!

Did you cut both cable loops on the xover as Gladen suggest? Apparantly if the original system did not have tweeters then you should cut them, which should cut noise.
No i did not. I read that in the manual, but then decided i'd have a listen first as the tweeters dont hiss but the actual speakers do. The doorcards are coming off for some sound deadening next so i might snip them and see. I can always join them back together.

Edit:

O.k so i've realised my bluetooth isnt working. Have i missed a cable out somewhere?
__________________
106 Gti Turbo

Currently 311bhp Atf.. Soon to be 300bhp Atw

E91 320D Workhorse

Last edited by 106turbo; 07-29-2013 at 01:57 AM.
106turbo is offline   United Kingdom
0
Reply With Quote
      07-29-2013, 11:53 AM   #102
Mr Singh
Banned
 
Drives: E91 330D M Sport Auto
Join Date: Oct 2011
Location: Milton Keynes

Posts: 773
iTrader: (3)

Sorry I'm late, the terminals have not been an issue for the last dozen or so sets that have gone out, so doesn't appear to be a bad batch.

Re Bluetooth. Did you install the quadloop harness, and are you sure the MOST connector was transferred over to the quadlock harness OK?
Mr Singh is offline   United Kingdom
0
Reply With Quote
      07-30-2013, 06:19 AM   #103
106turbo
Boost Junkie
 
Drives: 106 Gti T
Join Date: Jun 2012
Location: Notts

Posts: 107
iTrader: (1)

Quote:
Originally Posted by Mr Singh View Post
Sorry I'm late, the terminals have not been an issue for the last dozen or so sets that have gone out, so doesn't appear to be a bad batch.

Re Bluetooth. Did you install the quadloop harness, and are you sure the MOST connector was transferred over to the quadlock harness OK?
The connectors were only threaded in one Sub, all the rest were perfect. My Tweeter surrounds haev arrived at sytner so tonight i will fit those and check the rear of the radio to make sure all cables are connected as its such a tight fit something may have come loose. I will report my findings later.

BTW the bass is awsome. So much better than the boggo stereo! well worth the purchase.
__________________
106 Gti Turbo

Currently 311bhp Atf.. Soon to be 300bhp Atw

E91 320D Workhorse
106turbo is offline   United Kingdom
0
Reply With Quote
      10-13-2013, 02:08 PM   #104
-Ju-
Private
 
Drives: E93 335i
Join Date: Oct 2013
Location: Bradford

Posts: 81
iTrader: (1)

A really nice write up on the Gladen upgrade Andy, so nice in fact that I have gone down the same route.
I was looking at the Alpine upgrade initially but due to the fact you still have to add the subs, my car has the DAB tuner where the Alpine kit goes and some of the reviews were mixed I decided to just go the extra and get the Gladen kit.
It's all in now and I can confirm in the E93, the amp fits where the BMW one usually goes with the addition of a shallower storage bin. It's not a cheap upgrade but does make a big difference!
I'm still getting to grips with the setting up of the system as I've been used to half decent factory fit systems in the past so any help would be appreciated, but for now I'm happy
Julian
-Ju- is offline  
+1
Reply With Quote
      10-13-2013, 02:24 PM   #105
-Ju-
Private
 
Drives: E93 335i
Join Date: Oct 2013
Location: Bradford

Posts: 81
iTrader: (1)

Also thought I'd mention, I had a threaded connector on one of the mids too!
-Ju- is offline  
0
Reply With Quote
      10-18-2013, 10:12 AM   #106
CTR_Paul
New Member
 
Drives: 320d Sport Plus
Join Date: Oct 2013
Location: Cheshire, UK

Posts: 10
iTrader: (0)

Interesting thread (long time lurker!), I too have a 320d Sport Plus and the stereo really frustrates me, but I'm too damn scared of damaging something, so I'll probably not touch it.

*right that's my first post done - 24 hours until I can start a thread about my cars grinding noise issue I'm hoping you guys will be able to diagnose*
CTR_Paul is offline  
0
Reply With Quote
      10-19-2013, 09:32 AM   #107
TheBlondeFella
First Lieutenant
 
Drives: E93 320i M Sport
Join Date: Jun 2013
Location: Surrey, UK

Posts: 306
iTrader: (2)

Quote:
Originally Posted by -Ju- View Post
It's all in now and I can confirm in the E93, the amp fits where the BMW one usually goes with the addition of a shallower storage bin.
Any chance you could post a photo of where you installed the amp, I had to bolt mine to the rear partition in my e93?
TheBlondeFella is offline   England
0
Reply With Quote
      10-21-2013, 05:20 PM   #108
-Ju-
Private
 
Drives: E93 335i
Join Date: Oct 2013
Location: Bradford

Posts: 81
iTrader: (1)

Quote:
Originally Posted by TheBlondeFella View Post
Any chance you could post a photo of where you installed the amp, I had to bolt mine to the rear partition in my e93?
Yeah it's in the same place as the OP put it.
I had to order the shallower storage bin @ 45 to refit everything perfectly but everything is hidden as oem.
I took this pic before finalising the install with an mdf colour matched base but it shows the amp in position
-Ju- is offline  
0
Reply With Quote
      11-10-2013, 01:40 PM   #109
ecs0set
New Member
 
Drives: E93 335i
Join Date: Nov 2013
Location: Dorset, England

Posts: 14
iTrader: (0)

I'm almost ready to buy the Gladen kit. However I'm concerned about issues reported about volume of the bongs, PDC and Bluetooth. I also have front PDC which I guess will complicate it further as the front PDC will be amplified and the rear will not be.

Ive googled a lot but I'm finding it difficult to ascertain if there is a solution. Then theres the question over coding, to code or not to code (pre-LCI).

Can anyone give me some confidence that the Gladen kit will not break half the toys on the car?
ecs0set is offline  
0
Reply With Quote
      11-11-2013, 05:44 AM   #110
andyrap
Private
 
Drives: E91 320D M Sport Plus
Join Date: Feb 2013
Location: Bournemouth

Posts: 59
iTrader: (0)

Send a message via Skype™ to andyrap
Quote:
Originally Posted by ecs0set View Post
I'm almost ready to buy the Gladen kit. However I'm concerned about issues reported about volume of the bongs, PDC and Bluetooth. I also have front PDC which I guess will complicate it further as the front PDC will be amplified and the rear will not be.

Ive googled a lot but I'm finding it difficult to ascertain if there is a solution. Then theres the question over coding, to code or not to code (pre-LCI).

Can anyone give me some confidence that the Gladen kit will not break half the toys on the car?
I think that as you say, front PDC will be amplified but the rear won't. How much of an issue that might be for you I'm not sure.

Hifi coding is more of a problem potentially if you are still running the rears off the head unit (eg, install the 4-ch gladen to drive the front speakers and underfloor subs as most people do). The problem is that the rear speakers would then be driven at line level (unamplified) so the rear PDC will be a lot quieter. One reason I'm not coding mine.
andyrap is offline   United Kingdom
+1
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:34 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST