E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > 29F2 and 2DED - Meth pump without doing dynamic power supply step



Reply
 
Thread Tools Search this Thread
      04-07-2013, 07:14 AM   #1
PiSCaRGoT
Enlisted Member
 
PiSCaRGoT's Avatar
 
Drives: E93 335i 2007
Join Date: Mar 2013
Location: Malaysia

Posts: 37
iTrader: (0)

29F2 and 2DED - Meth pump without doing dynamic power supply step

I got this 2 codes. Nothing else.

29F2 10738 Fuel high pressure system, fuel pressure
2DED 11757 Power management, standby current control

Recently car has been idling less than perfect, but no long cranks.
Under a few high/full throttle pulls recently, I went into limp mode (probably 3 or 4 times now over 1 month period).

Injectors are 261, all new.
HPFP was changed about 20k kilometer ago (~2 years ago).

Recent mods were PWM Meth from Vishnu. Only note is that I did not perform the "optional but highly recommended" step to route dynamic power supply to Procede/Meth wiring.

Signs of a dying HPFP? Or on a long shot, could it be because of my wiring?
PiSCaRGoT is offline  
0
Reply With Quote
      04-07-2013, 12:16 PM   #2
caliguy562
Lieutenant
 
Drives: E92 335i
Join Date: Dec 2007
Location: garaged somewhere in soCal

Posts: 457
iTrader: (3)

When I had my meth kit in, I ran it without doing the optional step and had no issues. Only issues I did have were when I first did the dynamic power hook up. However, it may have been a coincidence.
caliguy562 is offline  
0
Reply With Quote
      04-08-2013, 04:15 AM   #3
PiSCaRGoT
Enlisted Member
 
PiSCaRGoT's Avatar
 
Drives: E93 335i 2007
Join Date: Mar 2013
Location: Malaysia

Posts: 37
iTrader: (0)

Hmm. Probably not related then.

I did however do the injector swaps myself. I didn't have a torque wrench for the fuel hard lines, so I did everything by feel (I did torque it down pretty hard, but equal, to my best judgement).

I did a quick fuel leak test and it turned out to be not leaking from anywhere. I might open it up again just in case I am springing a slow leak from somewhere.

Not sure if that would have triggered some 29F2 codes, but I should have been smelling some petrol if it was the case of a leak.
PiSCaRGoT is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:50 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST