E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > noise after Eibach coil install



Reply
 
Thread Tools Search this Thread
      04-18-2013, 05:54 PM   #1
J-RUE
Private
J-RUE's Avatar
1
Rep
65
Posts

 
Drives: 09 335
Join Date: Dec 2012
Location: New Rochelle NY

iTrader: (1)

noise after Eibach coil install

I've searched and read tons of threads on the topic of front end strut noise. seems similar to the knock others have described and is significantly worse at low speeds, no noise when hitting bumps on the highway.

I've had them taken apart and verified they were put together correctly with all washers in the same place. They've been taken off and re-installed by 2 reputable performance shops and the knock is still there.

The last shop suggested it may be the strut mount or endlinks but wanted to see if there is anything else I should be looking at.

thanks all!
Appreciate 0
      04-19-2013, 07:22 PM   #2
J-RUE
Private
J-RUE's Avatar
1
Rep
65
Posts

 
Drives: 09 335
Join Date: Dec 2012
Location: New Rochelle NY

iTrader: (1)

Anyone?
Appreciate 0
      04-23-2013, 01:12 PM   #3
MikeR1994
Second Lieutenant
United_States
5
Rep
227
Posts

 
Drives: 06 e90 325i, 05 325Ci (RIP)
Join Date: Sep 2011
Location: Charlotte, NC

iTrader: (0)

Garage List
2006 BMW 325i  [0.00]
Does it happen while turning? If so your end links might be getting caught on an improperly mounted wheel speed sensor wire bracket.
If it only happens over bumps at slower speeds it could just be coil bind, but I'd expect coil bind to happen at pretty much any speed. Maybe you just can't hear it over the road noise?
__________________
-Michael
Active Autowerke Stage II | MMW CSv2 Exhaust | MMW Catless Headers | BC Racing BR Extreme Low Coilovers | custom adjustable rear suspension links | 19" Hyperblack CSL's | M3 style front | trim wrapped in brushed steel vinyl | Slightly smoked tail lights with clear reverse lights | factory xenons

Appreciate 0
      04-25-2013, 06:25 PM   #4
J-RUE
Private
J-RUE's Avatar
1
Rep
65
Posts

 
Drives: 09 335
Join Date: Dec 2012
Location: New Rochelle NY

iTrader: (1)

Quote:
Originally Posted by MikeR1994 View Post
Does it happen while turning? If so your end links might be getting caught on an improperly mounted wheel speed sensor wire bracket.
If it only happens over bumps at slower speeds it could just be coil bind, but I'd expect coil bind to happen at pretty much any speed. Maybe you just can't hear it over the road noise?
I hear it, and can almost feel it if that makes sense, mostly on un even roads at slow speeds. Also immediately after accelerating from a stop or slow down
Appreciate 0
      04-25-2013, 07:00 PM   #5
MikeR1994
Second Lieutenant
United_States
5
Rep
227
Posts

 
Drives: 06 e90 325i, 05 325Ci (RIP)
Join Date: Sep 2011
Location: Charlotte, NC

iTrader: (0)

Garage List
2006 BMW 325i  [0.00]
Quote:
Originally Posted by J-RUE View Post
I hear it, and can almost feel it if that makes sense, mostly on un even roads at slow speeds. Also immediately after accelerating from a stop or slow down
sounds like something with the springs binding up. It's not really anything to worry about
__________________
-Michael
Active Autowerke Stage II | MMW CSv2 Exhaust | MMW Catless Headers | BC Racing BR Extreme Low Coilovers | custom adjustable rear suspension links | 19" Hyperblack CSL's | M3 style front | trim wrapped in brushed steel vinyl | Slightly smoked tail lights with clear reverse lights | factory xenons

Appreciate 0
      04-25-2013, 07:12 PM   #6
J-RUE
Private
J-RUE's Avatar
1
Rep
65
Posts

 
Drives: 09 335
Join Date: Dec 2012
Location: New Rochelle NY

iTrader: (1)

Quote:
Originally Posted by MikeR1994 View Post
sounds like something with the springs binding up. It's not really anything to worry about
Thanks..going to jack the car up and see if I see any spots that mind be binding.
Appreciate 0
      04-26-2013, 10:39 PM   #7
jjellyneck
First Lieutenant
3
Rep
335
Posts

 
Drives: 2008 335i MT
Join Date: Jun 2012
Location: TX

iTrader: (0)

Quote:
Originally Posted by J-RUE View Post
I hear it, and can almost feel it if that makes sense, mostly on un even roads at slow speeds. Also immediately after accelerating from a stop or slow down
On my old Infiniti G35 it was bad control arm bushings. The first 3 places(including the dealer) did not find it. An independent guy sniffed it out right away.
Appreciate 0
      04-27-2013, 04:47 PM   #8
natelam
Major
14
Rep
1,488
Posts

 
Drives: 08 e92 335i SG MT
Join Date: Jan 2011
Location: Bellevue Wa

iTrader: (5)

Does this happen when you are driving over speed bumps or just driving in general?
Appreciate 0
      04-28-2013, 04:24 AM   #9
CALWATERBOY
Captain
CALWATERBOY's Avatar
15
Rep
865
Posts

 
Drives: 2009 E93 N54
Join Date: Jan 2011
Location: San Francisco

iTrader: (0)

Quote:
Originally Posted by J-RUE View Post
I hear it, and can almost feel it if that makes sense, mostly on un even roads at slow speeds. Also immediately after accelerating from a stop or slow down

If lowered, suspension part can be knockin' against the body.

Did you align after reassembly?
Appreciate 0
      04-28-2013, 07:34 AM   #10
J-RUE
Private
J-RUE's Avatar
1
Rep
65
Posts

 
Drives: 09 335
Join Date: Dec 2012
Location: New Rochelle NY

iTrader: (1)

Quote:
Originally Posted by jjellyneck View Post
On my old Infiniti G35 it was bad control arm bushings. The first 3 places(including the dealer) did not find it. An independent guy sniffed it out right away.
I've had 2 shops look at it plus my boy whose a master tech and it appears the endlinks/bushings etc are fine.

Quote:
Originally Posted by natelam View Post
Does this happen when you are driving over speed bumps or just driving in general?
yup, speed bumps, accelerating from stop, and accelerating after slowing down. hear mostly at slow speeds.

Quote:
Originally Posted by CALWATERBOY View Post
If lowered, suspension part can be knockin' against the body.

Did you align after reassembly?
haven't done the alignment yet since I was waiting till i had the ride height I wanted.

thanks for the replies guys.
Appreciate 0
      06-10-2013, 01:09 AM   #11
rusty_g80
Private First Class
1
Rep
121
Posts

 
Drives: 2006 330xi
Join Date: May 2011
Location: Chicago

iTrader: (0)

Have you figured out what the issue was?
Appreciate 0
      06-10-2013, 07:31 PM   #12
J-RUE
Private
J-RUE's Avatar
1
Rep
65
Posts

 
Drives: 09 335
Join Date: Dec 2012
Location: New Rochelle NY

iTrader: (1)

Quote:
Originally Posted by rusty_g80 View Post
Have you figured out what the issue was?
not yet...i recently changed both front strut mounts and added adjustable endlinks. noise seems a bit better but def still there. not sure what else i can do...
Appreciate 0
      07-20-2013, 03:45 PM   #13
J-RUE
Private
J-RUE's Avatar
1
Rep
65
Posts

 
Drives: 09 335
Join Date: Dec 2012
Location: New Rochelle NY

iTrader: (1)

Quote:
Originally Posted by J-RUE View Post
not yet...i recently changed both front strut mounts and added adjustable endlinks. noise seems a bit better but def still there. not sure what else i can do...
thought i'd update this thread quickly....after adjusting the endlinks a bit more the noise is now gone, thank god!
Appreciate 0
      07-21-2013, 09:22 AM   #14
CALWATERBOY
Captain
CALWATERBOY's Avatar
15
Rep
865
Posts

 
Drives: 2009 E93 N54
Join Date: Jan 2011
Location: San Francisco

iTrader: (0)

boink!
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:13 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST