E90Post
 


VIBE Motorsports
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > Red Brake symbol + Red car on lift, need help!



Reply
 
Thread Tools Search this Thread
      04-08-2013, 08:32 PM   #1
330Raphi
Private
Canada
0
Rep
61
Posts

 
Drives: BMW 330i 2006
Join Date: Nov 2012
Location: Montreal

iTrader: (0)

Red Brake symbol + Red car on lift, need help!

So I got this red "parking brake" symbol and a red car on a lift. It did not appear when I was driving but next morning when I took the car. From what I read it might be a broken brake sensor. My question is: if I change my sensor, will I need to change braking pads too? Give me your thoughts I need help. Thanks!
Appreciate 0
      04-08-2013, 09:41 PM   #2
idrift4wd
Brigadier General
45
Rep
3,376
Posts

 
Drives: Three Hundred and Thirty Five
Join Date: Jul 2010
Location: Yonkers NY

iTrader: (0)

Garage List
2007 BMW  [3.50]
Quote:
Originally Posted by 330Raphi View Post
So I got this red "parking brake" symbol and a red car on a lift. It did not appear when I was driving but next morning when I took the car. From what I read it might be a broken brake sensor. My question is: if I change my sensor, will I need to change braking pads too? Give me your thoughts I need help. Thanks!
well that just means you need to do maintenance.

inspect your brakes and if they are okay, replace the sensors if they are faulty. your car has 2, front and rear, one for each, front driver side and rear passenger *i think. simply unplug sensor with tweezers and push back on. follow the wire to the box and swap the connections.

Might as well do a brake service. search how to reset your maintenance light.
Appreciate 0
      04-08-2013, 10:24 PM   #3
330Raphi
Private
Canada
0
Rep
61
Posts

 
Drives: BMW 330i 2006
Join Date: Nov 2012
Location: Montreal

iTrader: (0)

Quote:
Originally Posted by idrift4wd View Post
well that just means you need to do maintenance.

inspect your brakes and if they are okay, replace the sensors if they are faulty. your car has 2, front and rear, one for each, front driver side and rear passenger *i think. simply unplug sensor with tweezers and push back on. follow the wire to the box and swap the connections.

Might as well do a brake service. search how to reset your maintenance light.
Perfect thank you
Appreciate 0
      04-23-2013, 07:44 AM   #4
Philz BMW
Slow rollin
Philz BMW's Avatar
United_States
4
Rep
406
Posts

 
Drives: 328i koop
Join Date: Oct 2010
Location: USA

iTrader: (0)

Quote:
Originally Posted by idrift4wd View Post
well that just means you need to do maintenance.

inspect your brakes and if they are okay, replace the sensors if they are faulty. your car has 2, front and rear, one for each, front driver side and rear passenger *i think. simply unplug sensor with tweezers and push back on. follow the wire to the box and swap the connections.

Might as well do a brake service. search how to reset your maintenance light.
I had the same symbol pop up. I had the rear brakes serviced in 2011 and front serviced in 2012, so I doubt it's the pads or rotors. Must be a faulty sensor.
__________________

Business: BMW 328i Coupe
Pleasure: Ducati 1098S
Appreciate 0
      04-23-2013, 08:33 PM   #5
VTECaddict
Where'd my VTEC go?
VTECaddict's Avatar
47
Rep
4,620
Posts

 
Drives: 06 330i 6MT
Join Date: Mar 2009
Location: Bakersfield, CA

iTrader: (4)

did they reset the CBS after you had the brakes serviced?
__________________
AW/Terra | ZSP | ZPP | ZCW | iDrive | CA
Mods: BC BR | OEM Blacklines | M-tech rear | custom dual exhaust | M3 steering wheel | BMW SSK | ZHP shift knob | BMW Performance rep spoiler
Varrstoen ES1 19x9.5+20 Front, 19x11+25 rear
Appreciate 0
      04-24-2013, 04:27 PM   #6
330Raphi
Private
Canada
0
Rep
61
Posts

 
Drives: BMW 330i 2006
Join Date: Nov 2012
Location: Montreal

iTrader: (0)

My mechanic checked my car and told me I needed both front and rear brake pads, rotors and of course the sensors.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:20 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST