E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > All-Wheel-Drive (Xi / xDrive) Talk > Troubles 330xd e92 Automatic gearbox



Reply
 
Thread Tools Search this Thread
      04-22-2013, 12:55 AM   #1
aadum
Private
aadum's Avatar
0
Rep
90
Posts

 
Drives: 330 xd
Join Date: Aug 2011
Location: Split,Croatia

iTrader: (0)

Troubles 330xd e92 Automatic gearbox

Hello guys,
I have a problem that is getting worse and worse as time passes by.
I have 2007 European 330xd e92 Automatic gearbox.
Main problem is when I am accelerating with my car.Then I get feeling like my car is ("jerking") if that would be good term.Something like the clutch is slipping.Car does accelerate but I get feeling like it is skipping something. It feels worse when I am driving on inclines or hard accelerating.At first I thought it might be transfer case problem but now I am not sure because when I use my manual mode my car simply goes crazy.It doesn't want to shift to higher gear or it shifts to another gear but then suddenly loose its power and downshift. Also sometimes in the morning when I want to move away with the car and I push the throttle it takes a second or two until car starts moving and it jumps suddenly like something was holding it. There are no errors on dashboard and I didn't go to the dealer to connect it to computer to see if there are any fault codes there.(EDIT) Automatic gearbox fluid and filter changed 10000 km ago.
Any ideas? Appreciate any input
p.s. sorry for my bad English

Last edited by aadum; 04-22-2013 at 01:15 AM.
Appreciate 0
      04-22-2013, 07:59 PM   #2
Jeffman
Lieutenant
Jeffman's Avatar
5
Rep
442
Posts

 
Drives: 2008 335xi E90
Join Date: Jul 2010
Location: Somewhere in America

iTrader: (1)

Garage List
Quote:
Originally Posted by aadum View Post
Hello guys,
I have a problem that is getting worse and worse as time passes by.
I have 2007 European 330xd e92 Automatic gearbox.
Main problem is when I am accelerating with my car.Then I get feeling like my car is ("jerking") if that would be good term.Something like the clutch is slipping.Car does accelerate but I get feeling like it is skipping something. It feels worse when I am driving on inclines or hard accelerating.At first I thought it might be transfer case problem but now I am not sure because when I use my manual mode my car simply goes crazy.It doesn't want to shift to higher gear or it shifts to another gear but then suddenly loose its power and downshift. Also sometimes in the morning when I want to move away with the car and I push the throttle it takes a second or two until car starts moving and it jumps suddenly like something was holding it. There are no errors on dashboard and I didn't go to the dealer to connect it to computer to see if there are any fault codes there.(EDIT) Automatic gearbox fluid and filter changed 10000 km ago.
Any ideas? Appreciate any input
p.s. sorry for my bad English
What's the total mileage on your car? Are you the original owner? How do you drive it - lot's of 0-100kph launches, or are you a "normal" driver ?
Appreciate 0
      04-22-2013, 10:48 PM   #3
aadum
Private
aadum's Avatar
0
Rep
90
Posts

 
Drives: 330 xd
Join Date: Aug 2011
Location: Split,Croatia

iTrader: (0)

Quote:
Originally Posted by JHR View Post
What's the total mileage on your car? Are you the original owner? How do you drive it - lot's of 0-100kph launches, or are you a "normal" driver ?
124 000 miles (200 000 km) , it was driven mostly on highway.I am original owner. Last 1 year I have lot's of launches as I removed DPF (diesel particulate filter) and made chip tuning accordingly. I had 230 HP 500 nm now is 268HP 580nm.

problems started before chip tuning so I don't think it is related much.Maybe it made it worse
Appreciate 0
      04-23-2013, 08:24 PM   #4
Jeffman
Lieutenant
Jeffman's Avatar
5
Rep
442
Posts

 
Drives: 2008 335xi E90
Join Date: Jul 2010
Location: Somewhere in America

iTrader: (1)

Garage List
Quote:
Originally Posted by aadum View Post
124 000 miles (200 000 km) , it was driven mostly on highway.I am original owner. Last 1 year I have lot's of launches as I removed DPF (diesel particulate filter) and made chip tuning accordingly. I had 230 HP 500 nm now is 268HP 580nm.

problems started before chip tuning so I don't think it is related much.Maybe it made it worse
124,000 miles...doesn't sound good. Best to take it to a mechanic. Sorry dude.
Appreciate 0
      04-23-2013, 09:38 PM   #5
ska///235i
***** noob
ska///235i's Avatar
United_States
194
Rep
9,226
Posts

 
Drives: M235i
Join Date: Sep 2005
Location: Boston

iTrader: (32)

Garage List
2006 325xi  [0.00]
sounds like a tranny slip
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:44 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST