E90Post
 


ProTUNING Freaks
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Australia > Transmission faulty



Reply
 
Thread Tools Search this Thread
      04-25-2013, 05:48 AM   #1
R3N
Private First Class
Australia
1
Rep
197
Posts

Drives: None
Join Date: Aug 2012
Location: Perth, Australia

iTrader: (0)

Transmission faulty

Anyone had the "Transmission faulty" warning message come on before? Happened to me today as I was on the freeway, got up to 100km/h then set the cruise control on. The transmission would change up and down and back up again on the constant speed, then I got the warning message. Drove slowly after that, turned engine off then when back on again and the warning message was gone. After that the car drives fine. Car is a 08 e92 335i step.

Will try to get it to the dealer in the next few days.
Appreciate 0
      04-25-2013, 07:12 PM   #2
_ink
Major
_ink's Avatar
Australia
23
Rep
1,289
Posts

Drives: 335i 09' DCT M-Sport
Join Date: May 2012
Location: Sydney, Australia

iTrader: (0)

Did you install anything recently?
__________________
... Check out the garage
Appreciate 0
      04-26-2013, 04:37 AM   #3
Jin-ActiveMotorwerke
Private First Class
1
Rep
126
Posts

Drives: BMW E46 330i
Join Date: Apr 2012
Location: Melbourne

iTrader: (0)

For this kind of fault is best to have someone to check the fault code and do a diagnoses with the factory machine.
Appreciate 0
      04-26-2013, 05:37 AM   #4
R3N
Private First Class
Australia
1
Rep
197
Posts

Drives: None
Join Date: Aug 2012
Location: Perth, Australia

iTrader: (0)

Quote:
Originally Posted by _ink View Post
Did you install anything recently?
Nope, car is standard mechanically

Quote:
Originally Posted by Jin.ActiveMotorwerke View Post
For this kind of fault is best to have someone to check the fault code and do a diagnoses with the factory machine.
Are the faults logged in the computer even though the message has gone?
Appreciate 0
      04-26-2013, 08:22 PM   #5
BMJ
Captain
BMJ's Avatar
16
Rep
931
Posts

Drives: 335
Join Date: May 2012
Location: Australia

iTrader: (2)

Quote:
Originally Posted by R3N View Post
Are the faults logged in the computer even though the message has gone?
yeh they will be......
Appreciate 0
      04-29-2013, 03:00 AM   #6
BMJ
Captain
BMJ's Avatar
16
Rep
931
Posts

Drives: 335
Join Date: May 2012
Location: Australia

iTrader: (2)

Quote:
Originally Posted by R3N View Post
Anyone had the "Transmission faulty" warning message come on before? Happened to me today as I was on the freeway, got up to 100km/h then set the cruise control on. The transmission would change up and down and back up again on the constant speed, then I got the warning message. Drove slowly after that, turned engine off then when back on again and the warning message was gone. After that the car drives fine. Car is a 08 e92 335i step.

Will try to get it to the dealer in the next few days.
any updates on this R3N?
Appreciate 0
      04-29-2013, 08:05 AM   #7
R3N
Private First Class
Australia
1
Rep
197
Posts

Drives: None
Join Date: Aug 2012
Location: Perth, Australia

iTrader: (0)

Not had time yet. I connected a Cobb Accessport and got a few codes, none of which really relate to the transmission but still need attention. The only code which may be linked would be 2DC5 Torque requirement via CAN controller are network. Need to read up on it more...
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:24 PM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST