E90Post
 


VIBE Motorsports
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > The not so fun parts of the N54



Reply
 
Thread Tools Search this Thread
      05-19-2013, 10:04 AM   #111
psmitty95
Brigadier General
psmitty95's Avatar
United_States
101
Rep
3,754
Posts

 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

iTrader: (8)

Quote:
Originally Posted by DR-JEKL View Post
So you have changed plugs coils and done the walnut blast?

What about a check of your vac lines, what codes have you pulled?
Well I changed plugs but not coils. Coils I swapped around cyl 5 and 4 to 1 and 2 but the misfires stayed in 5 and 4. Yesterday at the shop the codes were misfire cyl 4. I threw a ton of codes on the way home but haven't had a chance to check them yet since the USB on my JB4 broke randomly... I ordered a new one so hopefully it gets here sometime in the next few days.

Quote:
Originally Posted by E92nate View Post
I don't know if this has been brought up already, but which firmware are you running? Have you updated to the latest JB4 firmware as of late? And also you might want to check to see if your AFR and Fuel open loop mapping numbers are set to default after an update. I had a similar problem awhile back and I updated my firmware and double checked all the default numbers and never had the problem ever again. Hope all is well.
Well I switched to the ISO board with ISO 19 the second day of misfires. First day I was on the G4 15 ohm board I was running for the last year then I switched. I haven't gotten to do ISO 20 yet since my USB cable is broken but i'm updating to that and I guess i'll restore to default firmware once I do that.



Another thing I forgot to mention from yesterday is at firs the tech came in and told me he thought it was my O2 sensors maybe got fried from that backfire I had the first day. He said he got the system check and trimm control codes and then when he was monitoring all the o2's one wasn't moving and monitoring like the others. But then when he brought me out it was back to normal and moving with the other rear o2 and monitoring properly. When we went out and got the car to misfire it didn't throw the o2 codes so he changed his mind and said its probably not o2's.
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: Cobb V3 w/ Motiv Tune, VRSF DP/FMIC, ER CP, Roc-Euro DCI, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
Appreciate 0
      05-19-2013, 10:52 AM   #112
Gugs
Cynical
Gugs's Avatar
United_States
5
Rep
439
Posts

 
Drives: E92 JetBlack
Join Date: Jul 2012
Location: Long island

iTrader: (1)

Go get new injectors. You cannot replace ONE. Each Bank is required. They are covered at the dealer as they were RECALLED. NOTHING to do with warranty
Appreciate 0
      05-19-2013, 11:53 AM   #113
cn555ic
BimmerPost Supporting Vendor
cn555ic's Avatar
United_States
246
Rep
18,287
Posts


 
Drives: Bimmerscoding.com
Join Date: Jun 2007
Location: New York

iTrader: (5)

Send a message via Yahoo to cn555ic
Can't even replace one anymore if you have the older injectors as they are discontinued. The new version Injectors require all to be the same.
Appreciate 0
      05-19-2013, 12:19 PM   #114
psmitty95
Brigadier General
psmitty95's Avatar
United_States
101
Rep
3,754
Posts

 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

iTrader: (8)

Quote:
Originally Posted by Gugs View Post
Go get new injectors. You cannot replace ONE. Each Bank is required. They are covered at the dealer as they were RECALLED. NOTHING to do with warranty
Wait so you're saying they have a recall for the new injectors? Not willing to pay the dealership to have all 6 replaced but if it's free i'll get in ASAP.

Quote:
Originally Posted by cn555ic View Post
Can't even replace one anymore if you have the older injectors as they are discontinued. The new version Injectors require all to be the same.
I know that's what sucks even more. Cyl 3 and 5 are new 261 part numbers and I bought an extra one just in case. Now Autocouture wants to do the other 4 and they've never heard the thing about having to replace all 6. They said they're calling BMW to confirm this week then they'll let me know what they hear but worst case if what I said is right they should be able to find 3 261 injectors
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: Cobb V3 w/ Motiv Tune, VRSF DP/FMIC, ER CP, Roc-Euro DCI, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
Appreciate 0
      05-19-2013, 03:37 PM   #115
marv85
Colonel
marv85's Avatar
United_States
25
Rep
2,558
Posts

 
Drives: '07 335i MT
Join Date: Jun 2010
Location: Portland

iTrader: (5)

Quote:
Originally Posted by psmitty95 View Post
Hmm that's not a bad idea but I think it would still misfire only because the first day of misfires was G4 board then then I swapped to ISO and nothing changed. I don't know anyone here with a cobb unfortunately but I guess I should start looking around. Pretty much willing to try almost anything at this point



Hahahah will do
thing is with COBB fuel control is spot on. at least you will remove AFRs as a possible cause.
__________________
'10 E92 335i , COBB
Appreciate 0
      05-19-2013, 03:58 PM   #116
psmitty95
Brigadier General
psmitty95's Avatar
United_States
101
Rep
3,754
Posts

 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

iTrader: (8)

Quote:
Originally Posted by marv85 View Post
thing is with COBB fuel control is spot on. at least you will remove AFRs as a possible cause.
Ik I definitely want to try cobb just don't know anyone local who has one they'd be willing to let me borrow for a few days. I'm seeing if E90company wants to trade with me for a few days and we can ship each other but I don't think he does. I plan on doing cobb with BMS flash eventually but can't buy one at the moment.


If anyone wants to trade and ship each other tunes so they can try iso for a few days and let me try the cobb i'm down
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: Cobb V3 w/ Motiv Tune, VRSF DP/FMIC, ER CP, Roc-Euro DCI, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
Appreciate 0
      05-20-2013, 02:31 PM   #117
psmitty95
Brigadier General
psmitty95's Avatar
United_States
101
Rep
3,754
Posts

 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

iTrader: (8)

My USB cable on the Jb4 is broken and i'm waiting for a new one but pulled some codes with some little OBD II reader today. P0304, P0305, P0420, P0430. From what i've gathered that's misfire cyl 4 and 5. The other two codes have something to do with O2's but I couldnt find a definite answer on what they mean. Are those normal catless codes or something are those the weird system check and trimm control codes I keep getting every now and then? I cleared the codes and then today on the way back from work i'll get it to misfire again then see what comes up
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: Cobb V3 w/ Motiv Tune, VRSF DP/FMIC, ER CP, Roc-Euro DCI, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
Appreciate 0
      05-20-2013, 04:17 PM   #118
psmitty95
Brigadier General
psmitty95's Avatar
United_States
101
Rep
3,754
Posts

 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

iTrader: (8)

On the way to work I got cylinder 4 and 2 misfire. On map 2 the car hesitates a bit but wont throw codes. Map 5 with e85 boosting 15+ is where i get the ses and then codes.
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: Cobb V3 w/ Motiv Tune, VRSF DP/FMIC, ER CP, Roc-Euro DCI, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
Appreciate 0
      05-20-2013, 05:14 PM   #119
marv85
Colonel
marv85's Avatar
United_States
25
Rep
2,558
Posts

 
Drives: '07 335i MT
Join Date: Jun 2010
Location: Portland

iTrader: (5)

Quote:
Originally Posted by psmitty95 View Post
On the way to work I got cylinder 4 and 2 misfire. On map 2 the car hesitates a bit but wont throw codes. Map 5 with e85 boosting 15+ is where i get the ses and ten codes.
ses means you are running lean right? it just smells like a lean misfire
__________________
'10 E92 335i , COBB
Appreciate 0
      05-20-2013, 05:57 PM   #120
psmitty95
Brigadier General
psmitty95's Avatar
United_States
101
Rep
3,754
Posts

 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

iTrader: (8)

Quote:
Originally Posted by marv85
Quote:
Originally Posted by psmitty95 View Post
On the way to work I got cylinder 4 and 2 misfire. On map 2 the car hesitates a bit but wont throw codes. Map 5 with e85 boosting 15+ is where i get the ses and ten codes.
ses means you are running lean right? it just smells like a lean misfire
I thought the SES light just meant there was a code stored? Maybe it is my o2's? The guys at autocouture thought maybe my backfire blew one of my rear o2's since the other 3 were reading normal but one was stuck at .1 . They changed their mind though after checking again in 5 minutes because it was back to normal and monitoring and the trimm control and system check codes didnt show up after we took it out to get it to misfire.
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: Cobb V3 w/ Motiv Tune, VRSF DP/FMIC, ER CP, Roc-Euro DCI, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
Appreciate 0
      05-20-2013, 07:34 PM   #121
psmitty95
Brigadier General
psmitty95's Avatar
United_States
101
Rep
3,754
Posts

 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

iTrader: (8)

Way home from work made it misfire again and got P0304 cylinder 4 misfire. Seems like now cylinder 4 is the main culprit. Anyone think I should just do all 6 coil packs so I can rule those out completely like spark plugs? I swapped cyl 4 with cyl 3 and cyl 6 with cyl 2 coils packs about two weeks ago but it seemed like the misfire didn't follow the coil pack. As of now i'm pretty much willing to try anything though
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: Cobb V3 w/ Motiv Tune, VRSF DP/FMIC, ER CP, Roc-Euro DCI, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
Appreciate 0
      05-20-2013, 07:40 PM   #122
joec500
Brigadier General
46
Rep
3,004
Posts

 
Drives: it has 4 wheels
Join Date: Jul 2008
Location: San Francisco

iTrader: (10)

Quote:
Originally Posted by psmitty95 View Post
Way home from work made it misfire again and got P0304 cylinder 4 misfire. Seems like now cylinder 4 is the main culprit. Anyone think I should just do all 6 coil packs so I can rule those out completely like spark plugs? I swapped cyl 4 with cyl 3 and cyl 6 with cyl 2 coils packs about two weeks ago but it seemed like the misfire didn't follow the coil pack. As of now i'm pretty much willing to try anything though
What are the conditions that cause the misfires? Higher RPM's? Cruising? When my coilpack failed, the car just misfired all the time and followed the cylinder when moved.

When I had sporadic misfires like yours, it was not the o2, but rather the injectors. But in my situation it was confined to ONE bank, where as yours jump between banks.

I think the only thing left to try is to replace all 6 injectors if you have not already. When I had a similar issue, I replaced all 3 injectors in the mis-firing bank and my misfires have yet to return.
__________________
2007 E92 6MT SGM: MusicarNW Level 2, Procede Rev 2.5, FFTEC/Vishnu LPFP with Flexfuel Sensor and Flash, M3 Offset V701's, WaveTrac LSD, Michelin PSS, Downpipes, M3 Control Arms, TCKline D/A Suspension, LCI Tail lights, Lux AE's, ER Charge Pipe, DCI's, Mtech Front and Rear, M3 Sideskirts, HPF Stage 1 Clutch
Appreciate 0
      05-20-2013, 07:58 PM   #123
psmitty95
Brigadier General
psmitty95's Avatar
United_States
101
Rep
3,754
Posts

 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

iTrader: (8)

Quote:
Originally Posted by joec500 View Post
What are the conditions that cause the misfires? Higher RPM's? Cruising? When my coilpack failed, the car just misfired all the time and followed the cylinder when moved.

When I had sporadic misfires like yours, it was not the o2, but rather the injectors. But in my situation it was confined to ONE bank, where as yours jump between banks.

I think the only thing left to try is to replace all 6 injectors if you have not already. When I had a similar issue, I replaced all 3 injectors in the mis-firing bank and my misfires have yet to return.
It happens under high boost (map 5 E85 15PSI+) and under a lot of load. For example in map 5 I can do a pull from 0mph to 70mph just ripping through 1st, 2nd, and 3rd and it will almost always be smooth as can be with no hiccups. Once I put it under load like 4th gear at 35-40mph for example, it will build boost then once boost is built start shaking until it throws a code and shuts down one cylinder.

Autocouture was as puzzled as I am and said they think I should make sure I have all new injectors. Since I did cyl 5 a few weeks ago and cyl 3 last summer they said I should just do the other 4 cylinders. My only thing that makes me think it might not be that is that one of my misfires on Saturday was a cylinder 5 misfire. They said maybe the first cylinder in the bank is misfiring then slowing down the others which results in cylinder 5? Since today was essentially all cylinder 4 misfires with one cylinder 2, it makes me think it could possibly be injectors. Some other suggestions i've had from people is cleaning or replacing Vanos, doing all 6 coil packs, or replacing both rear o2's
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: Cobb V3 w/ Motiv Tune, VRSF DP/FMIC, ER CP, Roc-Euro DCI, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
Appreciate 0
      05-20-2013, 08:05 PM   #124
joec500
Brigadier General
46
Rep
3,004
Posts

 
Drives: it has 4 wheels
Join Date: Jul 2008
Location: San Francisco

iTrader: (10)

Quote:
Originally Posted by psmitty95 View Post
It happens under high boost (map 5 E85 15PSI+) and under a lot of load. For example in map 5 I can do a pull from 0mph to 70mph just ripping through 1st, 2nd, and 3rd and it will almost always be smooth as can be with no hiccups. Once I put it under load like 4th gear at 35-40mph for example, it will build boost then once boost is built start shaking until it throws a code and shuts down one cylinder.

Autocouture was as puzzled as I am and said they think I should make sure I have all new injectors. Since I did cyl 5 a few weeks ago and cyl 3 last summer they said I should just do the other 4 cylinders. My only thing that makes me think it might not be that is that one of my misfires on Saturday was a cylinder 5 misfire. They said maybe the first cylinder in the bank is misfiring then slowing down the others which results in cylinder 5? Since today was essentially all cylinder 4 misfires with one cylinder 2, it makes me think it could possibly be injectors. Some other suggestions i've had from people is cleaning or replacing Vanos, doing all 6 coil packs, or replacing both rear o2's
If it's only High Boost, there is a good chance that it is Coilpacks or Plugs. I got a good deal 6 new coilpacks on Ebay. They sell Bosch ones at great deals.
__________________
2007 E92 6MT SGM: MusicarNW Level 2, Procede Rev 2.5, FFTEC/Vishnu LPFP with Flexfuel Sensor and Flash, M3 Offset V701's, WaveTrac LSD, Michelin PSS, Downpipes, M3 Control Arms, TCKline D/A Suspension, LCI Tail lights, Lux AE's, ER Charge Pipe, DCI's, Mtech Front and Rear, M3 Sideskirts, HPF Stage 1 Clutch
Appreciate 0
      05-20-2013, 08:36 PM   #125
psmitty95
Brigadier General
psmitty95's Avatar
United_States
101
Rep
3,754
Posts

 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

iTrader: (8)

Quote:
Originally Posted by joec500 View Post
If it's only High Boost, there is a good chance that it is Coilpacks or Plugs. I got a good deal 6 new coilpacks on Ebay. They sell Bosch ones at great deals.
Got the link anywhere? I did all 6 plugs recently so maybe i'll give coil packs a try even though I swapped them around and they didn't follow. But also keep in mind by only in high boost I meant high boost is only when it throws the code. If I do a 4th gear pull under load in map 2 it stumbles maybe once or twice but otherwise relatively smooth. Almost always no codes from that though
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: Cobb V3 w/ Motiv Tune, VRSF DP/FMIC, ER CP, Roc-Euro DCI, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
Appreciate 0
      05-20-2013, 08:38 PM   #126
joec500
Brigadier General
46
Rep
3,004
Posts

 
Drives: it has 4 wheels
Join Date: Jul 2008
Location: San Francisco

iTrader: (10)

Quote:
Originally Posted by psmitty95 View Post
Got the link anywhere? I did all 6 plugs recently so maybe i'll give coil packs a try even though I swapped them around and they didn't follow. But also keep in mind by only in high boost I meant high boost is only when it throws the code. If I do a 4th gear pull under load in map 2 it stumbles maybe once or twice but otherwise relatively smooth. Almost always no codes from that though
Also switch to straight Unleaded fuel if you have not tried that yet.
__________________
2007 E92 6MT SGM: MusicarNW Level 2, Procede Rev 2.5, FFTEC/Vishnu LPFP with Flexfuel Sensor and Flash, M3 Offset V701's, WaveTrac LSD, Michelin PSS, Downpipes, M3 Control Arms, TCKline D/A Suspension, LCI Tail lights, Lux AE's, ER Charge Pipe, DCI's, Mtech Front and Rear, M3 Sideskirts, HPF Stage 1 Clutch
Appreciate 0
      05-20-2013, 08:41 PM   #127
psmitty95
Brigadier General
psmitty95's Avatar
United_States
101
Rep
3,754
Posts

 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

iTrader: (8)

Quote:
Originally Posted by joec500 View Post
Also switch to straight Unleaded fuel if you have not tried that yet.
Well I have a 93/E85 mix in their now but I usually fill up with Mobil 93
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: Cobb V3 w/ Motiv Tune, VRSF DP/FMIC, ER CP, Roc-Euro DCI, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
Appreciate 0
      05-20-2013, 08:45 PM   #128
joec500
Brigadier General
46
Rep
3,004
Posts

 
Drives: it has 4 wheels
Join Date: Jul 2008
Location: San Francisco

iTrader: (10)

Quote:
Originally Posted by psmitty95 View Post
Well I have a 93/E85 mix in their now but I usually fill up with Mobil 93
I would try straight 93 to remove that variable.
__________________
2007 E92 6MT SGM: MusicarNW Level 2, Procede Rev 2.5, FFTEC/Vishnu LPFP with Flexfuel Sensor and Flash, M3 Offset V701's, WaveTrac LSD, Michelin PSS, Downpipes, M3 Control Arms, TCKline D/A Suspension, LCI Tail lights, Lux AE's, ER Charge Pipe, DCI's, Mtech Front and Rear, M3 Sideskirts, HPF Stage 1 Clutch
Appreciate 0
      05-20-2013, 08:54 PM   #129
ZTZ1010
Captain Planet
ZTZ1010's Avatar
United_States
23
Rep
1,062
Posts

 
Drives: 11' E92 ZCP M3
Join Date: Feb 2008
Location: CT

iTrader: (8)

Garage List
2009 BMW 335i  [4.80]
2011 BMW M3  [0.00]
Send a message via AIM to ZTZ1010
Quote:
Originally Posted by joec500 View Post
I would try straight 93 to remove that variable.
+1. could be e85 related, no? like a lean spike that damaged a piston? maybe get a compression test
__________________
2011.5 Alpine White E92 M3 | DCT w/ BPM Software | ZCP | CF Roof | CF Lip| Fully Coded | AFE Stage 2 Intake| ACM Exhaust | ACM Test Pipes | BPM Stage II Dev Tune | AA Pulleys | RPi Scoops | Swift Springs | LED Interior Lights| LUX V4 | Extended Aluminum DCT Paddles|
Appreciate 0
      05-20-2013, 08:57 PM   #130
Lifted07Duramax
Major
26
Rep
1,359
Posts

 
Drives: 2008 BMW red 335i coupe
Join Date: Jan 2013
Location: springfield, mo

iTrader: (1)

subbed to see what the fix finally ends up being
__________________
JB4 G5, VRSF catless DPs, FMIC, BMS DCI, Muffler Delete, Alpina B3 Flash, RB Turbos, BB Race Flash
Appreciate 0
      05-20-2013, 09:09 PM   #131
E90Company
Major General
E90Company's Avatar
No_Country
72
Rep
6,139
Posts

 
Drives: Car
Join Date: Mar 2012
Location: FL

iTrader: (2)

Quote:
Originally Posted by ZTZ1010 View Post
+1. could be e85 related, no? like a lean spike that damaged a piston? maybe get a compression test
I told him it's either bad front O2's or damaged ringland/cracked pistons. Told him to get a compression test too. He hasn't listened and was dead set on it being carbon buildup when I told him it wasn't. I was right
Appreciate 0
      05-20-2013, 09:12 PM   #132
vereak82
Second Lieutenant
vereak82's Avatar
4
Rep
287
Posts

 
Drives: 6-spd e92 335i
Join Date: May 2011
Location: michigan

iTrader: (0)

My serpentine belt just let go on the highway and tore up my front crank seal also after wrapping around the crank pulley... Oil everywhere son of ahhhh!
__________________
2008 135i 6-speed current stock for now
1995 e36 M3 5-speed
Jb4 G5//CM-FX400//FBO//Meth// 12.06@118 6-speed manual sold summer 2013
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:34 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST