E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > The not so fun parts of the N54



Reply
 
Thread Tools Search this Thread
      05-21-2013, 07:41 PM   #155
psmitty95
Brigadier General
 
psmitty95's Avatar
 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT

Posts: 3,445
iTrader: (7)

Ok so something weird happened tonight that really has me worried... A few guys suggested reset adaptations so I did that with JB4 (Menu 1 option 7) then drove home from work. Did a pull on my usual straight in 3rd gear and got the normal misfire and SES light. Restarted the car and had a 4x4/DSC light come on, start off assistance disabled, and half engine light. Pulled over immediately and the car was revving itself up to 1200 and back to 1000 nonstop...

Restarted the car and it did the exact same thing. Took a video with my phone but my phone stopped it early so it's only 3 seconds. When I first connected the OBD tool it said there were 5 faults but then I disconnected it to try to take another video and the car started up fine. When I put the OBD reader back in it said I only had 3 faults. Faults were P1632, P1417, and P0304 (cylinder 4 misfire). I'm looking into the other two codes now but here's the video of what happened. Felt like my car was trying to build boost and "two-step" like a Subaru.



To be honest i'm starting to get fed up with this. The misfire is my priority issue right now but the A/C is also not working on this car... I'm seriously starting to consider parting it out and selling it

Edit: Also to clarify that is not me hitting the gas pedal... The car was doing that itself


Just searched into those other codes and thank god but seems like this might be normal behavior... Aparently after doing a throttle adaptation reset you have to keep the key in the on position for 3 minutes to re-initialize the throttle body

http://forums.n54tech.com/showthread.php?p=245985
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: FBO + Meth JB4 ISO, BB flash, VRSF DP/FMIC, ER CP, Stett, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno

Last edited by psmitty95; 05-21-2013 at 07:53 PM.
psmitty95 is offline   United_States
0
Reply With Quote
      05-21-2013, 08:52 PM   #156
JETBLK335i
Lieutenant
 
Drives: 2008 335i
Join Date: Nov 2010
Location: Greenwich, CT

Posts: 413
iTrader: (1)

the same thing happened with me when i reset my throttle with the procede. Does it give you an option to reset the transmission with the JB4?
JETBLK335i is offline   United_States
0
Reply With Quote
      05-21-2013, 09:31 PM   #157
psmitty95
Brigadier General
 
psmitty95's Avatar
 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT

Posts: 3,445
iTrader: (7)

Quote:
Originally Posted by JETBLK335i View Post
the same thing happened with me when i reset my throttle with the procede. Does it give you an option to reset the transmission with the JB4?
Not that I know of but I don't think I have to since i'm a manual, right?
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: FBO + Meth JB4 ISO, BB flash, VRSF DP/FMIC, ER CP, Stett, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
psmitty95 is offline   United_States
0
Reply With Quote
      05-22-2013, 06:37 AM   #158
1nityrider
Private First Class
 
Drives: 2008 335xi
Join Date: Nov 2012
Location: St Paul

Posts: 152
iTrader: (0)

If you don't have downpipes why do you return the car to a known good state? Take off the JB4 and start troubleshooting back up.
1nityrider is offline   United_States
0
Reply With Quote
      05-22-2013, 07:28 AM   #159
psmitty95
Brigadier General
 
psmitty95's Avatar
 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT

Posts: 3,445
iTrader: (7)

Quote:
Originally Posted by 1nityrider
If you don't have downpipes why do you return the car to a known good state? Take off the JB4 and start troubleshooting back up.
I do have downpipes. On stock boost it doesnt seem to misfire although i will occasionally feel a slight hesitation. I dont think a fmic, charge pipe, or intake would cause a misire but i could be wrong

Edit: i think i might just do all 6 coils next since that will be another thing that can be rules out
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: FBO + Meth JB4 ISO, BB flash, VRSF DP/FMIC, ER CP, Stett, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
psmitty95 is offline   United_States
0
Reply With Quote
      05-22-2013, 08:02 AM   #160
..
Colonel
 
..'s Avatar
 
Drives: BMW
Join Date: Jun 2009
Location: Miami

Posts: 2,345
iTrader: (15)

the oscillating rpm is a result of the adaption reset. whenever you reset adaptions you will have that happen. clear the codes and it will go away.
.. is offline  
0
Reply With Quote
      05-22-2013, 09:13 AM   #161
SCS15
Captain
 
SCS15's Avatar
 
Drives: E92 335i 6MT
Join Date: Feb 2011
Location: Westchester, NY

Posts: 742
iTrader: (3)

Damn pete, cant believe this is still going on ....hope you get it figured out without blowing a whole in your pockets...dont sell it though man, its come so far and you honestly wont find another car as fun
__________________
Car for sale http://www.e90post.com/forums/showthread.php?t=881526
JB4 G5 - Forge FMIC - VRSF V2 DP - Magnaflow 15529 Catback Exhaust - BMS Clutch Stop - BMS DCI - CDV Delete - Dinan Stage 3 Suspension - 19x8.5/10 Forgestar F14 Gloss Gunmetal - Michelin PSS - M-Sport Front & Rear - M3 Side Skirts - OEM M3 Decklid Spoiler - BMW Performance Grilles - ZHP Shift Knob - M-Sport Steering Wheel - M-Sport Door Sills
SCS15 is offline  
0
Reply With Quote
      05-22-2013, 01:48 PM   #162
psmitty95
Brigadier General
 
psmitty95's Avatar
 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT

Posts: 3,445
iTrader: (7)

Quote:
Originally Posted by R 4 5 T 4 M 4 N View Post
the oscillating rpm is a result of the adaption reset. whenever you reset adaptions you will have that happen. clear the codes and it will go away.
Yea found that out after the panic. hahaha

Quote:
Originally Posted by SCS15 View Post
Damn pete, cant believe this is still going on ....hope you get it figured out without blowing a whole in your pockets...dont sell it though man, its come so far and you honestly wont find another car as fun
I know I really don't want to sell it and I had even more plans for the future but I can't keep paying thousands of dollars replacing parts. Along with this misfire issue my A/C is also not working... I've put that at the end of the priority list though because first I want to fix this
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: FBO + Meth JB4 ISO, BB flash, VRSF DP/FMIC, ER CP, Stett, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
psmitty95 is offline   United_States
0
Reply With Quote
      05-22-2013, 01:56 PM   #163
psmitty95
Brigadier General
 
psmitty95's Avatar
 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT

Posts: 3,445
iTrader: (7)

Codes today are Misfire cylinder 5 and P0420 which has something to do with o2's... Starting to think it's o2's again. Anyone have more info on the P0420 code, I couldn't find out much from googling...
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: FBO + Meth JB4 ISO, BB flash, VRSF DP/FMIC, ER CP, Stett, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
psmitty95 is offline   United_States
0
Reply With Quote
      05-22-2013, 02:08 PM   #164
Eleventeen
Second Lieutenant
 
Drives: 2007 335i
Join Date: May 2009
Location: South Jersey

Posts: 226
iTrader: (0)

Quote:
Originally Posted by psmitty95 View Post
Codes today are Misfire cylinder 5 and P0420 which has something to do with o2's... Starting to think it's o2's again. Anyone have more info on the P0420 code, I couldn't find out much from googling...
That's just a cat efficiency code, so I doubt that has anything to do with it. You just keep ignoring that fuel trim code though, don't you... Go ahead and change all of the coils, though.
__________________
[insert list of gas guzzling, warranty voiding, environment destroying, pocket emptying mods that still make you smile, here]
Eleventeen is offline   United_States
0
Reply With Quote
      05-22-2013, 04:11 PM   #165
psmitty95
Brigadier General
 
psmitty95's Avatar
 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT

Posts: 3,445
iTrader: (7)

Quote:
Originally Posted by Eleventeen View Post
That's just a cat efficiency code, so I doubt that has anything to do with it. You just keep ignoring that fuel trim code though, don't you... Go ahead and change all of the coils, though.
I haven't had that fuel trim code at all this week.... Last time it happened was last Saturday at Autocouture and since then i've had the car misfire well over 10 times and it hasn't popped up once. I have new rear o2's so it's not like i'm trying to avoid replacing them. Autocouture said they didn't think that was it so thought it would be a waste to have them replaced.
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: FBO + Meth JB4 ISO, BB flash, VRSF DP/FMIC, ER CP, Stett, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
psmitty95 is offline   United_States
0
Reply With Quote
      05-28-2013, 03:13 PM   #166
psmitty95
Brigadier General
 
psmitty95's Avatar
 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT

Posts: 3,445
iTrader: (7)

Posted these up on *********** and didn't get much of a response so figured i'd post them up here for you guys to check out. These were done on the G4 board since my ISO USB connection was broken. All were done in different gears and scenario's (uphill, flat, etc) to try and get it to throw a misfire code but I couldn't get it to do it.. Only two codes it threw were 2D18 manipulation cover, and 2C7F that cat code I keep getting. During one of the pulls the car lowered boost to only around 5 PSI which I think is the cause of the first pull. I'll put screenshots of the logs below then attach them to this post. As of now I think next time i'm at the shop i'll have them do both my rear o2's, and clean my Vanos. If that doesn't do it I think next up i'm going to try 3 brand new injectors in bank 2 since you no longer need to replace all 6.



















Oh also forgot to mention something is definitely wrong though... Plugged all these logs into Virtual dyno and this setup usually makes between 380-395 whp but these logs peaked at around 320 ish...
Attached Files
File Type: zip 52413logs.zip (18.5 KB, 10 views)
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: FBO + Meth JB4 ISO, BB flash, VRSF DP/FMIC, ER CP, Stett, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
psmitty95 is offline   United_States
0
Reply With Quote
      05-29-2013, 03:02 PM   #167
psmitty95
Brigadier General
 
psmitty95's Avatar
 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT

Posts: 3,445
iTrader: (7)

More logs... These are all map 2. I did 2 with ISO and 2 with G4 then plugged them in for virtual dyno and still getting way less than what I should be making. First two logs on ISO made 254 and 309 whp and the second two on G4 made 311 and 322 whp

Last year same setup on map 2 with G4 was making around 380... Odd part is the car doesn't really feel any slower although I might just be too used to how it is now

EDIT: I think I messed up naming the files so the ones named "g4 run 1/2" is really ISO run 1/2 and vice versa
Attached Files
File Type: zip 52913 logs.zip (8.8 KB, 9 views)
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: FBO + Meth JB4 ISO, BB flash, VRSF DP/FMIC, ER CP, Stett, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
psmitty95 is offline   United_States
0
Reply With Quote
      05-29-2013, 03:19 PM   #168
marv85
Colonel
 
marv85's Avatar
 
Drives: '07 335i MT
Join Date: Jun 2010
Location: Portland

Posts: 2,548
iTrader: (4)

so with these latest logs, no codes have been thrown?
__________________
'10 E92 335i , COBB
marv85 is offline   United_States
0
Reply With Quote
      05-29-2013, 05:07 PM   #169
psmitty95
Brigadier General
 
psmitty95's Avatar
 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT

Posts: 3,445
iTrader: (7)

Quote:
Originally Posted by marv85
so with these latest logs, no codes have been thrown?
Nope none when i checked. I've been running the car on full 93 only map 2 and I havent noticed it stumbling at all durigf acceleration either
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: FBO + Meth JB4 ISO, BB flash, VRSF DP/FMIC, ER CP, Stett, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
psmitty95 is offline   United_States
0
Reply With Quote
      05-29-2013, 05:14 PM   #170
marv85
Colonel
 
marv85's Avatar
 
Drives: '07 335i MT
Join Date: Jun 2010
Location: Portland

Posts: 2,548
iTrader: (4)

Quote:
Originally Posted by psmitty95 View Post
Nope none when i checked. I've been running the car on full 93 only map 2 and I havent noticed it stumbling at all durigf acceleration either
you've only gotten codes with E85 mixed in?
__________________
'10 E92 335i , COBB
marv85 is offline   United_States
0
Reply With Quote
      05-29-2013, 05:40 PM   #171
psmitty95
Brigadier General
 
psmitty95's Avatar
 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT

Posts: 3,445
iTrader: (7)

Quote:
Originally Posted by marv85
Quote:
Originally Posted by psmitty95 View Post
Nope none when i checked. I've been running the car on full 93 only map 2 and I havent noticed it stumbling at all durigf acceleration either
you've only gotten codes with E85 mixed in?
Havent mixed e85 in since about two weeks ago. Should i go grab some soon and see if the misfires/codes come back?
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: FBO + Meth JB4 ISO, BB flash, VRSF DP/FMIC, ER CP, Stett, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
psmitty95 is offline   United_States
0
Reply With Quote
      05-29-2013, 05:41 PM   #172
marv85
Colonel
 
marv85's Avatar
 
Drives: '07 335i MT
Join Date: Jun 2010
Location: Portland

Posts: 2,548
iTrader: (4)

Quote:
Originally Posted by psmitty95 View Post
Havent mixed e85 in since about two weeks ago. Should i go grab some soon and see if the misfires/codes come back?
I think so. I've probably said it a million times so I'm sorry for the repeat, but it smells like lean misfires... add E85 and test the theory
__________________
'10 E92 335i , COBB
marv85 is offline   United_States
0
Reply With Quote
      05-29-2013, 05:49 PM   #173
psmitty95
Brigadier General
 
psmitty95's Avatar
 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT

Posts: 3,445
iTrader: (7)

Quote:
Originally Posted by marv85
Quote:
Originally Posted by psmitty95 View Post
Havent mixed e85 in since about two weeks ago. Should i go grab some soon and see if the misfires/codes come back?
I think so. I've probably said it a million times so I'm sorry for the repeat, but it smells like lean misfires... add E85 and test the theory
Hmm that definitely might be a possibility but how can i fix that if that's the case? Stop using e85 or get a cobb to manage fueling? I always just assumed it was the higher boost being run by e85 causing the misfires
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: FBO + Meth JB4 ISO, BB flash, VRSF DP/FMIC, ER CP, Stett, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
psmitty95 is offline   United_States
0
Reply With Quote
      05-29-2013, 06:05 PM   #174
E90Company
Major General
 
E90Company's Avatar
 
Drives: 335i
Join Date: Mar 2012
Location: FL

Posts: 6,135
iTrader: (2)

Quote:
Originally Posted by psmitty95 View Post
Hmm that definitely might be a possibility but how can i fix that if that's the case? Stop using e85 or get a cobb to manage fueling? I always just assumed it was the higher boost being run by e85 causing the misfires
Get a new/better LPFP so it can keep up with demand.
__________________
E90 N54 6AT
E90Company is offline   No_Country
0
Reply With Quote
      05-29-2013, 06:14 PM   #175
psmitty95
Brigadier General
 
psmitty95's Avatar
 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT

Posts: 3,445
iTrader: (7)

Quote:
Originally Posted by E90Company
Quote:
Originally Posted by psmitty95 View Post
Hmm that definitely might be a possibility but how can i fix that if that's the case? Stop using e85 or get a cobb to manage fueling? I always just assumed it was the higher boost being run by e85 causing the misfires
Get a new/better LPFP so it can keep up with demand.
Well if it's just the lpfp not keeping up i could either do that or just run meth. I wasnt meaning it was running out of fuel, my original thoughts were that the misfires are still there now but the higher boost just makes them more apparent and throw codes. That might not be the case though since i havent felt any stumbling on map 2 in a while
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: FBO + Meth JB4 ISO, BB flash, VRSF DP/FMIC, ER CP, Stett, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
psmitty95 is offline   United_States
0
Reply With Quote
      05-29-2013, 07:29 PM   #176
E90Company
Major General
 
E90Company's Avatar
 
Drives: 335i
Join Date: Mar 2012
Location: FL

Posts: 6,135
iTrader: (2)

Quote:
Originally Posted by psmitty95 View Post
Well if it's just the lpfp not keeping up i could either do that or just run meth. I wasnt meaning it was running out of fuel, my original thoughts were that the misfires are still there now but the higher boost just makes them more apparent and throw codes. That might not be the case though since i havent felt any stumbling on map 2 in a while
Yeah, but in that one log you maxed fuel trims and ran way lean (on stock boost/timing).
__________________
E90 N54 6AT
E90Company is offline   No_Country
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:01 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST