E90Post
 


GT Haus
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Before I go tearing my new lpfp out, any other options? Car dying constantly.



Reply
 
Thread Tools Search this Thread
      05-01-2013, 06:43 PM   #1
Tronner
Second Lieutenant
3
Rep
206
Posts

 
Drives: 2008 335xi
Join Date: Sep 2010
Location: Centennial, CO

iTrader: (2)

Before I go tearing my new lpfp out, any other options? Car dying constantly.

I had a Walbro installed about 3 weeks ago at a reputable local shop. Ran about 1 tank of 91, then 1 1/2 tanks of e85 through it. A week ago I came home from a trip and the car had been sitting outside for 5 days and it was very cold. With the e85 not liking cold weather it took about 10 minutes and several cranks for it to start, but it finally did. However once it did start it stumbled and sputtered for a minute or two. Two days ago after running the e85 low I switched back over to the 91 octane map (done by Jake at PTF) and it stumbled and quit the first time I started it up. I chalked that up to the little bit of e85 still in there causing something funny.

Today, I was stuck in traffic for an accident and the car was idling for about 10 minutes until it died. Now it will start up, idle for about 15 seconds (I watch lpfp on the COBB go from 18psi or so drops to 9-10) and it dies. Sometimes it throws a cylinder injection shutdown code. Mostly just low fuel pump plausibility and low pressure.

Is there anything it could possibly be other than the lpfp? I'm probably going to have to have it towed back home or to the shop. It won't run long enough to get on the highway right now.

Thanks!
Appreciate 0
      05-01-2013, 08:34 PM   #2
Jeff@TopGearSolutions
BimmerPost Supporting Vendor
Jeff@TopGearSolutions's Avatar
United_States
246
Rep
18,414
Posts


 
Drives: C6 Z06, GSXR-750, 09 335i
Join Date: Dec 2008
Location: TopGearSolutions.com

iTrader: (32)

Send a message via AIM to Jeff@TopGearSolutions
One of our members here had a similar problem of the car just dying, I believe it turned out to be a kinked line from the LPFP or something about the return line disconnected. Eitherway it was a simple fix.

Last edited by Jeff@TopGearSolutions; 05-02-2013 at 10:18 AM.
Appreciate 0
      05-01-2013, 09:25 PM   #3
Dylan335i
Lieutenant
Dylan335i's Avatar
United_States
5
Rep
459
Posts

 
Drives: 2007 BMW 335i
Join Date: Sep 2011
Location: Orlando

iTrader: (4)

It should be holding a steady 72psi at idle so you def have an issue open it up
__________________
JB4 G5 / Walboro LPFP/ BMS Flash/ M3 Rep Front Bumper / OSS Headlights / BC Coilovers / 5" ETS FMIC / 3" VRSF Downpipes / AA Charge Pipe & BOV / BMS DCI / LCI Tails / CSL Trunk / CF Interior / CF Emblems / Cyba Air Scoops / 15% Tints / 5k Fogs / EBC RedStuff Pads / Drilled & Slotted Rotors / ECS SS Brake Lines
Appreciate 0
      05-01-2013, 09:38 PM   #4
caliguy562
Lieutenant
4
Rep
461
Posts

 
Drives: E92 335i
Join Date: Dec 2007
Location: garaged somewhere in soCal

iTrader: (3)

Sounds like a kink in the line
Appreciate 0
      05-01-2013, 09:41 PM   #5
BASELINE
Private First Class
2
Rep
142
Posts

 
Drives: A few...
Join Date: Jan 2011
Location: New Canaan, CT

iTrader: (3)

Or....

Fuel Pressure sensor... 100 dollar part.
Appreciate 0
      05-01-2013, 11:02 PM   #6
robc1976
DIYER
robc1976's Avatar
89
Rep
4,758
Posts

 
Drives: E90 335i
Join Date: Mar 2012
Location: Illinois

iTrader: (11)

Quote:
Originally Posted by Jeff@TopGearSolutions View Post
One of our members here had a similar problem of the are just dying, I believe it turned out to be a kinked line from the LPFP or something about the return line disconnected. Eitherway it was a simple fix.
I am one of those 4, it is either a kinked supply line or loose venturi line.I now use the smaller regulator line from my old regulator for the venturi. I ran 60% E85 in -15 degree weather all winter long...no issues.

http://www.e90post.com/forums/showthread.php?t=821304

http://www.e90post.com/forums/showthread.php?t=826645
__________________
JB4 G5, WEDGE flash, 455 LPFP, HFS-4 meth kit, BMS OCC, Motiv 750 ST, RB valve, BMS DCI, 3" AR Dps, Custom OC W/ SS lines, ER FMIC, ER CP W/HKS BOV, M3 control arms, M3 guide rods, M3 upper links, M3 front & rear sway-bars, HPA rear toe arms, Wavetrac LSD, HPF Gen 2 exhaust DEFIV kit, KW clubsport, Delrin solid subframe bushings, stoptech rotors, Rogue Tranny Mounts, 1M bumper, M3 CF hood, MORR VS8.2 rims 245/295
Appreciate 0
      05-02-2013, 05:58 AM   #7
enrita
Major General
enrita's Avatar
Sweden
94
Rep
7,331
Posts

 
Drives: 335i - Big turbos
Join Date: Sep 2008
Location: Italian in Sweden

iTrader: (0)

Does it happen on low fuel tank or always. You should monitor lpfp pressure
__________________
07 335i AT - TD St.2 Turbos - COBB (Custom Cobb mapping by http://www.protuningfreaks.com/) - JB4G5 ISO - Okada Coils - NGK 5992 Plugs - E85 Walbro - Injen Intake - Helix IC - Snow Stg. 3 - Stett CP - AR DPs - midpipes 100 HJS Cats - Bastuck Quad - PSS10 - QUAIFE LSD - BMS OCC - Forge DVs - AR OC - ALCON BBK - M3 Chassi - Dinan CP - Velocity M rear Toe arms - Advan RZ-DF - Level 10 AT upgrade - Alpina AT Flash
Appreciate 0
      05-02-2013, 08:09 AM   #8
BoostedE90
Lieutenant Colonel
BoostedE90's Avatar
United_States
27
Rep
1,673
Posts

 
Drives: e90 335i 6MT
Join Date: Nov 2007
Location: Tampa/Gainesville, FL

iTrader: (5)

What are the exact codes you are getting? These: 2AAF 29F2 AND 29F3?

If so it's what @BASELINE said.
Low pressure sensor: 13537614317
http://www.realoem.com/bmw/showphoto.do?id=13537614317
Appreciate 0
      05-02-2013, 08:49 AM   #9
enrita
Major General
enrita's Avatar
Sweden
94
Rep
7,331
Posts

 
Drives: 335i - Big turbos
Join Date: Sep 2008
Location: Italian in Sweden

iTrader: (0)

Could be the sensor to . Easy to check with inpa.
__________________
07 335i AT - TD St.2 Turbos - COBB (Custom Cobb mapping by http://www.protuningfreaks.com/) - JB4G5 ISO - Okada Coils - NGK 5992 Plugs - E85 Walbro - Injen Intake - Helix IC - Snow Stg. 3 - Stett CP - AR DPs - midpipes 100 HJS Cats - Bastuck Quad - PSS10 - QUAIFE LSD - BMS OCC - Forge DVs - AR OC - ALCON BBK - M3 Chassi - Dinan CP - Velocity M rear Toe arms - Advan RZ-DF - Level 10 AT upgrade - Alpina AT Flash
Appreciate 0
      05-02-2013, 09:13 AM   #10
Tronner
Second Lieutenant
3
Rep
206
Posts

 
Drives: 2008 335xi
Join Date: Sep 2010
Location: Centennial, CO

iTrader: (2)

Quote:
Originally Posted by BoostedE90 View Post
What are the exact codes you are getting? These: 2AAF 29F2 AND 29F3?

If so it's what @BASELINE said.
Low pressure sensor: 13537614317
http://www.realoem.com/bmw/showphoto.do?id=13537614317
2aaf - Fuel pump plausibility
2a2d - Fuel low pressure system
29dc - cylinder injection shutdown
29f2 - high pressure fuel system, fuel pressure
29e1 and e0 - mixture control

I was able to limp the car back to the shop. It was about 50 miles from where this started happening up in the mountains. At one point it died and I literally coasted downhill 4 MILES to Georgetown!! I've passed this info on to the shop and I'm sure they can fix it easily. I have to assume the pump isn't dead if it would work for a while sometimes, and fuel pressure was pretty constantly 9-10psi sometimes a bit higher. I assume that would also explain why it died after idling for so long. Hopefully it's just the line. Thanks for the responses!
Appreciate 0
      05-02-2013, 10:01 AM   #11
BoostedE90
Lieutenant Colonel
BoostedE90's Avatar
United_States
27
Rep
1,673
Posts

 
Drives: e90 335i 6MT
Join Date: Nov 2007
Location: Tampa/Gainesville, FL

iTrader: (5)

I would definitely have your shop replace the low pressure sensor. When mine went out my car behaved just like yours. I was driving from Tampa to Orlando and as soon as I got off the highway and stopped at a light the car stalled. Started it back up and stalled again after a few seconds of idling. To get the car to my friend's house I had to keep the RPMs above 1k/1.5k so it wouldn't stall. When it got dropped off at the dealership the tech told me that it wouldn't even start and they had to push it into the bay.

GL and keep us posted.
Appreciate 0
      05-02-2013, 10:20 AM   #12
Jeff@TopGearSolutions
BimmerPost Supporting Vendor
Jeff@TopGearSolutions's Avatar
United_States
246
Rep
18,414
Posts


 
Drives: C6 Z06, GSXR-750, 09 335i
Join Date: Dec 2008
Location: TopGearSolutions.com

iTrader: (32)

Send a message via AIM to Jeff@TopGearSolutions
Quote:
Originally Posted by BASELINE View Post
Or....

Fuel Pressure sensor... 100 dollar part.
This might be worth replacing anyway just for piece of mind if the car has some good mileage on it. (50,000 +).

Quote:
Originally Posted by robc1976 View Post
I am one of those 4, it is either a kinked supply line or loose venturi line.I now use the smaller regulator line from my old regulator for the venturi. I ran 60% E85 in -15 degree weather all winter long...no issues.

http://www.e90post.com/forums/showthread.php?t=821304

http://www.e90post.com/forums/showthread.php?t=826645
Appreciate 0
      05-02-2013, 01:46 PM   #13
Mike@N54Tuning.com
BimmerPost Supporting Vendor
Canada
480
Rep
15,051
Posts


 
Drives: 07335i
Join Date: Dec 2008
Location: Earth

iTrader: (88)

I would not trust a shop to do a Walbro in tank DIY. If you are going to use a shop the $100 inline DIY is probably a better bet as it's harder to mess up. It should work fine for cars up to 500rw.

Mike
__________________
LOWEST PRICE GURANTEE ON ALL PRODUCTS - www.n54tuning.com - Email; Mike@n54tuning.com
NEW PERFORMANCE LINE N54 DOWNPIPES & M3/M4 & F30 ER DOWNPIPES NOW IN STOCK - ER N54 CHARPE PIPE SPECIALS - NEW JB4 G5 ISO for N54 and F30 N55 ON SALE - NEW S55 M3/M4 JB4 NOW SHIPPING
Appreciate 0
      05-02-2013, 02:43 PM   #14
Tronner
Second Lieutenant
3
Rep
206
Posts

 
Drives: 2008 335xi
Join Date: Sep 2010
Location: Centennial, CO

iTrader: (2)

Quote:
Originally Posted by Mike@N54Tuning.com View Post
I would not trust a shop to do a Walbro in tank DIY. If you are going to use a shop the $100 inline DIY is probably a better bet as it's harder to mess up. It should work fine for cars up to 500rw.

Mike
I would go that route if I were to do it again, but this is a reputable shop in the area (and on this board), they've done them before, and they already did this one once so I'd rather not have them completely remove it and start over. I think they just need to fix this issue. I can order another low pressure sensor as well. How easy it that to replace if I do it myself?
Appreciate 0
      05-02-2013, 03:33 PM   #15
sammy_0559
Lieutenant Colonel
sammy_0559's Avatar
United_States
47
Rep
1,948
Posts

 
Drives: e93 2008 Montego Metallic 335i
Join Date: Apr 2011
Location: FortWorth, Texas

iTrader: (0)

Garage List
2008 E93 335i  [1.83]
or ripped line... I had the issue before. same exact codes. and a lot of backfireing.
Appreciate 0
      05-02-2013, 07:31 PM   #16
Tronner
Second Lieutenant
3
Rep
206
Posts

 
Drives: 2008 335xi
Join Date: Sep 2010
Location: Centennial, CO

iTrader: (2)

It was a torn hose. Going to pick it up now. Then some e50 tuning with Jake at PTF tomorrow!
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:15 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST