E90Post
 


Horizon LED
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N57 / M57 Turbo Diesel Discussions - 335d > P20ee ses



Reply
 
Thread Tools Search this Thread
      05-05-2013, 02:16 PM   #1
joe_planet
Captain
United_States
10
Rep
708
Posts

 
Drives: 2011 X5d
Join Date: Apr 2013
Location: DFW

iTrader: (1)

P20ee ses

Anyone got this code before?
It came on for about 400 miles and then turned off by itself.
Appreciate 0
      05-08-2013, 12:10 PM   #2
joe_planet
Captain
United_States
10
Rep
708
Posts

 
Drives: 2011 X5d
Join Date: Apr 2013
Location: DFW

iTrader: (1)

Made an appointment for friday, we'll see what those grease monkeys will say...
they going to give me a loaner and i'm interested to see how that car will compare
Appreciate 0
      05-13-2013, 02:11 PM   #3
joe_planet
Captain
United_States
10
Rep
708
Posts

 
Drives: 2011 X5d
Join Date: Apr 2013
Location: DFW

iTrader: (1)

so SA called said the urea injector clogged up and they cleaned it out.
The ses light already turned off on its own so i guess i'm good to go, yay!
Appreciate 0
      05-13-2013, 05:27 PM   #4
135i_vs_
Lieutenant
135i_vs_'s Avatar
United_States
9
Rep
533
Posts

 
Drives: M5(sold), 135i(sold), 335d
Join Date: Sep 2011
Location: NY

iTrader: (0)

Quote:
Originally Posted by joe_planet View Post
so SA called said the urea injector clogged up and they cleaned it out.
The ses light already turned off on its own so i guess i'm good to go, yay!
Guess this is sort of a common problem on these cars.
Appreciate 0
      05-14-2013, 06:35 AM   #5
Puerto Rican 335d
Colonel
Puerto Rican 335d's Avatar
Puerto Rico
37
Rep
2,875
Posts

 
Drives: Montego Blue 335d
Join Date: Jun 2011
Location: Puerto Rico

iTrader: (0)

joe I had the same issue wait for the forward and rear Ox sensor to go soon! mines went out inmediately after the clean up heres a pic of the cleaned up area of the urea in the exhaust
Attached Images
 
__________________
RENNtech Flash/WAGNER IC
VMR710 19"/Execuhitch Hitch/Koni FSD
Soft Ride Bike Rack
Amsoil Cetane Boost Diesel Fuel Additive
Amsoil Diesel Fuel Additive Concentrate
Appreciate 0
      05-14-2013, 06:37 AM   #6
joe_planet
Captain
United_States
10
Rep
708
Posts

 
Drives: 2011 X5d
Join Date: Apr 2013
Location: DFW

iTrader: (1)

Ya I think the reason was because car sat for a while before I purchased it.
I've also been driving it liberally and I think that helps keep the exhaust cleaner.
Appreciate 0
      05-14-2013, 06:40 AM   #7
joe_planet
Captain
United_States
10
Rep
708
Posts

 
Drives: 2011 X5d
Join Date: Apr 2013
Location: DFW

iTrader: (1)

Quote:
Originally Posted by Puerto Rican 335d View Post
joe I had the same issue wait for the forward and rear Ox sensor to go soon! mines went out inmediately after the clean up heres a pic of the cleaned up area of the urea in the exhaust
I guess we will wait and see. What a clogged urea injector has to do with ox or nox sensor I am not sure. Those seem like separate issues.
Appreciate 0
      05-14-2013, 06:44 AM   #8
Puerto Rican 335d
Colonel
Puerto Rican 335d's Avatar
Puerto Rico
37
Rep
2,875
Posts

 
Drives: Montego Blue 335d
Join Date: Jun 2011
Location: Puerto Rico

iTrader: (0)

I know but they are after the urea injector I believe and I think the urea thing must of done some harm I frankly cannot tell you if so , I would have to speak to the BMW Mechanic on this to confirm it
__________________
RENNtech Flash/WAGNER IC
VMR710 19"/Execuhitch Hitch/Koni FSD
Soft Ride Bike Rack
Amsoil Cetane Boost Diesel Fuel Additive
Amsoil Diesel Fuel Additive Concentrate
Appreciate 0
      06-01-2013, 01:54 PM   #9
joe_planet
Captain
United_States
10
Rep
708
Posts

 
Drives: 2011 X5d
Join Date: Apr 2013
Location: DFW

iTrader: (1)

Same ses code came on again, back to dealer it goes... Sigh
Appreciate 0
      06-20-2013, 04:50 PM   #10
joe_planet
Captain
United_States
10
Rep
708
Posts

 
Drives: 2011 X5d
Join Date: Apr 2013
Location: DFW

iTrader: (1)

OK so just a small update got the car back, they replaced the pre cat NOx sensor and no more check engine light.. also replaced some other thingy that broke... so far so good but i've only drove on it for a few days. If it breaks again i'll update.. lol
Appreciate 0
      06-21-2013, 07:24 AM   #11
Puerto Rican 335d
Colonel
Puerto Rican 335d's Avatar
Puerto Rico
37
Rep
2,875
Posts

 
Drives: Montego Blue 335d
Join Date: Jun 2011
Location: Puerto Rico

iTrader: (0)

damn joe same sheit I went thru both before and after NOX sensors went out!! WTF BMWoA cheap parts on our cars!! cant wait to remove all this crap after warranty expires
__________________
RENNtech Flash/WAGNER IC
VMR710 19"/Execuhitch Hitch/Koni FSD
Soft Ride Bike Rack
Amsoil Cetane Boost Diesel Fuel Additive
Amsoil Diesel Fuel Additive Concentrate
Appreciate 0
      06-21-2013, 08:50 AM   #12
F32Fleet
BMWCCA since '03
F32Fleet's Avatar
United_States
69
Rep
5,338
Posts

 
Drives: 2015 435i
Join Date: May 2005
Location: Atlanta (Vinings)

iTrader: (0)

IIRC the Urea pump is supposed to de-pressurize the line to the nozzle when the car is off to prevent build up. Very strange.
Appreciate 0
      06-21-2013, 08:57 AM   #13
Mark M
Captain
Mark M's Avatar
United_States
17
Rep
950
Posts

 
Drives: E30M3 E83X3 E90335D
Join Date: Aug 2007
Location: Lancaster, PA

iTrader: (0)

Had the same thing on mine. It had been sitting for some time at the selling dealership. Urea Injector had clogged and new NOx sensors were installed prior to me taking CPO delivery.
Appreciate 0
      06-21-2013, 10:38 AM   #14
joe_planet
Captain
United_States
10
Rep
708
Posts

 
Drives: 2011 X5d
Join Date: Apr 2013
Location: DFW

iTrader: (1)

Quote:
Originally Posted by Mark M View Post
Had the same thing on mine. It had been sitting for some time at the selling dealership. Urea Injector had clogged and new NOx sensors were installed prior to me taking CPO delivery.
Maybe this was the issue? I know the car had been sitting for quite some time and not being driven before I purchased it. It had right at 26k mi on the clock.
I've been driving it for 3 days now without any issues so far.. I'll keep my fingers crossed lol. I really liked the X5d loaner they gave me but I was getting baked with no tinted windows in the Texas heat. It also wasn't as fast obviously as my car, so it wasn't as fun to drive.
Appreciate 0
      06-21-2013, 10:43 AM   #15
Mark M
Captain
Mark M's Avatar
United_States
17
Rep
950
Posts

 
Drives: E30M3 E83X3 E90335D
Join Date: Aug 2007
Location: Lancaster, PA

iTrader: (0)

Yeah, the acceleration of the 335d is insane. Car gives me the giggles.

On my commute this morning, I was in right lane preparing to exit onto the interstate. Teenie bopper with cigarette hanging out dashed around me and cut right in front of me. End of the exit ramp she had her signal on to merge onto the interstate I got even. I pounced and merged on blocking her from merging then passed her like a Tomcat catapulting off a Carrier.

Thing is....I bet that makes me the D bag even though she cut me off first. Oh well, I'll perpetuate the BMW stereotype.
Appreciate 0
      06-21-2013, 05:21 PM   #16
joe_planet
Captain
United_States
10
Rep
708
Posts

 
Drives: 2011 X5d
Join Date: Apr 2013
Location: DFW

iTrader: (1)

lol nice... meh dont get mad get even!

I was on the interstate and this car gets right behind me. They're in a huge hurry.. and I know this because they're flashing their brights at me! lol They flashed about 20 times... I was getting aggravated. I will get over but I have to see the car first, so give me a chance, dont get behind me and start flashing lights at me with no time for me to react. So they quit flashing and try to pass me in the right lane... I just hit the accelerator and blew them away! lol It was priceless. This car is too much fun to drive.
I'm doing the rear fog light mod so I can give tailgaters something to look at.
Appreciate 0
      12-11-2014, 12:58 PM   #17
Got_Diesel
Private First Class
2
Rep
156
Posts

 
Drives: 335d
Join Date: Dec 2012
Location: United States

iTrader: (0)

Just got a P20ee code pop up from my scanner. Car will be going to the dealer in a few days!
__________________
Appreciate 0
      12-11-2014, 01:09 PM   #18
joe_planet
Captain
United_States
10
Rep
708
Posts

 
Drives: 2011 X5d
Join Date: Apr 2013
Location: DFW

iTrader: (1)

i think it was a nox sensor that went bad
Appreciate 0
      12-11-2014, 02:39 PM   #19
9mmkungfu
Private First Class
2
Rep
105
Posts

 
Drives: BMW 335d
Join Date: Sep 2014
Location: United States

iTrader: (0)

I had one pop up this week, too. Awesome!
Appreciate 0
      Yesterday, 08:47 AM   #20
135i_vs_
Lieutenant
135i_vs_'s Avatar
United_States
9
Rep
533
Posts

 
Drives: M5(sold), 135i(sold), 335d
Join Date: Sep 2011
Location: NY

iTrader: (0)

P20EE

This is the 2nd time I got it.
The 1st time it went away after 2 days of driving.

Also noticed BMWhat does not pick up the error code for this (there is no specific BMW code?). I had to do an OBDII scan to identify the code.
Attached Images
 
Appreciate 0
      Yesterday, 10:06 AM   #21
Austin335D
New Member
United_States
0
Rep
7
Posts

 
Drives: 2011 BMW 335D MSport
Join Date: Dec 2014
Location: Wilmington, NC

iTrader: (0)

Garage List
For those that had to have the sensor(s) replaced, what was the cost? Information like this helps to justify the cost of a full SCR/DEF rip out when warranty runs out.
Appreciate 0
      Yesterday, 08:03 PM   #22
135i_vs_
Lieutenant
135i_vs_'s Avatar
United_States
9
Rep
533
Posts

 
Drives: M5(sold), 135i(sold), 335d
Join Date: Sep 2011
Location: NY

iTrader: (0)

This is a BMW specific code I had for 2 months. Not sure if its related to the P20EE.
Going to the dealer tomorrow morning.
Attached Images
 
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:37 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST