E90Post
 


Horizon LED
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N55 Turbo Engine Tuning and Exhaust Modifications - 335i Tuning > Methanol pump issue?



Reply
 
Thread Tools Search this Thread
      05-26-2013, 02:32 PM   #1
Snaggletooth
General Nuisance
Snaggletooth's Avatar
United_States
4
Rep
277
Posts

 
Drives: 2007 E92 335i
Join Date: Oct 2012
Location: Orange County, CA

iTrader: (0)

Methanol pump issue?

Hey guys so I figure you all could help me with an issue I'm having with my Meth pump. I was doing a pull with a buddy when all of a sudden I smell a burning smell and hear my Meth pump whirring even after I get off the gas. I drive home carefully as soon as I notice it and wait for the misfire from the Meth but nothing happens. The flow stopped and no methanol was being injected (I think my failsafe kept the solenoid shut) buy the pump was still going like mad any time the power was switched on in the car. I disconnected the pump but any time I reconnect it, it instantly kicks on.

Anyone have a similar experience or input into what I should look into?
__________________
'07 E92 335i 6MT
Full Bolt On's, Vargas Stage 2's, Carbon Fiber, and Methanol.
Appreciate 0
      05-26-2013, 08:14 PM   #2
madmanhiker
Lieutenant Colonel
madmanhiker's Avatar
United_States
25
Rep
1,563
Posts

 
Drives: '11 E92 335i
Join Date: Jul 2008
Location: Jacksonville, Fl

iTrader: (3)

Garage List
never heard of that before... but a pump is very simple. something is "telling" it to turn "on".
__________________
-madmanhiker jax,fl
Appreciate 0
      06-19-2014, 05:27 PM   #3
blackbeast06
adrenergic stimulation
blackbeast06's Avatar
United_States
6
Rep
321
Posts

 
Drives: 2007 E92 335i
Join Date: Dec 2009
Location: Akron

iTrader: (4)

Garage List
2006 325i  [0.00]
Bumping an old thread because I just had the same issue. I just got my power cable recall done and when I popped the trunk there was a burning smell but the pump wasn't on. When I got home and popped the trunk again the meth pump was and the car was shut off. It stayed on for about a minute and then it finally shut off. I never noticed this before although my meth kit is only a couple weeks old. Any ideas on why the pump would be on with the car off?
__________________
07 335i. Montego Blue/Saddle Brown. 6 MT.

[IMG]
bm insta by senntera, on Flickr[/IMG]
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:47 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST