E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N55 Turbo Engine Tuning and Exhaust Modifications - 335i Tuning > Help! Engine Malfunction after JB4 Hex update!



Reply
 
Thread Tools Search this Thread
      06-08-2013, 08:58 PM   #1
J3FF3RSON
Private First Class
 
J3FF3RSON's Avatar
 
Drives: 2011 335I (E90)
Join Date: Jul 2011
Location: Louisville, KY

Posts: 168
iTrader: (3)

Help! Engine Malfunction after JB4 Hex update!

Never had this issue before, but I re-installed the JB4 after taking it to the dealer. I hooked it up to the laptop, did the firmware update and now when I start the car I get an engine malfunction and the steering wheel controls don't work. What could have gone wrong?!

I have a 2011 N55 - Thanks!!!
__________________
My Rides:
1.) 2014 Ram 1500 Sport
2.) 2011 BMW 335I (E90)

"If you're going through Hell... Keep Going."
J3FF3RSON is offline  
0
Reply With Quote
      06-08-2013, 09:07 PM   #2
johngrossi
Second Lieutenant
 
johngrossi's Avatar
 
Drives: 2011 135i e82
Join Date: May 2013
Location: Illinois

Posts: 234
iTrader: (1)

Contact Terry he should be able to walk you through troubleshooting steps.

There is also a troubleshooting guide on their website
johngrossi is offline  
0
Reply With Quote
      06-08-2013, 11:25 PM   #3
J3FF3RSON
Private First Class
 
J3FF3RSON's Avatar
 
Drives: 2011 335I (E90)
Join Date: Jul 2011
Location: Louisville, KY

Posts: 168
iTrader: (3)

It appears that I uploaded the G5 hex onto my N55 board on accident. I've taken the JB4 off the car, but still has the engine malfunction. Not sure what to do at this point.

I've emailed terry, but I believe I may hear from him tomorrow.

Will unhooking the battery for any length of time reflash the car?
__________________
My Rides:
1.) 2014 Ram 1500 Sport
2.) 2011 BMW 335I (E90)

"If you're going through Hell... Keep Going."
J3FF3RSON is offline  
0
Reply With Quote
      06-08-2013, 11:26 PM   #4
J3FF3RSON
Private First Class
 
J3FF3RSON's Avatar
 
Drives: 2011 335I (E90)
Join Date: Jul 2011
Location: Louisville, KY

Posts: 168
iTrader: (3)

Also, I can't get my laptop to connect to the board anymore to upload the new firmware. Not good lol.
__________________
My Rides:
1.) 2014 Ram 1500 Sport
2.) 2011 BMW 335I (E90)

"If you're going through Hell... Keep Going."
J3FF3RSON is offline  
0
Reply With Quote
      06-08-2013, 11:31 PM   #5
Lifted07Duramax
Major
 
Drives: 2008 BMW red 335i coupe
Join Date: Jan 2013
Location: springfield, mo

Posts: 1,359
iTrader: (1)

Subbed for the fix
Lifted07Duramax is offline  
0
Reply With Quote
      06-09-2013, 12:05 AM   #6
J3FF3RSON
Private First Class
 
J3FF3RSON's Avatar
 
Drives: 2011 335I (E90)
Join Date: Jul 2011
Location: Louisville, KY

Posts: 168
iTrader: (3)

More info:

Pulled codes after I uninstalled the JB4...

2C6F tends to be the code that keeps returning immediately after I clear them. Something to do with my boost pressure sensor?

Is it possible to mess up your DME with a JB4 install?
__________________
My Rides:
1.) 2014 Ram 1500 Sport
2.) 2011 BMW 335I (E90)

"If you're going through Hell... Keep Going."
J3FF3RSON is offline  
0
Reply With Quote
      06-09-2013, 08:52 PM   #7
SRT14PimPin07
Captain
 
SRT14PimPin07's Avatar
 
Drives: BMW 335i Coupe
Join Date: Jun 2009
Location: Los Angeles

Posts: 917
iTrader: (2)

I think one of your connections are incorrect. Check and make sure everything is plugged in right.
__________________
2011 Alpine White E92 335i M-Sport N55 Engine
SRT14PimPin07 is offline   Armenia
0
Reply With Quote
      06-10-2013, 01:58 PM   #8
Mike@N54Tuning.com
BimmerPost Supporting Vendor

 
Drives: 07335i
Join Date: Dec 2008
Location: Earth

Posts: 14,705
iTrader: (87)

Quote:
Originally Posted by J3FF3RSON View Post
More info:

Pulled codes after I uninstalled the JB4...

2C6F tends to be the code that keeps returning immediately after I clear them. Something to do with my boost pressure sensor?

Is it possible to mess up your DME with a JB4 install?
Sure. If you connect or disconnect the JB4 box from the harness with the battery connected you can easily short out a sensor or the DME itself. Always remove that battery cable before working with wiring! If that happens you'll want to remove all mods and dealer it.

Mike
__________________
LOWEST PRICE GURANTEE ON ALL PRODUCTS - www.n54tuning.com - Email; Mike@n54tuning.com
NEW PERFORMANCE LINE N54 DOWNPIPES & M3/M4 & F30 ER DOWNPIPES NOW IN STOCK - ER N54 CHARPE PIPE SPECIALS - NEW JB4 G5 ISO for N54 and F30 N55 ON SALE
Mike@N54Tuning.com is offline   Canada
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:17 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST