E90Post
 


VIBE Motorsports
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > abs hydro unit failure, is it terminal or intermittent?



Reply
 
Thread Tools Search this Thread
      06-30-2013, 04:38 PM   #1
mikeouk
Lieutenant
 
mikeouk's Avatar
 
Drives: 2010 E92 325D m sport
Join Date: Oct 2010
Location: cumbria

Posts: 417
iTrader: (0)

abs hydro unit failure, is it terminal or intermittent?

further to my post the other day

had the unit checked by 2 garages, both say its the abs dsc hydro unit. Warning lights have been on for a few weeks now, until tonight, warning lights on dash have gone out, warning message on nav screen gone, and cruise is now working again

so, my question is, when the unit fails, is that normally it? is it dead, or can it be intermittent. is it possible that ive just got a bad connection or something?
__________________
2010 E92 325D M SPORT

BLUE WATER, CORAL RED LEATHER
mikeouk is offline   United Kingdom
0
Reply With Quote
      07-01-2013, 12:40 AM   #2
lemonukas
Second Lieutenant
 
Drives: 325i e91
Join Date: Jun 2012
Location: hemel hempstead

Posts: 281
iTrader: (0)

Maybe it was not ABS unit. Just wheel sensor. Like I had for more than 6 month and fault disappeared like it come. Without fix.
Garages you used was probably lazy plug in computer to have a look and said its abs unit.
lemonukas is offline  
0
Reply With Quote
      07-01-2013, 05:50 AM   #3
mikeouk
Lieutenant
 
mikeouk's Avatar
 
Drives: 2010 E92 325D m sport
Join Date: Oct 2010
Location: cumbria

Posts: 417
iTrader: (0)

Quote:
Originally Posted by lemonukas View Post
Maybe it was not ABS unit. Just wheel sensor. Like I had for more than 6 month and fault disappeared like it come. Without fix.
Garages you used was probably lazy plug in computer to have a look and said its abs unit.
interesting, so you had same thing happen on same engined car as mine?

I was told that its pretty rare for the pump to go on the 6cyl cars, but its a major issue on 4cyl cars, hense why there is no bmw repair kit for the 6cyl.
How long ago did you have the same problem and has it never reappeared?
__________________
2010 E92 325D M SPORT

BLUE WATER, CORAL RED LEATHER
mikeouk is offline   United Kingdom
0
Reply With Quote
      07-01-2013, 09:48 AM   #4
tmarshall57
Lieutenant
 
Drives: E90 330d
Join Date: Apr 2008
Location: Bury, Lancs, UK

Posts: 454
iTrader: (0)

Garage List
Mine was showing intermittent errors before it became permanent. Gave me some false hope but it was the hydro unit at fault.
tmarshall57 is online now   United Kingdom
0
Reply With Quote
      07-02-2013, 03:57 AM   #5
lemonukas
Second Lieutenant
 
Drives: 325i e91
Join Date: Jun 2012
Location: hemel hempstead

Posts: 281
iTrader: (0)

Quote:
Originally Posted by mikeouk
Quote:
Originally Posted by lemonukas View Post
Maybe it was not ABS unit. Just wheel sensor. Like I had for more than 6 month and fault disappeared like it come. Without fix.
Garages you used was probably lazy plug in computer to have a look and said its abs unit.
interesting, so you had same thing happen on same engined car as mine?

I was told that its pretty rare for the pump to go on the 6cyl cars, but its a major issue on 4cyl cars, hense why there is no bmw repair kit for the 6cyl.
How long ago did you have the same problem and has it never reappeared?
I had problem last year from spring till about November. And never had same problem after that.
Buy yourself bmw cable.
Did you recently change your tyres or wheels?
lemonukas is offline  
0
Reply With Quote
      07-02-2013, 03:18 PM   #6
old grey steve
335i E Maps Re Map, VRSF Catless DownPipes & More.
 
old grey steve's Avatar
 
Drives: 335i SE
Join Date: Oct 2012
Location: UK in Hertfordshire

Posts: 991
iTrader: (2)

We re starting you see a good number if these 6 cylinder cars coming our way with Hydro unit failure normally when it hooked up to our AutoLogic diagnostic machine codes wise it's something like 5E20 or something like that but the magic phrase we are continually seeing is "internal" which points to the unit itself, I've spoken to customers who've said that they'd lost the light only to have it reappear later on. But usually when we get to see them it's pretty conclusive.

On the subject of rarity on 6 cylinder cars having the problem compared with 4 cylinder cars I'd of agreed 2 months ago but of late I've seen 5 come our way with the same issue so although the numbers are lower than the many 4 cylinder cars we've seen I'm seeing a pattern with more coming our way on July I've got another 3 that are due in over the next 2 weeks all reporting the same lights on the dash!

Re pricing on the 4 cylinder cars whether petrol or diesel the repair kit option is available at around 168+VAT(we done a 320i today) but on the 6 cylinder vehicles the financial difference is vast. For the Hydro unit itself its an eye watering 1580.85+VAT(though there is a repair unit for around 895+VAT but usually so I'm told for pressure sensor failure on these you have to buy the complete unit-which I don't quite understand) however there's reasonably good news as there is another option.

If its 100% faulty and its confirmed send it away to ECU Testing in Derbyshire http://www.ecutesting.com/ there quick efficient and on the ball(I've used them a couple of times)you'll get the unit returned to you refurbished it'll just need installing and correctly bleeding and coded to the car(must be done correctly as ECU Testing will point out otherwise you'll have issues) car will be off the road for a few days but in the pocket if its failed you'll be over 1000 better off by sending it away to ECU Testing.

Hope this in someway helps
old grey steve is offline   United Kingdom
0
Reply With Quote
      07-02-2013, 11:39 PM   #7
lemonukas
Second Lieutenant
 
Drives: 325i e91
Join Date: Jun 2012
Location: hemel hempstead

Posts: 281
iTrader: (0)

+1 ecutesting.
lemonukas is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:45 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST