E90Post
 


E92-lighting
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > AC not blowing any air?



Reply
 
Thread Tools Search this Thread
      06-13-2013, 07:56 PM   #1
BMW..
Lieutenant
 
Drives: E46 M3 /E90
Join Date: May 2013
Location: Boca Raton FL

Posts: 570
iTrader: (0)

AC not blowing any air?

Hey guys. Just making a long story short:

AC does not blow any air whether cold or hot regardless of fan setting

I have replaced fuse 67 (blower fuse) and it has not changed the behavior

I now have 2 repair options: replace blower itself or replace the resistor.

I am pretty sure the blower is working because I can hear activity from where the blower is when i mess with the fan settings.

I read somewhere that spraying WD40 on the blower and prodding it with a screwdriver cam "unjam" the blower and get it working again.

I dont want to spend money on a blower and it wont solve the problem. What do you guys think? Thanks
BMW.. is offline  
0
Reply With Quote
      06-14-2013, 06:45 AM   #2
Efthreeoh
Brigadier General
 
Drives: E90
Join Date: May 2012
Location: MARLAND

Posts: 3,309
iTrader: (0)

I'd pull off the cabin airfilter housing and then start the engine and activate the manual HVAC controls to run the blower. You can clearly see the blower fan from the vent hole that are covered by the cabin airfilter housing (on the passenger side). You can prod the blow fan and try the WD40. I've not seen anywhere where someone has needed to replace a blown resistor pack.

The blower unit is about $160, the resistor is about $95. It'd cost you about the same just to have the dealer evaluate the problem for you.
Efthreeoh is offline   United_States
0
Reply With Quote
      06-14-2013, 10:50 AM   #3
index1489
Colonel
 
index1489's Avatar
 
Drives: Out of warranty BMW
Join Date: Sep 2008
Location: Chino, CA

Posts: 2,022
iTrader: (7)

You can get the blower for ~$150 here
http://bmwpartspros.com/parts/index....&siteid=216857

Do what is suggested above, its most likely the blower.
__________________
Gotta pay to play.
index1489 is offline   United_States
0
Reply With Quote
      06-14-2013, 11:08 AM   #4
BMW..
Lieutenant
 
Drives: E46 M3 /E90
Join Date: May 2013
Location: Boca Raton FL

Posts: 570
iTrader: (0)

Quote:
Originally Posted by Efthreeoh View Post
I'd pull off the cabin airfilter housing and then start the engine and activate the manual HVAC controls to run the blower. You can clearly see the blower fan from the vent hole that are covered by the cabin airfilter housing (on the passenger side). You can prod the blow fan and try the WD40. I've not seen anywhere where someone has needed to replace a blown resistor pack.

The blower unit is about $160, the resistor is about $95. It'd cost you about the same just to have the dealer evaluate the problem for you.
I did this last night and it worked ! I saw it on a old thread and never really bothered to update it but that indeed works! Thanks for the help!
BMW.. is offline  
0
Reply With Quote
      06-15-2013, 05:20 PM   #5
dmtyper
Registered
 
Drives: BMW E90 330i N52 3.0
Join Date: Jun 2013
Location: Puerto Rico

Posts: 2
iTrader: (0)

I have kind of similar problem, My ac turns on and blows air out but sometimes it is not cool air.

If I cold start the car and turn the ac on it will be cold air, If I turn the car of or the ac it will not deliver cold air.

I did some experiments and If the radiator fan goes on I the air will be cold... Sometimes it just dosent start I have no clue on what it could be if anyone knows.. Help appreciated.
dmtyper is offline  
0
Reply With Quote
      06-30-2013, 05:53 PM   #6
Hisho335i
New Member
 
Hisho335i's Avatar
 
Drives: 335i Premium/Sport/Dinan Soft
Join Date: Jul 2011
Location: LA, Sherman Oaks

Posts: 11
iTrader: (0)

Climate control Blower doesn't work

I do have similar problem and i took out the glove box to figure out which one gone bad (FSU or Motor) to find out there is no volt coming to the blower/fsu unit, measured give me zero when blower is on, so if its nto the FSU or teh motor ! any suggestions? also i checked every fuse in that car with a volt meter.
Hisho335i is offline   United_States
0
Reply With Quote
      07-01-2013, 06:53 PM   #7
Hisho335i
New Member
 
Hisho335i's Avatar
 
Drives: 335i Premium/Sport/Dinan Soft
Join Date: Jul 2011
Location: LA, Sherman Oaks

Posts: 11
iTrader: (0)

I have a 335i 2007 E90 and the inside blower is not working, with a multimeter there is no voltage coming to the motor or resistor (tried all setting high) checked all fuses. still no voltage coming on the Motor/resistor . Climate control panel all green lights and it functions normal . That happened after changing water pump/thermostat.
any ideas
Hisho335i is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:36 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST