E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Australia > Anyone had their water pump die?



Reply
 
Thread Tools Search this Thread
      06-19-2013, 10:25 AM   #1
R3N
Second Lieutenant
Australia
2
Rep
207
Posts

Drives: None
Join Date: Aug 2012
Location: Perth, Australia

iTrader: (0)

Anyone had their water pump die?

Think mine just did tonight. Car is an 08 335i. Would have been 5 minutes into my trip and on the freeway doing 100, noticed car wasn't accelerating and got an engine overheat error message on the iDrive. Pulled over and shut off the engine. Left it for about 10-15 minutes and restarted. Cooland temp climbed from 100'C to 120'C pretty quick whiskt idling so shut it off again and got a tow truck.

I assume that the water pump has shat itself. Also, ambient air temp was about 12'C tonight.
Appreciate 0
      06-19-2013, 06:22 PM   #2
drjekl
Captain
16
Rep
788
Posts

Drives: E92 335i
Join Date: Jan 2013
Location: Oz

iTrader: (0)

Yeah it's a ccommon issue, do a search on here is a thread on it where cars are only a few years old and suffer from a failed pump (seems as common as the fuel pumps )
Appreciate 0
      06-19-2013, 08:47 PM   #3
Zen
Captain
Australia
8
Rep
631
Posts

Drives: E92 335i
Join Date: Nov 2008
Location: Sydney Aus

iTrader: (0)

If you could hear the fan running overdrive while outside and inside your car then your waterpump had died.
__________________
08' E92 335I
Black Sapphire Metallic | M-Sport | GT-CS 19" Matte Anthracite | BMW Perf. Exhaust | JB4 | AR Design Catless DP | R1 Concepts Cross-drilled & Slotted Rotors | aFe DCI | ER Chargepipe with Forge DV | ER FMIC
Appreciate 0
      06-19-2013, 11:11 PM   #4
Stuart@BMRAutowerkes
BimmerPost Supporting Vendor
Stuart@BMRAutowerkes's Avatar
144
Rep
5,023
Posts


Drives: a black car
Join Date: Sep 2010
Location: Sydney

iTrader: (3)

I've sold a few waterpumps, pretty common maintenance item
Appreciate 0
      06-19-2013, 11:47 PM   #5
driving_impaired
Private First Class
driving_impaired's Avatar
United_States
1
Rep
156
Posts

Drives: '08 335 Jet Black
Join Date: Jan 2013
Location: Atlanta, GA

iTrader: (1)

Garage List
2008 BMW 335i  [0.00]
Same car with same symptoms, and it was the water pump. Read on here it was a good idea to replace thermostat with pump so had the dealership do both. Extended warranty covered pump but tstat was out of pocket. And yes, the fan was extremely loud, you can't mistake that.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:04 AM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST