E90Post
 


PYSPEED
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > All-Wheel-Drive (Xi / xDrive) Talk > knocking noise Please Help



Reply
 
Thread Tools Search this Thread
      07-08-2013, 06:34 PM   #23
akotten
Major
 
akotten's Avatar
 
Drives: 2007 335xi
Join Date: Mar 2011
Location: Rapid City, SD

Posts: 1,032
iTrader: (2)

Quote:
Originally Posted by phozenstone View Post
I have the same issue with a creaking in the firewall due to the large center strut bar bolt. Unfortunately I cannot find the right torx size to retorque it
I just bought a cheap female torx socket set from Amazon, which had the sizes I needed.
__________________
TC Kline S/A | Vorshlag Camber Plates | ///M Bushings & ARB | CP-e DPs | VRSF FMIC | Procede 2.5 w/ OpenFlash | DCI |
akotten is offline  
0
Reply With Quote
      07-08-2013, 09:17 PM   #24
Tim603
Captain
 
Tim603's Avatar
 
Drives: 2007 328xi coupe
Join Date: Feb 2012
Location: Manchester Nh

Posts: 922
iTrader: (2)

Quote:
Originally Posted by ajsalida View Post
I saw this video the other day, someone posted it up for diagnosing front end issues, maybe will help
Thanks man for trying to help find a solution on this
__________________
Tim603 is online now   United_States
0
Reply With Quote
      07-09-2013, 05:03 PM   #25
AWD Addict
Chief Executive
 
AWD Addict's Avatar
 
Drives: 2008 335xi 6spd Coupe
Join Date: Dec 2007
Location: Boston

Posts: 2,471
iTrader: (1)

Garage List
2008 335xi  [0.00]
Quote:
Originally Posted by ajsalida View Post
I saw this video the other day, someone posted it up for diagnosing front end issues, maybe will help

That sounds more like our issue
AWD Addict is offline  
0
Reply With Quote
      07-09-2013, 05:07 PM   #26
ajsalida
Lieutenant Colonel
 
ajsalida's Avatar
 
Drives: 95 M3, 02 R1150GSA, 09 335xi
Join Date: Aug 2010
Location: SW USA

Posts: 1,578
iTrader: (2)

Yeah that's what I was thinking, pretty hard to diagnose while inside the car driving. If it isn't you guys' issue then at least something to remember for future.
ajsalida is online now  
0
Reply With Quote
      07-26-2013, 02:32 PM   #27
index1489
Lieutenant Colonel
 
index1489's Avatar
 
Drives: Out of warranty BMW
Join Date: Sep 2008
Location: Chino, CA

Posts: 1,997
iTrader: (7)

BMW says not to drive around with the strut brace removed or body damage can occur sounds ridiculous to me, but I imagine the torque on those nuts is important.

I replaced all of mine and torqued them properly based on my Bentley manual.
__________________
Gotta pay to play.
index1489 is offline   United_States
0
Reply With Quote
      07-27-2013, 10:07 AM   #28
Tim603
Captain
 
Tim603's Avatar
 
Drives: 2007 328xi coupe
Join Date: Feb 2012
Location: Manchester Nh

Posts: 922
iTrader: (2)

I have an apt with BMW on monday so I will keep you guys posted on what it is!
__________________
Tim603 is online now   United_States
0
Reply With Quote
      07-28-2013, 01:48 PM   #29
0_creativity
Registered
 
Drives: 2006 325xi
Join Date: May 2013
Location: NoVa

Posts: 4
iTrader: (0)

Garage List
2006 BMW 325xi  [0.00]
I ran into a similar issue this morning after I hit an area of heavy road work. A knocking/clicking noise when I turn right or apply the breaks at about 40mph. I have a 2006 325xi. I dropped by my dad's job for a quick check up (it's a ford dealership) They said I might need to order a Half Shaft for the right front side. (Where the noise is coming from) Making an appointment in the am to have an actual diagnostic.
__________________
0_creativity is offline   United_States
0
Reply With Quote
      07-28-2013, 07:05 PM   #30
E94
Private
 
E94's Avatar
 
Drives: E92 335i
Join Date: Jan 2013
Location: Michigan

Posts: 50
iTrader: (0)

Had the same issue and I was 99% certain it was either the tophat or endlink (most common areas to create the "clunking" noise), but it turns out it was an exhaust clamp that came loose. Dealer charged me $65 for a half hour diagnostics fee
E94 is offline   United_States
0
Reply With Quote
      07-29-2013, 10:22 AM   #31
Tim603
Captain
 
Tim603's Avatar
 
Drives: 2007 328xi coupe
Join Date: Feb 2012
Location: Manchester Nh

Posts: 922
iTrader: (2)

SO.... i just heard back from the dealer and turns out this is probably an isolated incident. After getting the clutch replaced it turns out a couple subframe bolts were not tightened completely and THAT was making the sound. So nothing major even though I do have to pay BMW for a Diag fee

Problem Solved!
__________________
Tim603 is online now   United_States
0
Reply With Quote
      09-20-2013, 11:05 AM   #32
AWD Addict
Chief Executive
 
AWD Addict's Avatar
 
Drives: 2008 335xi 6spd Coupe
Join Date: Dec 2007
Location: Boston

Posts: 2,471
iTrader: (1)

Garage List
2008 335xi  [0.00]
My issue was thrust arm bushings.
AWD Addict is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:13 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST