E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > O2 sensor question



Reply
 
Thread Tools Search this Thread
      06-29-2013, 08:58 AM   #1
GAM
Lieutenant
GAM's Avatar
9
Rep
464
Posts

Drives: 2011 E92 M3
Join Date: Mar 2012
Location: Palm Beach

iTrader: (1)

O2 sensor question

Hello everyone,

I have been having the 2c9c code coming up on every start this week and my car is running really lean.
2C9C: Lambda Sensor Heater Pre Cat 1
Does that mean the faulty one is the front O2 sensor on the left downpipe (driver side)?

Thanks for your help
Appreciate 0
      07-03-2013, 01:33 PM   #2
GAM
Lieutenant
GAM's Avatar
9
Rep
464
Posts

Drives: 2011 E92 M3
Join Date: Mar 2012
Location: Palm Beach

iTrader: (1)

The answer is Yes, just changed it last weekend.
Front O2 sensor near the turbo and on the driver side
Appreciate 0
      07-03-2013, 01:39 PM   #3
cleex024
Major
31
Rep
1,465
Posts

Drives: 2008 BMW 335i Coupe
Join Date: Mar 2011
Location: Woodbridge

iTrader: (2)

damn im getting the bank 2 o2 sensor going bad...was hoping it was just going to go away but its definitely not going away lol.

is changing o2 sensor going to be a bitch?
__________________
Space Gray l 6MT l OSG LSD w/ VAC Race Diff Cover l Cobb e30 l Morr vs8.2 l UUC SSK w/ DSSR l VSRF Catless Dps l RPI Intercooler l CDV Removed l HID AE 8000k l ETS Catback l AST 5200 w/ Vorshlag Camber Plates l ER Dual Oil Coolers l Rear Camber and Toe Arms l K&N Drop In l Solid Tranny/Diff/Subframe Bushings l Bridgestone RE-11
Appreciate 0
      07-03-2013, 05:34 PM   #4
dirtmaster666
"J" BONE
dirtmaster666's Avatar
Canada
7
Rep
578
Posts

Drives: 2007 335i
Join Date: Jan 2010
Location: edmonton

iTrader: (0)

Send a message via MSN to dirtmaster666
Quote:
Originally Posted by cleex024
damn im getting the bank 2 o2 sensor going bad...was hoping it was just going to go away but its definitely not going away lol.

is changing o2 sensor going to be a bitch?
Yes. Unless you have skinny arms or move your steering rack
__________________
procede v5 rev3, afe dual cone intake, full catless exhaust with muffler delete, hm style carbon fibre lip, 235/35/19,275/30/19 satin black linea corse818, H&R sport springs, Vishnu charge pipe with forged diverter valves, matte black kidneys, mtec superwhite angel eyes and fogs, bms cdv ER fmic, VRSF coated DP. Vishnu pwm meth kit
Appreciate 0
      07-17-2013, 09:17 PM   #5
hankcah
Second Lieutenant
8
Rep
285
Posts

Drives: BMW 335i E90
Join Date: Jun 2010
Location: Saint Louis

iTrader: (0)

Garage List
2007 335i  [0.00]
How much would replacing the 2C2E and 2C3E cost? parts and labor?
Appreciate 0
      07-21-2013, 05:40 AM   #6
DR-JEKL
Colonel
62
Rep
2,466
Posts

Drives: Space Grey 335i 6MT
Join Date: Jul 2012
Location: Newcastle Ozstraylia

iTrader: (1)

Quote:
Originally Posted by hankcah View Post
How much would replacing the 2C2E and 2C3E cost? parts and labor?
o2 sensors take around 2 hrs labour to replace, and can be had for around $100 each.

So around $400 based on my experience.
Appreciate 0
      07-21-2013, 11:53 AM   #7
psmitty95
Brigadier General
psmitty95's Avatar
United_States
152
Rep
3,938
Posts

Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

iTrader: (9)

Quote:
Originally Posted by cleex024 View Post
damn im getting the bank 2 o2 sensor going bad...was hoping it was just going to go away but its definitely not going away lol.

is changing o2 sensor going to be a bitch?
Are you noticing any other symptoms? I've been getting SES lights with boost not going over 10 PSI for a while along with some misfires. Terry is convinced it's o2 sensors since I also am running lean despite timing being perfect. Thing that sucks is I just replaced the rears a few weeks ago and now i'm getting a rear code again...
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: MHD w/ Wedge Flash, VRSF DP/FMIC, ER CP, Roc-Euro DCI, SteveAZ LPFP & more
More Pictures: Build Thread /// 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
Appreciate 0
      07-21-2013, 09:51 PM   #8
cleex024
Major
31
Rep
1,465
Posts

Drives: 2008 BMW 335i Coupe
Join Date: Mar 2011
Location: Woodbridge

iTrader: (2)

Quote:
Originally Posted by psmitty95 View Post
Are you noticing any other symptoms? I've been getting SES lights with boost not going over 10 PSI for a while along with some misfires. Terry is convinced it's o2 sensors since I also am running lean despite timing being perfect. Thing that sucks is I just replaced the rears a few weeks ago and now i'm getting a rear code again...
Actually everything seems to be running pretty well except for slight hiccupsat idle...I'm still going to change it the o2 sensors eventually but I wanna know if I should go ahead and replace both and how hard it's going to be
__________________
Space Gray l 6MT l OSG LSD w/ VAC Race Diff Cover l Cobb e30 l Morr vs8.2 l UUC SSK w/ DSSR l VSRF Catless Dps l RPI Intercooler l CDV Removed l HID AE 8000k l ETS Catback l AST 5200 w/ Vorshlag Camber Plates l ER Dual Oil Coolers l Rear Camber and Toe Arms l K&N Drop In l Solid Tranny/Diff/Subframe Bushings l Bridgestone RE-11
Appreciate 0
      07-21-2013, 10:01 PM   #9
psmitty95
Brigadier General
psmitty95's Avatar
United_States
152
Rep
3,938
Posts

Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

iTrader: (9)

Quote:
Originally Posted by cleex024 View Post
Actually everything seems to be running pretty well except for slight hiccupsat idle...I'm still going to change it the o2 sensors eventually but I wanna know if I should go ahead and replace both and how hard it's going to be
Have you done any logs? Mine seemed to be running fine and even looked fine in logs but when I plug the logs into VD it makes much less power than it used too and its not pulling nearly as strong
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: MHD w/ Wedge Flash, VRSF DP/FMIC, ER CP, Roc-Euro DCI, SteveAZ LPFP & more
More Pictures: Build Thread /// 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
Appreciate 0
      07-22-2013, 03:06 PM   #10
sickem
Freude am fahren
sickem's Avatar
25
Rep
1,953
Posts

Drives: in the fast lane
Join Date: Mar 2010
Location: People's Republic of New Jersey

iTrader: (4)

Garage List
Quote:
Originally Posted by psmitty95 View Post
Are you noticing any other symptoms? I've been getting SES lights with boost not going over 10 PSI for a while along with some misfires. Terry is convinced it's o2 sensors since I also am running lean despite timing being perfect. Thing that sucks is I just replaced the rears a few weeks ago and now i'm getting a rear code again...
you replaced the rear oxygen sensors, you mean secondaries? My understanding was that those didn't have anything to do with AFRs and only measure catalytic efficiency...not sure if I'm mistaken?
__________________
Cobb E40 PROtune by Jake@PTF/RR catless DPs/aFe DCI/ETS 5" FMIC/ER CP/Forge DVs/Alpina B3 TCU flash/BMW Perf. Exhaust./BMW Performance Style 313s/M-Tech Rear
Appreciate 0
      07-22-2013, 03:15 PM   #11
psmitty95
Brigadier General
psmitty95's Avatar
United_States
152
Rep
3,938
Posts

Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

iTrader: (9)

Quote:
Originally Posted by sickem View Post
you replaced the rear oxygen sensors, you mean secondaries? My understanding was that those didn't have anything to do with AFRs and only measure catalytic efficiency...not sure if I'm mistaken?
Yea that was my understanding also but those are the ones i'm getting a code for and what terry told me to do. Still getting codes and running lean despite timing being perfect. I think i'm going to do all 4 o2's next and see what happens per Terry's recommendation
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: MHD w/ Wedge Flash, VRSF DP/FMIC, ER CP, Roc-Euro DCI, SteveAZ LPFP & more
More Pictures: Build Thread /// 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
Appreciate 0
      07-22-2013, 03:22 PM   #12
sickem
Freude am fahren
sickem's Avatar
25
Rep
1,953
Posts

Drives: in the fast lane
Join Date: Mar 2010
Location: People's Republic of New Jersey

iTrader: (4)

Garage List
Quote:
Originally Posted by psmitty95 View Post
Yea that was my understanding also but those are the ones i'm getting a code for and what terry told me to do. Still getting codes and running lean despite timing being perfect. I think i'm going to do all 4 o2's next and see what happens per Terry's recommendation
hmm, sounds more like a fueling issue...lpfp/hpfp or injectors?
__________________
Cobb E40 PROtune by Jake@PTF/RR catless DPs/aFe DCI/ETS 5" FMIC/ER CP/Forge DVs/Alpina B3 TCU flash/BMW Perf. Exhaust./BMW Performance Style 313s/M-Tech Rear
Appreciate 0
      07-22-2013, 03:24 PM   #13
psmitty95
Brigadier General
psmitty95's Avatar
United_States
152
Rep
3,938
Posts

Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

iTrader: (9)

Quote:
Originally Posted by sickem View Post
hmm, sounds more like a fueling issue...lpfp/hpfp or injectors?
That's what I thought but everything looks fine in logs. Logs look perfect except for running lean and the car not putting out as much power on VD or during pulls with friends. The rear cat #2 code is the one that keeps popping up whenever I get the SES light so he thinks its that.
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: MHD w/ Wedge Flash, VRSF DP/FMIC, ER CP, Roc-Euro DCI, SteveAZ LPFP & more
More Pictures: Build Thread /// 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
Appreciate 0
      07-22-2013, 03:25 PM   #14
sickem
Freude am fahren
sickem's Avatar
25
Rep
1,953
Posts

Drives: in the fast lane
Join Date: Mar 2010
Location: People's Republic of New Jersey

iTrader: (4)

Garage List
Quote:
Originally Posted by psmitty95 View Post
That's what I thought but everything looks fine in logs. Logs look perfect except for running lean and the car not putting out as much power on VD or during pulls with friends. The rear cat #2 code is the one that keeps popping up whenever I get the SES light so he thinks its that.
ok, well GL keep us updated...that's weird.
__________________
Cobb E40 PROtune by Jake@PTF/RR catless DPs/aFe DCI/ETS 5" FMIC/ER CP/Forge DVs/Alpina B3 TCU flash/BMW Perf. Exhaust./BMW Performance Style 313s/M-Tech Rear
Appreciate 0
      07-22-2013, 03:26 PM   #15
psmitty95
Brigadier General
psmitty95's Avatar
United_States
152
Rep
3,938
Posts

Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

iTrader: (9)

Quote:
Originally Posted by sickem View Post
ok, well GL keep us updated...that's weird.
Yea it's bizarre. Here's a thread I made about the issues a while back if you are bored and feel like reading through it

http://www.e90post.com/forums/showthread.php?t=833724
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: MHD w/ Wedge Flash, VRSF DP/FMIC, ER CP, Roc-Euro DCI, SteveAZ LPFP & more
More Pictures: Build Thread /// 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
Appreciate 0
      03-09-2015, 01:57 AM   #16
Sikh335xi
It's Karan Bitches
Sikh335xi's Avatar
United_States
0
Rep
51
Posts

Drives: 08 E90 335xi 6AT
Join Date: Jun 2013
Location: Brighton, CO

iTrader: (0)

Quote:
Originally Posted by GAM View Post
The answer is Yes, just changed it last weekend.
Front O2 sensor near the turbo and on the driver side

Upstream on the driver's side? Bank 1 Sensor 1?
Some are saying in front of the cat on bank 1... Maybe my terminology is just off.
__________________
JB4 G5 ISO|DCI|OBX DP's|NX WET SETUP|DUAL WALBRO 455's|BMS BACKEND E85
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 01:29 AM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST