E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Low Battery - Throwing All Sorts of Codes!



Reply
 
Thread Tools Search this Thread
      07-04-2013, 06:21 PM   #1
ChasVS
Colonel
ChasVS's Avatar
United_States
26
Rep
2,432
Posts

 
Drives: 2012 MB ML350 Bluetec
Join Date: Aug 2009
Location: Central FL

iTrader: (10)

Low Battery - Throwing All Sorts of Codes!

So I know my 2007 335 has an old battery and I've had to trickle charge it to keep if from going completely dead, but today when I started it, it had a slow crank like the battery was near dead but started right away. Immediately I had an Active Steering warning, followed shortly by a DSC failure warning and finally when I tried to set the cruise control I got a Cruise Control malfunction warning!!!

I figured this was all related to the battery dying so I drove it for awhile to charge up the battery a bit and then shut it off and restarted it. The battery was weak again, and it hardly turned the engine over but it did start and no malfunction warnings were displayed this time...

Anyone ever had this sort of experience?

Looks like a drive to the dealer for a new battery is in my future!
__________________
My speeding isn't the problem. It's the Slow Folks ahead of me that cause accidents!
Appreciate 0
      07-04-2013, 06:26 PM   #2
sovende96
(Sleeper96) gĺ Norge
sovende96's Avatar
United_States
6
Rep
390
Posts

 
Drives: 2007 e92 335i, 2010 e60 m5
Join Date: Mar 2013
Location: Greenwich, CT

iTrader: (1)

Ive experienced this. Bought a new battery, registered and installed it. Problem solved. How many miles does yours have?
__________________
SOLD 2007 e92 335i FBO minus meth/dp's --- 2010 e60 m5
Build Thread : http://www.e90post.com/forums/showthread.php?t=825542
Instagram : sovende96
100k Club!
Appreciate 0
      07-04-2013, 06:33 PM   #3
ChasVS
Colonel
ChasVS's Avatar
United_States
26
Rep
2,432
Posts

 
Drives: 2012 MB ML350 Bluetec
Join Date: Aug 2009
Location: Central FL

iTrader: (10)

A little over 59000 miles. How did you register the battery?
__________________
My speeding isn't the problem. It's the Slow Folks ahead of me that cause accidents!
Appreciate 0
      07-04-2013, 06:35 PM   #4
sovende96
(Sleeper96) gĺ Norge
sovende96's Avatar
United_States
6
Rep
390
Posts

 
Drives: 2007 e92 335i, 2010 e60 m5
Join Date: Mar 2013
Location: Greenwich, CT

iTrader: (1)

Quote:
Originally Posted by ChasVS
A little over 59000 miles. How did you register the battery?
Ok. My oem battery died at 105k lol. And took it to my local indy shop to get registered...
__________________
SOLD 2007 e92 335i FBO minus meth/dp's --- 2010 e60 m5
Build Thread : http://www.e90post.com/forums/showthread.php?t=825542
Instagram : sovende96
100k Club!
Appreciate 0
      07-04-2013, 06:45 PM   #5
ChasVS
Colonel
ChasVS's Avatar
United_States
26
Rep
2,432
Posts

 
Drives: 2012 MB ML350 Bluetec
Join Date: Aug 2009
Location: Central FL

iTrader: (10)

Thanks, mine is 6 yrs old even though it's low miles for that age, I live in Florida where the heat is rough on batteries.
__________________
My speeding isn't the problem. It's the Slow Folks ahead of me that cause accidents!
Appreciate 0
      07-04-2013, 06:49 PM   #6
Delusive
Lieutenant Colonel
Delusive's Avatar
United_States
27
Rep
1,502
Posts

 
Drives: Static E92
Join Date: May 2012
Location: Bay Area, CA

iTrader: (6)

Same happened to me last year, bought new battery and registered it myself now my car has been fine ever since
__________________
Appreciate 0
      07-04-2013, 06:55 PM   #7
sovende96
(Sleeper96) gĺ Norge
sovende96's Avatar
United_States
6
Rep
390
Posts

 
Drives: 2007 e92 335i, 2010 e60 m5
Join Date: Mar 2013
Location: Greenwich, CT

iTrader: (1)

Quote:
Originally Posted by ChasVS
Thanks, mine is 6 yrs old even though it's low miles for that age, I live in Florida where the heat is rough on batteries.
No problem. Also I diddn't replace it with the expensive oem battery. I forgot the brand name but the one I bought is 100amp/hr and was around 250$... DONT GO TO THE DEALER FOR A BATTERY... They quoted me 800$ which is ridiculous.
__________________
SOLD 2007 e92 335i FBO minus meth/dp's --- 2010 e60 m5
Build Thread : http://www.e90post.com/forums/showthread.php?t=825542
Instagram : sovende96
100k Club!
Appreciate 0
      07-05-2013, 09:49 PM   #8
ChasVS
Colonel
ChasVS's Avatar
United_States
26
Rep
2,432
Posts

 
Drives: 2012 MB ML350 Bluetec
Join Date: Aug 2009
Location: Central FL

iTrader: (10)

Quote:
Originally Posted by JS-NA.E92 View Post
Same happened to me last year, bought new battery and registered it myself now my car has been fine ever since
What's the registration process if you did it yourself? Would really like to save the money if possible!
__________________
My speeding isn't the problem. It's the Slow Folks ahead of me that cause accidents!
Appreciate 0
      07-06-2013, 12:17 AM   #9
Delusive
Lieutenant Colonel
Delusive's Avatar
United_States
27
Rep
1,502
Posts

 
Drives: Static E92
Join Date: May 2012
Location: Bay Area, CA

iTrader: (6)

Quote:
Originally Posted by sovende96 View Post
No problem. Also I diddn't replace it with the expensive oem battery. I forgot the brand name but the one I bought is 100amp/hr and was around 250$... DONT GO TO THE DEALER FOR A BATTERY... They quoted me 800$ which is ridiculous.
That's overpriced, I bought an OEM Battery from my local BMW dealership and it only cost me $220 total and I installed it myself

Quote:
Originally Posted by ChasVS View Post
What's the registration process if you did it yourself? Would really like to save the money if possible!
I borrowed my friends INPA Cable and used this program called BMW Logger that had a feature to register new batteries at a click of a button.
__________________
Appreciate 0
      07-06-2013, 11:44 AM   #10
ChasVS
Colonel
ChasVS's Avatar
United_States
26
Rep
2,432
Posts

 
Drives: 2012 MB ML350 Bluetec
Join Date: Aug 2009
Location: Central FL

iTrader: (10)

Quote:
Originally Posted by JS-NA.E92 View Post
I borrowed my friends INPA Cable and used this program called BMW Logger that had a feature to register new batteries at a click of a button.
wishing!
__________________
My speeding isn't the problem. It's the Slow Folks ahead of me that cause accidents!
Appreciate 0
      07-06-2013, 06:12 PM   #11
Garticus
A & P guy
Garticus's Avatar
0
Rep
64
Posts

 
Drives: BMW 330i
Join Date: Apr 2013
Location: Florida

iTrader: (1)

Garage List
06' BMW 330i  [0.00]
My car had a lot of weird "anomalies" that I thought were quirks.....then my battery died. Got it replaced and all of my quirks went away.


Replace your battery and save yourself any future headaches.
__________________
A&P Avionics Mech.
Appreciate 0
      07-06-2013, 08:30 PM   #12
ChasVS
Colonel
ChasVS's Avatar
United_States
26
Rep
2,432
Posts

 
Drives: 2012 MB ML350 Bluetec
Join Date: Aug 2009
Location: Central FL

iTrader: (10)

Scheduled for battery on Saturday!
__________________
My speeding isn't the problem. It's the Slow Folks ahead of me that cause accidents!
Appreciate 0
      07-19-2013, 09:18 PM   #13
roger911
Lebenskünstler
United_States
2
Rep
31
Posts

 
Drives: E92 335i, sparkling graphite
Join Date: Apr 2008
Location: Paso Robles, CA

iTrader: (0)

My 2008 335i E92 has been acting strangely. Occasionally, the comfort access won't work, and if this happens, the car's clock has also lost memory and needs to be reset. I wonder if the battery is starting to go, or if this might be related to the wiring harness recall that I had performed last month. I don't know what's causing this quirk, but it's really starting to get irritating. It seems like every time my car has been taken in for recall work, it's worse off than before.
Appreciate 0
      07-19-2013, 10:15 PM   #14
fazman
Lieutenant Colonel
United_States
23
Rep
1,809
Posts

 
Drives: 335 e90
Join Date: Feb 2011
Location: LI, NY

iTrader: (0)

Quote:
Originally Posted by roger911 View Post
My 2008 335i E92 has been acting strangely. Occasionally, the comfort access won't work, and if this happens, the car's clock has also lost memory and needs to be reset. I wonder if the battery is starting to go, or if this might be related to the wiring harness recall that I had performed last month. I don't know what's causing this quirk, but it's really starting to get irritating. It seems like every time my car has been taken in for recall work, it's worse off than before.
It could be a bad IBS cable or it could be the battery is about to fail. The car knows it doesn't have enough power for the next start so it starts to shut off any non critical consumers of power (like the clock memory/counter and many others). If you have never changed out your battery... That is probably the first place i would start with because at some point soon you will need a new one anyways. If that doesn't fix the issue it might be alternator or IBS cable.
Appreciate 0
      07-20-2013, 07:30 AM   #15
Bluesnake01
Private First Class
1
Rep
194
Posts

 
Drives: 09 335i Sedan, 6AT
Join Date: Aug 2012
Location: Los Angeles

iTrader: (1)

Quote:
Originally Posted by roger911 View Post
My 2008 335i E92 has been acting strangely. Occasionally, the comfort access won't work, and if this happens, the car's clock has also lost memory and needs to be reset. I wonder if the battery is starting to go, or if this might be related to the wiring harness recall that I had performed last month. I don't know what's causing this quirk, but it's really starting to get irritating. It seems like every time my car has been taken in for recall work, it's worse off than before.
More than likely the battery going out. Mine does the same thing, clock gets resetted or last car reading goes back to blank. Not often and sometimes I have a battery discharge warning. Also noticed my halo lights don't turn on when I lock the car or unlock it.
__________________
2009 BMW 335i Jet Black - BMS Dual Cones, GP Thunder 7500k Fog's, Hellst XRT H8 AE, JB4 G5 ISO Map 5 -
2001 Cobra True Blue - Terminator Swap, 460WHP -
Appreciate 0
      07-20-2013, 12:12 PM   #16
roger911
Lebenskünstler
United_States
2
Rep
31
Posts

 
Drives: E92 335i, sparkling graphite
Join Date: Apr 2008
Location: Paso Robles, CA

iTrader: (0)

Interesting. I thought it might be the battery too, but it has 12.25V after sitting all night.
Does anyone know the real story with the batteries for these cars? What's the replacement procedure? I've read of people having to "register" a new battery. What are they talking about? Does this car really need an outrageously expensive OEM BMW Battery or are there aftermarket batteries available from an independent BMW mechanic for much less?
Appreciate 0
      07-20-2013, 02:45 PM   #17
ctuna
Brigadier General
45
Rep
4,339
Posts

 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

FYI I got an interstate 49/h8 from my Indy

FYI I got an interstate 49/h8 from my Indy
Cost me about 240 installed and registered .
If you want a diagnostic and coding setup capable
of registering the battery and much more read the
sticky's in the coding sub board.

http://www.e90post.com/forums/forumdisplay.php?f=368

6 years is about average for a battery in these cars they demand
a lot of power in the standby mode.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:24 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST